KILVA

Sooo do any MX5 skins exist?

21 posts in this topic

Macaw thread was deleted. I hate looking at this pasty white browser. Any skins or tutorials on how to skin?

Share this post


Link to post
Share on other sites
9 minutes ago, BugSir006 said:

Hi KILVa, our designers and developers are working on themes and skins now. 

While currently, you can search on this board and find some brilliant skins made by Maxthon fans!

http://forum.maxthon.com/index.php?/forum/80-skin-extension/

Here is some useful information:

 

thats interesting news - if the internal people are working on skins it will be a first - from MX2 they have pushed nothing more that the stock skin - as to skins in the link you put up - i have not checked each post but the bulk of what was there has been deleted - there are skins on the Chinese forum - apart from that i dont think you will find many here

again i question what the devs are doing - is that wishful thinking - guesswork or a fact

Share this post


Link to post
Share on other sites

Sorry Tony for the misunderstanding. Let me clarify one point, we are not working on skins, we are designing themes. :wink:

7 minutes ago, Tony said:

what was there has been deleted

BTW, do you know who created and shared skins before and why they were deleted? 

But as I know, the self-made skins often cause some unexpected problems on the browser. 

Share this post


Link to post
Share on other sites

Let people achieve a more accomplished browser; MX5 is still in early dev. If you want skin before a good stuff can be released; that your point of view.

If someone is working on skins i'm happy for those who call for, though i don't bother.

Share this post


Link to post
Share on other sites
3 hours ago, BugSir006 said:

Sorry Tony for the misunderstanding. Let me clarify one point, we are not working on skins, we are designing themes. :wink:

BTW, do you know who created and shared skins before and why they were deleted? 

But as I know, the self-made skins often cause some unexpected problems on the browser. 

self made skins cause no problem if done correctly - i have been using one i designed through MX3 4 and 5 - others here would say the same - as to themes - well joe with 2 hats will be happy to hear that :titter:

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

The skin I used caused no problems. 

On 11/24/2016 at 4:28 AM, BugSir006 said:

Hi KILVa, our designers and developers are working on themes and skins now. 

While currently, you can search on this board and find some brilliant skins made by Maxthon fans!

http://forum.maxthon.com/index.php?/forum/80-skin-extension/

Here is some useful information:

@BugSir006,
I have already looked on this website. Perhaps I have missed it, but where are these brilliant MX5 skins you're talking about?
Please link me.

On 11/24/2016 at 5:54 AM, karajan said:

Let people achieve a more accomplished browser; MX5 is still in early dev. If you want skin before a good stuff can be released; that your point of view.

If someone is working on skins i'm happy for those who call for, though i don't bother.

@karajan I am quite aware that MX5 is in early dev, but believe it or not - in this beta phase, it is superior to other browsers that have more skin availability.

From what I could tell from the Macaw skin, it wasn't hard to update the skin files every beta update, as it was out within a few days of every update (likely longer than a day only because the skin creator wasn't totally invested in keeping it updated).

Thus, yes I want skins before the browser is finalized - why would I wait that terribly long? I know for a fact that MX5 is going to be tested much more before the final version is released. I'm not stopping them from achieving improvement - in this thread it even states that the devs are working on themes themselves. 

Not only am I not stopping them, they're doing it themselves! I was just wondering if there was a skin creator that could give me a tiny tutorial on which files I should edit with what in order to create my own skin--or even send me a few files already edited, and then tell me what I should do in order to make it compatible with all new versions.

On 11/24/2016 at 8:14 AM, Tony said:

self made skins cause no problem if done correctly - i have been using one i designed through MX3 4 and 5 - others here would say the same - as to themes - well joe with 2 hats will be happy to hear that :titter:

@Tony: in mentioning that you have designed a skin, would you mind telling me how I should edit 0.dat and 1.dat and whatever else in order to change my own colors?
Thank you all for your responses.

Edited by KILVA
fixing my post, it was all put into the first quote for some reason.

Share this post


Link to post
Share on other sites

Does anyone still have downloaded copies of the mx 5 skins or a link to them somewhere.  The current 5.02.3000 default skin is butt ugly.  Some may like it...not me.  

I get the generic skin, but it would be nice if we had the option, like in 4.9, to colorize it, either with our own pics or from a color palate.

Share this post


Link to post
Share on other sites

Thanks.  Can I assume that those taged with 3000 are for 5.0.2.300?

Share this post


Link to post
Share on other sites

Posted (edited)

1 hour ago, soaringeagle said:

Can I assume that those taged with 3000 are for 5.0.2.300?

No, described as 3000 are for 5.0.1.3000 version. To newer versions Mx there no skins.

Edited by Galileusz

Share this post


Link to post
Share on other sites

I figured it out.  It's the stable version.  5.0.2 is a beta.  Thanks again for the skins.  

Share this post


Link to post
Share on other sites

So I can use those included skins? Can I update them myself to work with new versions... somehow?

Share this post


Link to post
Share on other sites
1 hour ago, KILVA said:

So I can use those included skins? Can I update them myself to work with new versions... somehow?

They don't work with current versions, but if you want to modify them to work with your version, go right ahead.

Share this post


Link to post
Share on other sites

Posted (edited)

On 2017-01-23 at 4:32 PM, No.1MaxthonFan said:

They don't work with current versions, but if you want to modify them to work with your version, go right ahead.

That's exactly what I've been asking how to do for two full months now.

On 2016-11-24 at 11:23 PM, KILVA said:

Any skins or tutorials on how to skin?

 

On 2016-11-28 at 6:16 PM, KILVA said:

I was just wondering if there was a skin creator that could give me a tiny tutorial on which files I should edit with what in order to create my own skin--or even send me a few files already edited, and then tell me what I should do in order to make it compatible with all new versions.

@Tony: in mentioning that you have designed a skin, would you mind telling me how I should edit 0.dat and 1.dat and whatever else in order to change my own colors?
Thank you all for your responses.

 

Edited by KILVA

Share this post


Link to post
Share on other sites

there is or was some help files on modding skins - have a search - you have to unpack the dat 0 and 1 files using the packers that are on here - once you have them unpacked you have a series of css and htm files for various elements of the skin - depending on your knowledge and ambition its all in there

packer is here

 

Share this post


Link to post
Share on other sites

Posted (edited)

8 minutes ago, Tony said:

there is or was some help files on modding skins - have a search - you have to unpack the dat 0 and 1 files using the packers that are on here - once you have them unpacked you have a series of css and htm files for various elements of the skin - depending on your knowledge and ambition its all in there

Well I'm sure I could figure it out, however it can't be that simple. Yeah, CSS and HTM stuff to edit, but there must be some file I need to change in order to make it compatible with other versions.

Could somebody tell me what that is or am I expected to figure that out myself?

Edited by KILVA

Share this post


Link to post
Share on other sites
5 minutes ago, KILVA said:

Well I'm sure I could figure it out, however it can't be that simple. Yeah, CSS and HTM stuff to edit, but there must be some file I need to change in order to make it compatible with other versions.

Could somebody tell me what that is or should I just give up?

not sure what you are asking - the newer versions use the same method - the dat 0 and 1 files have benm renamed - 7twenty posted that earlier - old skins may or may not work fully once the files have been renamed - if thats all you want then wiltsers skins may work

 

Share this post


Link to post
Share on other sites
1 hour ago, KILVA said:

however it can't be that simple. Yeah, CSS and HTM stuff to edit, but there must be some file I need to change in order to make it compatible with other versions.

Could somebody tell me what that is or am I expected to figure that out myself?

Why can't it be that simple? Many versions don't change anything, or just minor things like a text placeholder etc. Others completely change the code for UI elements. Just looking back at my current 4.9 skin to the 5.x skins, while things look similar on the outside, there's been quite a few changes of code behind the scenes. And in whichever version they change the names of the files, hopefully related to the talk of a proper skin system being put back in place.

So it's hard to say what exactly needs to be changed, as it's not a case of changing a line that says "version=5.0.1" to "version=5.0.2" to make it compatible.

It really does depend on what was changed. It might be just a text string placeholder, where you'll get the placeholder instead of the actual text. It might be a link to something outside of the HTML files which was moved/changed, in which case just renaming the files won't work, and you need to rewrite/update the code to allow for that.

Share this post


Link to post
Share on other sites

Posted (edited)

On 2017-01-26 at 5:47 PM, 7twenty said:

Why can't it be that simple? Many versions don't change anything, or just minor things like a text placeholder etc. Others completely change the code for UI elements. Just looking back at my current 4.9 skin to the 5.x skins, while things look similar on the outside, there's been quite a few changes of code behind the scenes. And in whichever version they change the names of the files, hopefully related to the talk of a proper skin system being put back in place.

So it's hard to say what exactly needs to be changed, as it's not a case of changing a line that says "version=5.0.1" to "version=5.0.2" to make it compatible.

It really does depend on what was changed. It might be just a text string placeholder, where you'll get the placeholder instead of the actual text. It might be a link to something outside of the HTML files which was moved/changed, in which case just renaming the files won't work, and you need to rewrite/update the code to allow for that.

I dunno, you answered your own question within your post. 


Q: Why can't it be that simple?
A: it's hard to say what exactly needs to be changed, as it's not a case of changing a line that says "version=5.0.1" to "version=5.0.2" to make it compatible. It really does depend on what was changed.

On top of not knowing what I need to change if it did need to be changed, even if I did know, say it was an addition to the 'settings' menu. How does that help me with figuring out what to change and how does that affect the skin? Are you saying that if the version update isn't going to affect the UI in any way, the skin should work?

The UI is the only thing I can imagine that could get in the way of a modification, if renaming didn't work.

On 2017-01-26 at 5:21 PM, Tony said:

not sure what you are asking - the newer versions use the same method - the dat 0 and 1 files have benm renamed - 7twenty posted that earlier - old skins may or may not work fully once the files have been renamed - if thats all you want then wiltsers skins may work

 

Tony, I know that they have been renamed, but I wasn't aware just renaming the files is all that needs to be done because I tried it and failed a few times in the past.

But, thank you for the help, I got one to work. 

Edited by KILVA

Share this post


Link to post
Share on other sites