×

Give a tip

No.1MaxthonFan

MX Master
  • Posts

    2,971
  • Joined

  • Last visited

  • Days Won

    63

 Content Type 

Profiles

Forums

Release Notes

Bug Tracker

Help page

Help page-CN

Release Note5

Rules and recruitment

Release Note6

Everything posted by No.1MaxthonFan

  1. It must be where you are located. I can watch HBO Max without any problem. I'm in the United States.
  2. You posted this before and I tested and, on my system, Maxthon 6.1.3.2900, it remembers size and position on my 34" monitor.
  3. Yes, good heavens, I just barely click the link and it was done, didn't even show me the download speed. 😁
  4. Well apparently I'm doing something wrong because I can change to any search engine in the list, close Maxthon, re-open Maxthon and it stays to what I have changed it to. I'm on 6.1.3.2900 on Windows 11 Insider build 25126
  5. Not bad here, anywhere from 95Mbps to 138Mbps on all 4 downloads.
  6. Doesn't seem to be a problem here.
  7. I just logged in and it is working for me. I'm in the U.S.A.
  8. It's additional work, but you could save it to your desktop and then check the properties. It appears that Vivaldi is the only one who still has it. Firefox doesn't have it either.
  9. I watch HBO Max without any problem. I'm in the USA, maybe that could be the problem?
  10. Sorry, well I hope BugSir006 sees your messages and gets back to you.
  11. Ok, then click on name and go directly to their page and see if it's there.
  12. Hover over BugSir006's name and click on Message
  13. And I haven't had any crashes in any version since I can't even remember when. And I wish I could help everyone who is having problems.
  14. When I click on it, it takes me to my original post with the screenshot.
  15. HBO Max is working fine for me. I'm watching Dune now.
  16. Ok, I think this is where they run into a problem. Your above statement may ONLY be most important for YOU, but how important is it for the other millions of users? I cannot visualize them customizing a browser for one user. I may be wrong and if I am, I will apologize. Just my opinion, so please don't misjudge me. Was just there and played a few hands and it was working just fine, but then I'm on a GIG speed tier.
  17. Go to the Google Web Store and add them from there. https://chrome.google.com/webstore/category/extensions
  18. I just use F10 instead of looking for an icon to click on, but that's me.
  19. Well, they only have 3 months to figure it out, so we will see.
  20. This is what I get on Chrome and Edge but I have no idea what it says. LOL
  21. Worked just fine for me also with 6.1.3.2000
  22. Not having any problem either yesterday or today. All pages load just time for me.