Chim

pc issue Invalid Certificates on MX5

42 posts in this topic

Why am I intermittently getting Invalid Certificate messages when accessing gmail via the official gmail button on the Speed Dial that came with MX5?  I sure hope that's not gonna be the norm.  That would get me seeing red here soon.

Then MX5 will give me one of those same Invalid Certificate messages when trying to access https://vivaldi.net/en-US/ while my Maxthon Cloud Portable 4.9.4.2000 and my Opera 36.0.2130.65 WILL bring up the Vivaldi site.  Could it be that MX5 is purposely blocking the Vivaldi site because it is a competitor?

Invalid Certificate.jpg

Share this post


Link to post
Share on other sites

I think it's just an intermittent bug, I kept seeing it in Gmail a while ago. It doesn't happen for me now, it didn't in your Vivaldi link either.

Share this post


Link to post
Share on other sites

Maxthon has no interest in blocking Vivaldi. 

Not knowing which version you are using, I would suggest the latest M5 release.

Share this post


Link to post
Share on other sites

I am using the absolute latest version of MX5 --- 5.1.2.3000.

Jussst in case it could possibly make a difference, I am using Windows XP SP3 Pro.  I have avast 12.3.2280.  I use NetZero Dial Up.  Despite all those, though, I wasn't experiencing this issue with Maxthon Cloud 4.9.4.2000 and Opera.

Yeah, just like yesterday ... today I again still encountered the Invalid Certificate way more often than not with gmail.  This while not having a problem with Opera.  And I'm talking a VERY old Opera --- 36.0.2130.65.

And as for the Vivaldi experiment?  Wooooo, that one is worse.  My MX5 will not bring up the Vivaldi Blog, Vivaldi Forums or Vivaldi Community anytime.  Those 3 aren't even a case of sometimes.  I get the Invalid Certificate message with those 3 ALL of the time with MX5.  Again, while not having a problem with Opera.

This seems to me more like a bug rather than just a glitch.  Hopefully it can be fixed very soon.  I sure don't want to be forced to have to get used to clicking on "Continue" at the Invalid Certificate message ... or to have to bring up Opera every time I have to check my gmail.

Share this post


Link to post
Share on other sites

Posted (edited)

Because you are having issues does not mean it is a bug, not that xpsp3 is the most relevant OS in existence, I'm on win10. 

Edit: You might try disabling or modifying your proxy settings. 

viv.png

Edited by joemax

Share this post


Link to post
Share on other sites

Same here, I have no problem at all with any of the Vivaldi pages using 5.1.2.3000 on Windows 10 build 16299.15

Share this post


Link to post
Share on other sites

Posted (edited)

Hmmm ... Odd.  Unfortunately this is probably pointing towards it being a compatibility issue with Windows XP.  And that means it's not likely to get fixed.  Doh!

On the bright side, as of this morning, on my 3rd day of using MX5 ... accessing my Gmail with my MX5 is working fine --- so far.  I've done several takes and I haven't encountered the dreaded Invalid Certificate message yet.  I don't know if it'll suddenly start making some cameos later in the day, but for now I'm good.

The accessing Vivaldi issue is still solidly there, but ehhhhh, that one is not a big issue, not a deal breaker at this time anyway given that as long as I have Windows XP, I cannot use Vivaldi anyway.  It's just that I happened to have those links in my bookmarks and in testing them and having them fail with my MX5 and not with Opera and Maxthon Cloud 4, I figured it indicated an issue that Maxthon might want to look into.

Oh well.  As long as my Gmail keeps working, I'll be satisfied.  Thanks, DaveMax, joemax, No.1MaxthonFan. :5884970a7da3a_1:

Edited by Chim
1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

XP doesn't support chrome 50 and above. MX5 is chrome 55. Update your OS.

Edited by Magdalene
1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

I already knew about the Chrome having kicked support for XP to the curb at that certain point in the past.  That's why I had switched to Maxthon Cloud after enjoying several years of Opera as my browser of choice until Opera 36.0.2130.65 became the WALL of no more support for XP after that.

However, while Maxthon Cloud 4 has been cool with my XP ... what I didn't know was what was going on under the hood of MX5.  I somehow assumed :Grinmacing_Face_Emoji_42x42:   that MX5 would also somehow be fully-compatible with and fully-support XP.  So thanks for the heads up regarding what's going on under the hood of MX5, Magdalene.

At least Maxthon allows us XP users to download MX5 and test drive it and decide for ourselves whether it's compatible enough for our uses with our XP.  This unlike how Opera and Vivaldi won't even allow you to install the newer versions if Windows XP is detected.

I'll continue evaluating MX5 and monitoring the situation in general with MX5 in my XP.  If at some point some compatibility issue makes me start pulling my hair out, I can always go back to 4.9.4.2000.

It now makes perfect sense why my Opera 36.0.2130.65 just happened to have no trouble bringing up those Vivaldi pages.  It's that Opera 36.0.2130.65 was the last Opera version that still supported XP.

Edited by Chim

Share this post


Link to post
Share on other sites

I tried 4.9.5.1000, Magdalene.  However, it had an issue that I didn't like.  And it was another one of those issues that appeared to be Windows XP compatibility-related.  You know ... as in not likely to get fixed.  I brought the issue up here on the forums.  It had to do with the displaying of the entire page now being off by I believe 2 or so pixels vs. the LOOK on 4.9.4.2000.  Like a very minute, micro zooming action was incorporated in the displaying of the page.  As micro as it was, though, it was enough to throw off certain things ... like how many Favorites were now displayed in my Favorites Bar vs. on 4.9.4.2000 for starters.  And I believe it was chopping off a 1 pixel height bit off the very top of the tabs --- as in the top outline / border of the tabs.

I believe it was 7twenty who confirmed that he could duplicate the issue when he used Windows XP.

Given that 4.9.5.1000 was supposed to be an official update to 4.9.4.2000, in my opinion, the issue was significant enough that it should have been fixed ... otherwise, that would make 4.9.5.1000 inferior / defective compared to 4.9.4.2000.  But, I didn't kid myself.  I faced reality.  I knew that with Maxthon Cloud 4 being way in the backburner now that MX5 is around, the issue was not likely remotely going to be fixed.  So, I just went back down to 4.9.4.2000.

 

Share this post


Link to post
Share on other sites

Posted (edited)

This is not just a XP problem... I having the same exact popup when using google.co.uk or even Maps.google.co.uk

I am running Windows 10 (1703) + all updates. and MX 5.1.2.3000

tested with V4.9.5.1000 and i dont get the error below.

 

snap_screen_20171006202958.png

Edited by Brunes

Share this post


Link to post
Share on other sites

Did you confirm with other browsers that they didn't exhibit that problem and that it was only MX5 with the problem, Brunes?

As of last night, I finally waved the white flag and cried uncle.  Yeah, I ripped MX5 out and went back down to 4.9.4.2000.  I was downloading some apps at PortableApps.com.  On some of them, the image for the green download button just didn't want to display no matter what I tried.  I even tried individually opening the images in another tab so that the data would then be in the cache.  But, nope.  Trying that just threw up yet another Invalid Certificate message.  And with those green download button images not being able to be displayed, I of course could not download the apps.

I concluded that that Invalid Certificate Fest was not going to stop as long as I kept using MX5 with Windows XP.  So I declared my MX5 experiment DONE for now.

Share this post


Link to post
Share on other sites

@Chim yes other browsers do NOT show any certificate errors.. (Edge, IE, Chrome and MX4)

In MX5 if i switch back to IE mode then it works, so it only in MX browser enginee..

so far it only on google pages... i dont get this error on the Vivaldi page, and Facebook is fine etc.

Share this post


Link to post
Share on other sites

We'll see if some of the other members here can confirm / duplicate the issue you're experiencing, Brunes.  I can't do it myself since I no longer have MX5 installed.

You might have to just resign yourself to using Retro mode for those Google pages.

Heck, frankly I was surprised, borderline shocked the other day when if I interpreted the info in the Menu window correctly ... ALL of the websites that I use were being displayed in Retro mode.  I would have thought that if most websites supposedly try to stay up to date with technology ... MX5 would have been displaying most if not all of them in Ultra mode.

Who knows.  Maybe I have an incorrect understanding of how the dual engine system in MX5 works.  My understanding is that it is supposed to be automatic and that if it is a website with up to date technology --- MX5 will display it using Ultra mode ... unless the User forces it to use Retro mode.  If it is a website using older technology, MX5 will display it in Retro mode.  Can anyone confirm whether my understanding is incorrect so that I can update my thinking on how the dual engine system in MX5 works?

Share this post


Link to post
Share on other sites

Mx5 does display most pages using ultra mode until you last close that site after changing to retro mode. Mx5 remembers whatever mode a site was last closed in. MX5 can also be forced to only use ultra mode(settings > advanced > browsing > Always use Ultra Mode (Some websites might be displayed incorrectly)). You can't force it to use only retro.

I have no issues with certificates on Google.com. but I do have the certificate issue on google.co.uk but I don't frequent it either. I have had issues on google.com in the past after cleaning cookies. This might be an issue you are having too.

Share this post


Link to post
Share on other sites
8 hours ago, Chim said:

My understanding is that it is supposed to be automatic and that if it is a website with up to date technology --- MX5 will display it using Ultra mode ..

Ultra is used by default on all sites. As joemax said, the only time Retro mode is used is if the user selects it - it can't be set to default.

MX does change it automatically if the option is enabled in settings (search for Enable Switch browser core). I'm guessing it checks all URLs against a list of known sites that have issues with Ultra mode. To my knowledge this list is manually curated, eg. someone complains on the forum then a dev adds it to the Retro mode list.

Share this post


Link to post
Share on other sites

Posted (edited)

Okay, help me understand this more.  In my case, as far as Browsing settings, I have checked the Enable standard rendering in Retro Mode setting.  I do NOT have the Always use Ultra Mode setting checked.  If Ultra mode is used by default on all sites, why do I see the Switch browser core: Ultra -> Retro indication on ALL sites as per the attached image?  Shouldn't I be seeing Retro -> Ultra?  Or am I misinterpreting which one means Retro and which one means Ultra?

Oh, and interestingly enough, just for the heck of it, while on THIS site, I clicked to change the setting to Retro -> Ultra ... and the Reply Box to this thread didn't want to work.  A micro-dotted outline would appear around the collapsed Reply Box and nothing else would happen after that.  So, I switched it back to Ultra -> Retro.  (This is on Maxthon 4.9.4.2000.)

Ultra - Retro.jpg

Edited by Chim

Share this post


Link to post
Share on other sites

Posted (edited)

You are seeing Ultra to Retro because you are in Ultra mode. You can activate the switch core button from the view menu to better see which mode you are in. Click the button to switch mode.

retrol.png

Edited by joemax
1 person likes this

Share this post


Link to post
Share on other sites
2 hours ago, Chim said:

Okay, help me understand this more.  In my case, as far as Browsing settings, I have checked the Enable standard rendering in Retro Mode setting. 

This only affects Retro mode when it is activated. It forces using the most recent version installed of the IE engine instead of the compatibility version (circa IE8).

Quote

I do NOT have the Always use Ultra Mode setting checked. 

 

Doesn't matter. Ultra will always be used by default unless Retro has been selected by you at some stage and not changed back before you closed the tab.

I have't tested how that option works, but i'm guessing you can still use Retro as required (as shown in your image) but the setting will not save for the next time you visit the site. I'd imagine that the auto core switching would be disabled as well.

Quote

If Ultra mode is used by default on all sites, why do I see the Switch browser core: Ultra -> Retro indication on ALL sites as per the attached image?  Shouldn't I be seeing Retro -> Ultra?  Or am I misinterpreting which one means Retro and which one means Ultra?

You're misinterpreting something.

The 1st part (Ultra) shows what mode you are currently using
The 2nd part (->) shows there's going to be a change
The 3rd part (Retro) shows what mode will be changed to if the button/option is pressed

Quote

Oh, and interestingly enough, just for the heck of it, while on THIS site, I clicked to change the setting to Retro -> Ultra ... and the Reply Box to this thread didn't want to work.  A micro-dotted outline would appear around the collapsed Reply Box and nothing else would happen after that.  So, I switched it back to Ultra -> Retro.  (This is on Maxthon 4.9.4.2000.)

Some of that doesn't make sense, but here's my deduction:

Sounds like you were using Retro mode (so using the IE core) and because you're on XP, chances are you're using IE1, so enabling the standard mode isn't going to do anything.

Changing to Ultra means you're using a somewhat recent blink core of which almost all sites should work on. This one included.

1 person likes this

Share this post


Link to post
Share on other sites

regarding the certificate issue. I read on another browser forum that at least one user had the same issue. So it's not only related to Maxthon, but again, as far as tracking down the actual cause, that's something the dev's need to work on.

It's also not XP related, as the previous few weeks had many users over multiple OS's having the same problem.

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

Ahhh, now I get it.  You cleared things up, 7twenty.  Yes, apparently I was misinterpreting the 2 modes completely backwards as to which one was active at any given time by the indication in the menu.  So I do see now that all my websites ARE being displayed in Ultra mode contrary to what I previously thought.  

@Joemax --- Hey, Joe, that Lightning Bolt Ultra Mode-indicating icon bit is an excellent piece of info.  No mistaking things now with that in my face indication. :titter:

@7twenty --- Regarding my explanation regarding the micro-dotted outline Reply Box not entirely making sense?  I have attached an image to show what I meant.  As you can see, upon having switched to Retro Mode ... when I would place my cursor inside the Reply Box, it would not expand to show all the text attributes and stuff.  It would just get a dotted outline and nothing else would happen.

That additional info regarding the Invalid Certificate issue is good to know, 7twenty.  If that gets ironed out by the Devs, hopefully I can return back to MX5 even with Windows XP.

Thanks, JoeMax ... 7twenty!  That was a pretty good, very useful batch of information.:5884970a7da3a_1: 

Dot Outlined Reply Box.jpg

Edited by Chim
1 person likes this

Share this post


Link to post
Share on other sites

so did some testing and tested all previous versions and the last good version that did not give me a error was 5.1.1.100-beta, it then broke in each version after this one, so 5.1.1.200-beta onwards.

 

1 person likes this

Share this post


Link to post
Share on other sites

Interesting test results, Brunes.  It'd be great if the Maxthon Devs get that data.  Of course, like you, I too am just a Freshman around here.  I don't know how to go about ensuring that the Devs get data like that.

Then again, you might try sending it via Menu > Help > Send feedback

Reference this thread along with the findings of your testing.

1 person likes this

Share this post


Link to post
Share on other sites
On 10/5/2017 at 1:29 AM, joemax said:

Because you are having issues does not mean it is a bug, not that xpsp3 is the most relevant OS in existence, I'm on win10. 

Edit: You might try disabling or modifying your proxy settings. 

 

Well after visiting google.co.uk, every time I go to mail I am now seeing the certificate issue. But I'm quite sure it will eventually fix itself(???).

Share this post


Link to post
Share on other sites

I had the certificate issue on Gmail and some other Google-related websites about a month ago, and they were gone after a week or two.

Now it's back again.

How could it be?

Share this post


Link to post
Share on other sites

my work PC was running same version as at home, but was working fine.. but today it too as now moaning about the certificate.. so i know it nothing to do with my home PC and something that MX is not picking up when reading the certificate date.. even though it defo not expired.

Share this post


Link to post
Share on other sites

Getting same invalid certificates notifications as other people today. It was fine yesterday. 

Share this post


Link to post
Share on other sites

Seeing as google is probably one of the biggest names on the internet, you'd hope they get this sorted out. Way to many sites using google related links that may potentially get this error for it to be ignored.

Everytime an MX user sees this and gets scared off there's the possibility of them jumping to any other browser that doesn't have the issue..

Share this post


Link to post
Share on other sites

I am also experiencing the same issue with invalid certificates on google sites (not youtube). MX 5.1.2.3000 on Win8.1. Problem appeared a few days ago.

Share this post


Link to post
Share on other sites