Problem with Noads Menu


Recommended Posts

it works for me but i never run anything as is - but i have seen what you describe before - i fixed it by running an earlier version of maxthon that worked


- go to noads config and copy settings

- close old version of maxthon

- open new version and go to noads config

- delete any content - even if same as from other version

- paste other content and save

what that does i have no idea but it got it working - maybe it links it to the new version

Link to post
Share on other sites

Thanks Tony...

I'll try anything :)

I moved everything Maxthon from C to E: drive to share the wear a little (I head a couple of clacks on c.... never good to hear.

Of course, everything is screwed up now. :funk:

I'll give it a try

Link to post
Share on other sites

golfmann replied at 2013-4-6 19:11 back.gif

I won't download or save anything for me and if I use the click on blocking it freezes up.

XP strik ...

Which version of Maxthon are you using please?You might need to try the NoAds with the latest Maxthon cloud browser.It works fine for me!

Link to post
Share on other sites

noads is choosy - it works on all versions of maxthon that i have tried but its somehow tied to the version its installed on - some ini file i guess - if you over install it usually works but if you install a new version of maxthon to a new dir its hit and miss - the config file will still be there but it needs pointing to the new version of maxthon

Link to post
Share on other sites

The popup html with keyboard shortcuts defined/listed/explained, does not function as buttons. It's simply an explanation of the shortcuts available. Shortcuts are necessary to block, unless you go into noads config for that page and add something manually, but even then, it requires shortcuts to open the config page.

As for the ini file, no it's not tied to the specific version of Mx. It simply outlines the rules you have set-up. It's in the user folder, in addonsdata, in the folder named after its GUID number.

Link to post
Share on other sites

The popup html with keyboard shortcuts defined/listed/explained, does not function as buttons.

then i have a different version to you - or maybe you are wrong - if i click on a shortcut it acts as a button

Link to post
Share on other sites

:):D:) Let's put it this way: the only time I've ever tried using the html file popup as possible buttons had been in mx3 with, at the time, a bugged rightinbox extension. That is now fixed, but since then I have removed the html file since I don't use it, and since mx4 has come out, and even before then, I have NEVER used the html even if it WERE there.

Sync synchronizes extensions by GUID not file, so the html file would have been there before I had recently gotten rid of sync ALSO in mx4.

:D :$ :p:D

Link to post
Share on other sites

thats fair enough - but when giving advice its better to add that you have modded the original otherwise it can become a fact

so to be clear - the html does not work as buttons for you - others may get a different result

as the recognised tester of maxthon people will accept your word - in this instance it was wrong

Link to post
Share on other sites

Didn't know it at the time. Seemed like probable hypothesis.

Everything has a chance of being wrong. All are fallible.

I'm STILL not even sure it's the case: mostly speculation.

You have my apologies.

also wasn't a mod that caused it. It was another extension that originally ran on all pages, with a jquery script that broke stuff. The removal of the html file simply was AFTER I had the notion it didn't do it. Still having doubts somewhat that it's caused it, because locally-defined scripts don't run on sidebar or toolbar panels. Still, as said, speculation. PROBABLE speculation, yes, but NOT definite.

Either way, the REST stands as fact: the ini isn't defined to one version of Mx, therefore no inconsistencies. And it still works finely for myself. And, yes, the ini is in the path explained.

Link to post
Share on other sites

BugSir007 replied at 2013-4-7 01:21 back.gif

Which version of Maxthon are you using please?You might need to try the NoAds with the latest Maxt ...

I have the latest version, of course.... :)

(unless there happens to be rebuilds within a release. I often wonder when I get a new quick launch page message)

I tried everything I could think of... lol

I WILL say though, since we can "inspect" elements (and all the work that went into that feature) why can't we BLOCK elements by click some day in our OWN ad hunter :handshake

Link to post
Share on other sites

I know that of course in ad hunter. I have been using Maxthon since the beginning, Well 2002 anyway...

adhunter will NOT block the add elements in facebook, which is WHY I went with noads in the 1st place... :)

I just tried removing noads from the application data and re downloading it.

still locks up for me when I try to click on the add element in facebook.

I gave it a good attempt but alas.....


Thanks for your trying to help and thanks for the info on the inspector. Interesting.

I guess it doesn't add much to the browser overhead as I don't use it and could live without it. :@

Link to post
Share on other sites

some elements make it freeze up. Sometimes, I find it useful to...well use the shortcut, the popup dialog box shows the element rule that will be added. Then ctrl+c and then go to noads config by way of shortcut, and ctrl+v into the site-specific USER css rules, with a comma before it, no space though. Then save, and it should apply automatically/immediately without a need for a refresh.

I have yet to find a cause. For now, I will try to figure out the cause.

I constantly clean up addonsdata stuff, so it's not necessarily an issue there.

And no problem.

And also you might want to know that removing the extension does NOT remove the addonsdata folder assigned to its GUID. That stays behind. Kind of like any uninstallation without an advanced one (everyone probably knows what I use, at least from the old forum, and from my rants). It takes manual spring-cleaning to remove a lot of it.

Which is why I always do so in everything I remove, after the fact, even WITH a proggy that adds to the efficiency of the auto-job.

Link to post
Share on other sites

I of course tried that too but it won't SAVE anything either.

I said also that I removed the GUID in my app data.

anyway, thanks for your help and yes the sidebar box acts as a link in mine (though cut off), but that's ALL I get,,, lol


why it won't download or save manually is a java thing but ta heck with it for now!

Link to post
Share on other sites


This topic is now archived and is closed to further replies.