Google Sheets unusable -- stuck in reload !!

Recommended Posts

Google Sheets is unusable as of today for me. Every spreadsheet I try to open gets locked into a "reload" cycle, with the following errors appearing while trying to access any spreadsheet:

A server error occured. Please press 'Reload' in your browser.
Unable to load file. Try to load it again or send an error report.
Something went wrong. Please Reload.

This seems to only happen in Maxthon, since I did not encounter this issue with a few other browsers.

I was using MX I tried updating to MX v4.9.5.1000 but that did not help.
I tried clearing browsing data, and reseting cache under advanced settings. I also tried a new UserAgent string to no avail.


There is a related issue with Google Sheets home screen, where that page is also getting stuck into a "reload" cycle, with the following errors:

Home screen is temporarily unavailable.
Try to load it again or send an error report.

I started enountering this issue about a week ago but I never reported it since the page was still usable for a few seconds before the forced reload message appeared, which was long enough for me to choose a spreadsheet.

I cannot use Maxthon for the time being due to this bug as I work on spreadsheets all the time :(

Link to comment
Share on other sites

2 hours ago, Atavus said:

Unable to load file. Try to load it again or send an error report.

Hi there, Thanks for reporting and sorry for the inconvenience.

I've tried Google Sheets and Google Docs on, sheets have no problem, while docs got the same pop-up info "reload" as you described. 


I'll let our tester have a check on the issue on Docs, I assume they may be caused by the same issue.

Please also try them again sometime else to help exclude the internet factor. 

Please also tell me if the issue also happens to you on Google Docs.

BTW, we recommend you to upgrade your browser to Maxthon5, this is the latest and brand new Maxthon version, which is under a continuous upgrading lately. So issues on Maxthon5 will be fixed more quickly than Maxthon4. 

Link to comment
Share on other sites

Ty for your reply.

I am having this issue everywhere: in both Google Docs and Google Sheets home screens, and when I open any documents or spreadsheets.

As I described earlier, the issue in the home screens started happening about a week ago, and in documents and spreadsheets just today.

Here are some screenshots:




Btw my internet is fine, and everything works fine with other browsers.


As for Mx5, I have not made that transition yet as Mx4 is so familiar to me.
Can you plz test if this bug is happening on MX5? If it isn't I may just switch over :)

Link to comment
Share on other sites

Hi there, I've forward this issue to our testers, they'll identify and our developers will deal with it soon. :Smiling_Face_Emoji_with_Blushed_Cheeks_42x42:


Seems have been fixed on the internal test build, the new core one. So please stay tuned for our future release.

On 6/7/2017 at 11:52 AM, 7twenty said:

Same errors in

Hi Rob, could you help test this issue on the latest internal build? I've tried it with no issue.

Link to comment
Share on other sites

1 hour ago, vedicaudio said:

just installed

Google sheets is totally unusable. This is of tremendous importance to me as a Maxthon user. I only mention this because I know that Maxthon devs are more interested in fixing issues with lots of "votes." So here is my vote.

Please try version beta version and in next official release, there should be no problem about this issue.

Link to comment
Share on other sites


Just a quick note.

As of yesterday, it seems all issues with Google Sheets and Docs have been resolved, both home screens and files.
I am still using MX, the same one that was having issues before, but I assume Google Devs themselves changed or fixed something on their end?

I hope this does not happen again in the future as I am too attached to my Maxthon :p

Thanks again :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.