Archived

This topic is now archived and is closed to further replies.

Rei-kashi

Maxthon Extension Center lags

Recommended Posts

Dear Community,

I think I don't get it. Since a few weeks I've problems when trying to view the Extension Page for Maxthon.- I use Maxthon 4 Cloudbrowser.

I've tried to adjust the settings, even checked my files. But, that's irrelevant as all other pages do not behave this way. Anyone has an idea why the page's lagging?

One more thing. Trying to comment an extension, the browser simply doubleposts my posts- sometimes there are even 5-10 identical posts... Yep, I only click "Comment" once.

Duh! >.<

Share this post


Link to post
Share on other sites

Saibagami replied at 2013-5-11 21:32 back.gif

Could you be more specific?

Laconic/terse statements do provide any useful infos.

Do you mean, tha ...

lagging yes it happens to everybody

double posting didn't happen to me yet, maybe because I have all extensions I need..

all I can say is that usually this things happen when a server is busy or has an issue.. I can't be more specific sorry

sigmax.png

Share this post


Link to post
Share on other sites

I see.

I needed an Ad-hunter. Unfortunately I couldn't find no one. >.<

Well, if the Ad-center lags for everyone, this topic is solved!

Share this post


Link to post
Share on other sites

it's because the extension site's server is hosted in Beijing, China, so depending on where you live, it might be slow.

Share this post


Link to post
Share on other sites

O c'mon, I am currently residing in the EU, daily accessing my Japanese websites as like my e-mail account whose serves are located in Japan. No problems(ping etc).

Most probably Maxthon's servers are bad.

Share this post


Link to post
Share on other sites

Saibagami replied at 2013-5-12 17:42 back.gif

O c'mon, I am currently residing in the EU, daily accessing my Japanese websites as like my e-mail a ...

O c'mon. Makes no difference where you are. Servers have different loads at different times of the day and you probably hit it at a high load time. Either that or the servers can't handle the same amount of traffic you Japanese mail servers can.

Share this post


Link to post
Share on other sites

I am sure that the second statement's right.

A priori, I am online for more then 15 hours a day. There's a time difference between Europe-Asia-USA and I view all my sites when the traffic's high/ when the traffic's low. Servers are most probably just laggy for Maxthon. When I am not the only one, reporting it, it means that Comsenz's servers just cannot handle that much. I use Maxthon from "home"and many other abroad-locations. The problem appears to be there, no matter the location. Therefore it is only natural, that I'd like to enjoy my web-experience, "reporting"that kind of "errors". If no matter the location you cannot access core-options, like the Extension-center, it means that the company does not meet their customers/users demands. When, you do not wish to change the browser, you should report such major-errors. It's not just laggy, sometimes it's just unbearable. Possible easons: Bad internert, bad servers or bad pc's the company uses. It's not ten million people accessing the webpage to download Kbytes at the same time.... something's hidden in the bush. :p

Finally, this should be checked and changed/stabilized.

Share this post


Link to post
Share on other sites

Saibagami replied at 2013-5-12 19:18 back.gif

I am sure that the second statement's right.

A priori, I am online for more then 15 hours a day. Th ...

not really laggy for me, not to the extent you describe anyway.

just location-based slight lag. I don't experience any lag beyond that.

If it's anything, it's because it's in China.

Unless you have network issues such as bandwidth usage, or not enough bandwidth provided by your service provider.

If it were a server issue, I'd also be having the issue, which I have never had, beyond what has always been that way because of location. Other people would also be having the issue - many more people.

If it truly were maxthon's servers, how come it's not affecting this forum? And the argument can be made that it's because this is on a separate server than the Chinese-hosted Maxthon sites and child sites. But now, you come back again down to the location logic.

Share this post


Link to post
Share on other sites

If anyone who has been having problems with the extension site being slow will try accessing now I think they will see a marked improvement, I certainly have. I no longer have to wait three to five seconds(and more at times) for the page to load. It had become tiring and frustrating. Thanx Devs!

Share this post


Link to post
Share on other sites

joemax replied at 2013-5-27 14:37 back.gif

If anyone who has been having problems with the extension site being slow will try accessing now I t ...

Yes, that's not a new issue though. And only about 2-3 usually - for me anyway. And that lag is still there, it's just smaller at bits. The better speed has already been in place, too, for a little while, already, since before the original post in this thread has been made, for me anyway.. I know, because I keep it in a locked tab, and have for a long time.

The lag has and always has been because of location in my perception, perhaps the server's config has something to do with it, but it's not the only thing. Perhaps they've done some tweaking to balance out the location issue, so that it's faster nevertheless, but it doesn't change the fact that it's almost certainly location for most of the issue.

Bandwidth is also a heavy consideration. Same thing with your NIC config. I optimize mine, so while location IS STILL a concern, it's not AS much a concern. I also have a good internet connection. All of these things factor in. Also keep in mind, servers are not all configured the same way. If you can access sites hosted in Japan, doesn't mean it's as black and white as: location doesn't matter: it does. It simply means that one might have a higher-quality server than the other. But despite the fact the server might not be as high-quality, it doesn't change the fact that location is a heavy consideration. Also keep in mind that a lot of foreign-language-written sites are hosted in the U.S., or sites in English hosted outside of the U.S. Just because it might be in Japanese, or that the company may be based in Japan, doesn't mean the server is HOSTED there.

Share this post


Link to post
Share on other sites

it's almost unusuable here today.. yesterday it worked fine.

but I have troubles with the hourglass running forever on the forum too.

sigmax.png

Share this post


Link to post
Share on other sites

Imanerd replied at 2013-5-27 14:42 back.gif

Yes, that's not a new issue though. And only about 2-3 usually - for me anyway. And that lag is st ...

Yea, the servers of my sites are in Japan.

Nevertheless, thank you for the information! I agree with you- quality, ping etc.

Share this post


Link to post
Share on other sites

Help me, i want backup all my extension, for load to another computer with the same browser,

and i dont know, how to do it.

Many thanks, in advance

Share this post


Link to post
Share on other sites

npo33770 replied at 2013-6-18 11:02 back.gif

Help me, i want backup all my extension, for load to another computer with the same browser,

and i d ...

You don't have to do anything, simply install M4 onto the new computer and sign into your account, sync will happen automatically.

Share this post


Link to post
Share on other sites

joemax replied at 2013-6-18 11:53 back.gif

You don't have to do anything, simply install M4 onto the new computer and sign into your account, ...

Many thanks

Share this post


Link to post
Share on other sites