×

Give a tip

Enable/disable plugins?


Recommended Posts

I searched for this in forums and old forums but I can't find any help.

I need to see and to manage Maxthon plugins.

 

Similar topic:

http://old-forum.maxthon.com/forum.php?mod=viewthread&tid=700&highlight=plugins

 

I have problem with Facebook game CastleVIlle Legends. It's game which needs Unity Webplayer plugin to be played.

 

But for some reaosn game is not loading since 9 months in Maxthon. 

But what is interesting is game not lioading in other browsers either but I found that if I disable then I enable Unity Player then game will load. But now game is very slow and it's not worth to play it.

I already left game because it's very slow at other browsers but what I remember is with Maxthon was much faster than with Chrome or Firefox.

So, how can I disable then enable Unity Player (or any other plugin) in Maxthon just to see if game is faster or same in Maxthon?

Unistalling and reinstalling Unity nothing helps. Even when I reinstaled WIndows (for other reasons) I noticed nothing happoens when I open game.

Thanks.

 

Tip   Give
Link to comment
Share on other sites

Plugin Manager feature is not yet supported by Maxthon, there is no option for managing plugins such as disable or enable a particular plugins, the only one that is available just the option to enable or disable all plugins.
 
You need a third party to view a list of all installed plugins on your Maxthon. For example, you can use this web service to check your plugins list but of course you can't manage it.
 

Browsercheck
 
Pluginchecker

 
 
You can also manually manage your plugins by opening Maxthon plugins directory* and remove some plugins that you do not need. For example, international user no need some specific plugins for Chinese user like this.
 
post-431500-0-14437400-1436326354_thumb.
 
* Maxthon plugins directory
 

C:\Program Files\Maxthon\Core\Webkit\Npplugins\
C:\Program Files (x86)\Maxthon\Core\Webkit\Npplugins\

post-431500-0-14437400-1436326354_thumb.

Tip   Give
Link to comment
Share on other sites

Plugin Manager feature is not yet supported by Maxthon, there is no option for managing plugins such as disable or enable a particular plugins, the only one that is available just the option to enable or disable all plugins.

 

You need a third party to view a list of all installed plugins on your Maxthon. For example, you can use this web service to check your plugins list but of course you can't manage it.

 

Browsercheck

 

Pluginchecker

 

 

You can also manually manage your plugins by opening Maxthon plugins directory* and remove some plugins that you do not need. For example, international user no need some specific plugins for Chinese user like this.

 

 

* Maxthon plugins directory

 

C:\Program Files\Maxthon\Core\Webkit\Npplugins\

C:\Program Files (x86)\Maxthon\Core\Webkit\Npplugins\

 

thanks for the info. as you have probably guessed, i need more control on the plugins than just enable/disable them all. and deleting them one by one doesn't solve the issue either.

but at least i know now i can stop searching for a plugin control tab.

 

at this day and time, i'm amazed a browser such as maxthon doesn't have one of the most basics features, though.

 

 

Hi,

Thanks for your question. You can enable your plugins as what we often called it extension by right clicking on side bar> extension manager>tick or uncheck whichever you want to.

 

thanks but as i've specifically mentioned in my initial post, plugins are NOT extensions. 

Tip   Give
Link to comment
Share on other sites

thanks for the info. as you have probably guessed, i need more control on the plugins than just enable/disable them all. and deleting them one by one doesn't solve the issue either.

but at least i know now i can stop searching for a plugin control tab.

at this day and time, i'm amazed a browser such as maxthon doesn't have one of the most basics features, though.

The option to disable/enable all plugins was built to disable/enable all plugins from both core and to make it less conflicts. Maxthon has two cores browser engine (webkit/blink and trident), merges all plugins from the different core into standalone plugins manager will triggering more conflict and issue. It will need more time to make it stable or at least to minimize conflicts to each other.

At this time, especially due to this setting option, 'Enable standard rendering in Retro Mode' will force Maxthon using the IE renderer. It means, you can manage the plugins that will be used on retro mode by managing it manually from IE (eg, disable ActiveX in IE will triggering retro mode to render without flash support, and so on).

But if you still curious to implement it on ultra mode (webkit/blink). Honestly, I have no idea. No appropriate settings, no advanced settings such as about:config or chrome://flags, no command line support. It's true, Maxthon not so friendly for advanced user. Not possible for now.

Tip   Give
Link to comment
Share on other sites

The option to disable/enable all plugins was built to disable/enable all plugins from both core and to make it less conflicts. Maxthon has two cores browser engine (webkit/blink and trident), merges all plugins from the different core into standalone plugins manager will triggering more conflict and issue. It will need more time to make it stable or at least to minimize conflicts to each other.

At this time, especially due to this setting option, 'Enable standard rendering in Retro Mode' will force Maxthon using the IE renderer. It means, you can manage the plugins that will be used on retro mode by managing it manually from IE (eg, disable ActiveX in IE will triggering retro mode to render without flash support, and so on).

But if you still curious to implement it on ultra mode (webkit/blink). Honestly, I have no idea. No appropriate settings, no advanced settings such as about:config or chrome://flags, no command line support. It's true, Maxthon not so friendly for advanced user. Not possible for now.

 

useful information though, thanks. i'll give a shot to retro mode and play around, just to see if and how much it helps.

Tip   Give
Link to comment
Share on other sites

no advanced settings such as about:config or chrome://flags, no command line support. It's true, Maxthon not so friendly for advanced user. Not possible for now.

 

Yes, this is something that needs to be be added. It almost seems like Maxthon are trying to market to a more novice user by leaving out a lot of advanced features like this. But at the end of the day, if a user doesn't know or care about a feature they just won't use it. While those that want or need it have that option.

Tip   Give
Link to comment
Share on other sites

Hi MrFreezzzz,

Really sorry for not getting you. Would you please describe it for me specificlly? Maybe the function, the positon in other browser,how does it work... More information would be helpful. Thanks in advance.

 

As Dinataspace said, "about:config [in Firefox] or chrome://flags [in Chrome]", but the OP wants plugins specifically which is chrome://plugins [in Chrome]

 

Currently MX only allows a single ON/OFF option for all plugins in advanced setttings. This doesn't help if a site uses more than one, but only one is causing errors.

 

MX needs some more advanced options for users that might need or want to adjust various settings. EG. heartbleed and other hacks of a few months ago could all be nullified in every other browser by going into their advanced settings pages to disable SSL1/2 etc. This isn't available for Maxthon and puts it way down the list for any user that might be looking for a new browser but wants that functionality..

Tip   Give
Link to comment
Share on other sites

As Dinataspace said, "about:config [in Firefox] or chrome://flags [in Chrome]"

Yes, honestly I need something such as 'chrome://flags' to optimize my discrete graphics cards and for some performance reasons. Maxthon has a GPU information page on 'about:gpu', unfortunately it's not equipped with appropriate settings like 'chrome://gpu' with 'chrome://flags'. But nevermind, I think it's not related with this thread.

Tip   Give
Link to comment
Share on other sites

~Ohke, are you sure it's working on Nitro? In my case Nitro does not recognize Unity at all. 

7twenty, thanks for reply, I will try it.

Edit: unfortunately not working. It's weird.

Nitro Version: 1.1.0.2000 plays very well (fast and stable) on a Win. 8.1 (64-bit), with the newest Flash (NPAPI version = Firefox) on it, with no Unity Webplayer installed on the PC.

So try update your Flash to NPSWF32_18_0_0_203.dll and rename it to pepflashplayer.dll (remember it Always MUST be a 32-bit version .dll file, or it won't work)

This way you go...  >   C:\Users\*user name*\AppData\Roaming\mxnitro\1.1.0.2000\plugins

 

On a Win. 7 (64-bit) Nitro plays only so-so in flash, but with the Unity Webplayer installed, it speeds up a lot, way better than before. (yes and i do test this)

Unity Webplayer is just a Game Booster, just like IObit Game Booster is it = (Accelerate PC Game for Better Performance)  • http://www.iobit.com/en/gamebooster.php

 

On Maxthon you MUST copy/paste the NPSWF32_18_0_0_203.dll , in just as it is, into the Maxthon folder, then it work's best and optimized.

This way... > C:\Program Files (x86)\Maxthon\Core\Webkit\Npplugins

It works with it removed, from the Maxthon folder, as some says. It uses the OS ( = Operating System) installed flash file,

BUT this won't work on all websites (e.g. for some movie-sites online in Flash format = no movie window pop out, so you can resize it).

 

And for your Maxthon, to work the very best on all websites, try use a Truncated version (it's faster loading) for your UA one that fits for your OS. 

Remember to keep an [v] marking for Maxthon, so it works permanently, this is my UA version i use in Win. 7 64-bit. So websites open up for there services, to your browser.

Mozilla/5.0 (compatible; Windows NT 6.1; WOW64; IA64; en) AppleWebKit/599.0+ (KHTML, like Gecko) Chrome/43.0.2357.124 Maxthon/4.4.5 QupZilla/1.8.6 Safari/537.36

If CastleVille Legends on FB,  when / or if it pops up with an error or freezes up, then right-click and Refresh the page ( = Reload in Nitro) and it safes your game automatic.

post-327978-0-25106900-1436590949.png  <~ This error in Nitro, before any Unity Webplayer is installed, so this looks like FB have Unity.com on there website somehow... 

Before you do play, always check Windows update first, it makes the PC slower if it runs in the background. (have seen this many times before)

A good way is to clear PC and Browser (cache and history etc.) and restart PC, before any kind of game-play or movie-video viewing. The PC plays well and longer this way.

 

Best Regards Ohke

OBS!! SORRY if this is to loooong a typing, but i can NOT ever and don't NEVER know, how well and good you are on a PC, i always type so even Mom (or a newbie) can understand it... (^^,)

Tip   Give
Link to comment
Share on other sites

@ Thanks 7twenty for the merging... (^^,)

And no Maxthon do not have this as a plugin, but Facebook have it implemented on there website games, so you really don't need to install this to your PC. 

But it do helps a lot on the games, in the Maxthon Browser version 4.4.5.3000 (but make sure you do a CLEAN install / update of Maxthon + Nitro).

@ And Xahi4475 if your Maxthon still don't play well, you can try to remove your old cache here (Unity website), to rebuild a new for your games. (this some times helps a lot on a PC to)

Unity Webplayer - Setup and Clean game cache to the right >  https://unity3d.com/webplayer/setup

And bee sure that your Maxthon, do play it in Retro mode, then it's faster than Nitro.

 

The plugin is used e.g. in Facebook games. Facebook "endorses" the plugin and has an API for embedding Facebook features in games...

FB says this > " One of the initial barriers to entry when using Unity is the installation of the browser Unity Web Player plug-in.

We've constructed a Facebook branded Unity Web Player installation flow, showing potential players that Unity Web Player is endorsed by Facebook, a brand they know and trust."

 

As an NPAPI plugin, Unity Web Player has been available for all major browsers. However on Chrome, NPAPI plugins have been disabled by default since version 42 (April 2015).

Because of this > • Flaw in Unity Web Player Allows Theft of Personal Data: Researcher ~ SecurityWeek.Com  http://www.securityweek.com/flaw-unity-web-player-allows-theft-personal-data-researcher

If you use version 4.6.6f2 and 5.0.3f2 (or above) your are safe for the moment. Test it here (and make sure your login on Google to test) • Klikki Oy - Unity vulnerability test  https://klikki.fi/unity/

 

And an update on Nitro, with the Unity Webplayer installed, it's preforms better but also gives bigger error messages.

Maybe some one (like 7twenty or Dinataspace ) can see what the error is, the memory is haywire i can see.

post-327978-0-04090700-1436691476_thumb.  

And this is the Process Manger at the same time > post-327978-0-93073100-1436691618_thumb.

Hope this can help some how, to make Nitro and Maxthon better maybe...

Best Regards Ohke

Tip   Give
Link to comment
Share on other sites

  • 4 months later...

Sorry for late. I thought no more replies.

And now I forgot also I started this topic. I used search about plugins and I got this my thread. titter.gif

So, thanks for replies, guys. :)

In meantime when I got my first smartphone I started to play mobile version of CVL and it was super fast like it was in Maxthon last year. But now I got problem in mobile version too, can't connect game to Facebook. It's known issue and Zynga is trying to fix it 

Anyway I tried to disable then reenable Plugins in Maxthon but nothing changed and I tried game in Nitro and voila game works and it's faster than in Chrome but still is slow and not fun to play it.

I'm really curious if game would be even faster or better to say maximal performance like used to be in Maxthon at 2014. But too bad it's not working in Maxthon. About retro mode, I don't think it's good idea because my IE is version 8 and it's horrible for games. If I had Windows 7 or 8 would be other story. But I tried it and I got interesting error message.

About Unity web settings it's empty. Weird.

Anyway it's just game, no big deal. I gave up until mobile version is fixed. 

Also when I tried Unity test after 3-4 minutes progress I got new message about DX9. What? But Unity works in Chrome and Nitro.

 

123.png

123.png

123.png

 

OK, now we know why Unity not working on Maxthon. It's DX9 graphic card!? How can I fix it so Maxthon will know my graphic card? Any idea? emotion-5.gif

P. S. One more thing. I must say I use WIndows Server 2003. I do not change OS for game. 

And game works in my Nitro because Flash is old it's version 15. When I replaced it with latest version now it's not working. You said it work on WIndows 8 smooth and fast without installing Unity? Well, that's nice but I won't install Windows 8. I keep 2003 until Maxthon won't support it. :D

I understand very well PC and I'm good on these things but this time not problem in knowledge but somthing else. 

Tip   Give
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.