Keep showing bunches of download dialogs


Recommended Posts

Las time I download newest version and when tring to save a file, Maxthon keeps showing bunches of download dialogs and the message is "invalid download folder.." something like that. I have to go back to a much older version. Take a look at following screenshot. My last saved folder is: C:\Users\scottchu\Videos\man driver\unsync to exthd\. I turn to press ctrl+j to bring up the download dialog and click '+' to add a new download by copying download url in the text box and then I choose c:\ as download folder but Maxthon still shows "invalid download folder". If I go back Maxthon 5.2.x, it works fine. So what's wrong with new version?  (note: I'm using portable version.)

xTcraRM.png

Link to post
Share on other sites

No, I'm under Win7 and No, I doesn't check quick download to, neither. I've mentioned that it's ok using Maxthon 5.2.x, so I don't think it's privilege problem. There must be something wrong with new-version MX5 and I believe it must be some side-effect when add or update new functions.

Link to post
Share on other sites
17 minutes ago, scottchu.tw said:

No, I'm under Win7 and No, I doesn't check quick download to, neither. I've mentioned that it's ok using Maxthon 5.2.x, so I don't think it's privilege problem. There must be something wrong with new-version MX5 and I believe it must be some side-effect when add or update new functions.

Try checking the "quick download to" then changing the download path, please. There is an old bug about it.

Link to post
Share on other sites
6 hours ago, BugSir006 said:

Try checking the "quick download to" then changing the download path, please. There is an old bug about it.

It works, thanks. I never heard this bug before, so I apologize for my misunderstanding that it is a bug of upgrade new functions. Sorry again!

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.