[] Video source not supported - EWTN.com

Recommended Posts

I've run into a killer video problem with the Live Streaming video feed on EWTN.com.

It is a killer because this station is my most important site and I regularly watch some of its videos.

However with version release I have been presented with the error message below.

To get there:

1) Go to EWTN.com

2) Click the "Watch/Listen" button on the left side.

3) Scroll down till you see the large "LIVE" button.  Click it.

4) Click the "UNITED STATES" (or "CANADA") button.

5)  After a brief attempt to load the video stream, the following message appears.


I have used a clean install of Maxthon Portable and still get the problem.

EWTN uses the Brightcove streaming service and the videos are Flash.

I hope you can figure out what is wrong.

[EDIT] More info:  I get the same result in Guest mode.  


Link to comment
Share on other sites

21 hours ago, No.1MaxthonFan said:

Have no problem with EWTN


Thanks, but my problem went away as quickly as it appeared a while after I posted about it yesterday with no changes to anything.  And it remains in that state today.  So problem resolved, but keeping watch.

Thanks for your checking efforts.



Link to comment
Share on other sites

17 hours ago, 7twenty said:

Works fine here as well.

Flash / UA: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36 OPR/


Do you have any errors in the dev tools, console (F12 > console)?

I didn't think of checking for that.  Since the problem seems to have reslved itself, I'll keep that idea in mind for the future.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.