Flash Player issues


Recommended Posts


I have windows 10. and I have been using Maxthon for sometime  I could not get you tube videos to play out of all 4 speakers  so I downloaded a maxthon exstention which was to dosable html 5 in you tube and when I did that the videos all played in all 4 of my desktop speakers. I didn't have to switch  from ultra mde with the yellow Lighting Icon to the retro mode with the blue Icon. I guess maxthon just did it automaticlly when I would play the videos. Cause I had the exstention that turned off html 5 in you tube. I had to restore my operating system as of late cause I was having some issues with different things. and when I reinstalled maxthon and then added the exstention to turn off html 5 in you tube so it will use flash the you tube videos will not play in all 4 of my speakers like they used too. Now I have always use Ultra mode some webpages might be displayed incorrectly. I have that Unchecked. It's under browsing in the settings is that right? Also enable stabdard rendering in retro mde. That's unchecked also. I have at the top of my browser the yellow Icon for the Lightning telling me that I'm viewing the page in Ultra mode. I downloaded the l;atest version of flash. when I downloaded flash I already have the exstention to turn off html 5 in you tube Installed. And yes I installed flash correctly I have the altest version I renanbmed the old version  so it was no longer usable. Here is the thing if I click on the yellow Lightning at the top of the browser  and I switch to retro mode when I go into you tube the videos will play on all 4 speakers but there are some site issue with that some of the videos don't show up and some don't play at all. Only in retro mode though. So I guess the browser isn't switching automatically to retro mode when I enter youtube and play a video. Otherwise they might play out of all 4 speakers.


Any help would be great. And I can't remember what version of flash I was using before I reinstalled. Maybe I have to go back to an older version of flash.


Thank you so much!

Link to comment
Share on other sites

8 minutes ago, Clue4me58 said:

it's disable html 5 it allows me to use flash player when watching you tube videos out of all 4 of my speakers. but it's not working now for some reason I tried it it's version 15.o,o,189. so I guess I didn't install the new version of flash the right way



we will update flash plug-in in the next version. please have a try. it may release tomorrow. Thanks for you help us to improve our browser. Have a nice day~

Link to comment
Share on other sites

39 minutes ago, Zurobara said:

You should  do intensive testing for flash player in win 8.1 pro (especially on facebook)..This is an old issue on both versions (4.8.xxx and 4.9.xxx)

Thanks your proposal~ i already suggested our test team to do that~

Hope you continue make proposals for help us improving our browser~ we are always trying to do the best browser~

Link to comment
Share on other sites


 adobe flash npapi is installed in my add and remove programs. So it looks Like I have correct version of flash installed properly with maxthon

For 4.9 You need the Pepperflash PPapi Flash installed as pepflashplayer.dll in Core\plugins\Blink folder. There should be no Webkit folder.

For 4.4 just delete the Flash file in Core\Plugins\Webkit. There should be no Blink folder.

Link to comment
Share on other sites

22 minutes ago, Clue4me58 said:

For 4.9 You need the Pepperflash PPapi Flash installed as pepflashplayer.dll in Core\plugins\Blink folder. There should be no Webkit folder. so how do I get this version of flash installed that you are talking about and delete the version I have I follwed instructions specific to what it said I needed to download for flash to use with Maxthon? Also when I switch to maxthons retro mode in you tube it uses an older version of flash version 15 how do I get retromode to use the latest version of flash like ultra mode does. can you sendme a link with instructions for both of my issues? Thank you!

You already got these instructions...

Anyway once again - http://forum.maxthon.com/index.php?/topic/13262-adobe-flash-and-maxthon/

Link to comment
Share on other sites

3 hours ago, Zurobara said:

In Maxthon - portable is no "pepflasplayer.dll.org" file like in image from your link

Of courese tthe wouldn't be any pepperflasshplayer.dll.org if you didn't  ffollow the suggesstion in the instructions to rename the original copy to disable it raqther thaan deleting it.  Then you copy the pepperflashplayer32_xx_x_x_xxx.dll fromC:\Windows\SysWOW54\Macromed\Flash\ and past it into the *\Core\Blink\Plugins\ folder in your Maxthon oor MaxthonPortable director.

The image showss what it will look like AFTER you follow the directions provided you choose to keep the original versio availabble.  You may also delete it if that suits you better.



Link to comment
Share on other sites

3 minutes ago, Zurobara said:

maybe i'm crazy.

Not crazy, just not reading it from top to bottom as it should be. Jumping to whatever bits seem most pertinent to you, or just looking at the pictures isn't the way to do it.

Copy/paste from thread:



Open an Explorer window (Win+E) and go to the folder you installed Maxthon to, then navigate to the \Core\Blink\plugins folder.

NOTE: Default install folders are:
32bit - C:\Program Files\Maxthon
64bit - C:\Program Files (x86)\Maxthon

In this folder there should be a file called pepflashplayer.dll. Rename (eg. append .org to the filename) or delete this file only. Renaming is the recommended option.

Copy pepflashplayer32_XX_X_X_XXX.dll from the windows folder to the Maxthon \Core\Blink\plugins folder, and rename it to pepflashplayer.dll.

The original instruction stated: Rename (preferred) or delete this file only. I didn't think it was that obscure when read along with the image.

Regardless, the instructions are correct and not hard to follow and lead to the desired outcome if followed correctly.


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.