Annoying that everytime we upgrade Maxthon 4, it changes our default search engine...


ghost z

Recommended Posts

It is very annoying that everytime we upgrade Maxthon 4, it changes our default search engine to a Google custom search. Additionally, the Google custom search has problems--which makes it more noticeable that our search engine got changed. Please stop doing this!

Link to post
Share on other sites

It is very annoying that everytime we upgrade Maxthon 4, it changes our default search engine to a Google custom search. Additionally, the Google custom search has problems--which makes it more noticeable that our search engine got changed. Please stop doing this!

This was stopped in a fix a couple versions ago.  But there are some user actions needed to make it take.

 

1.  Update to the current version which is at this writing 4.4.7.3000 available from here

http://forum.maxthon.com/index.php/topic/17454-maxthon-cloud-browser-for-windows-v4473000-released/#entry90225

 

2.  Go to Settings on the Main Menu and select Search Engine in the left column.  Change the Default Browser to one of your choice.

3. Delete the Google Search entry from the list of search engines shown.

4. Go to Extensions on the Main Menu

5. Disable the Search extension.  You may delete it if you prefer.  I have mine disabled so there's no "mistaking" that I don't want it.

 

After that, the fix I mentioned should prevent reinstalling the Search extension and restoration of Google Search as the default search engine.

Link to post
Share on other sites
  • 1 month later...

this is still not fixed.  i just upgraded from 4.4.7.3000 to 4.4.8.1000 and it happened again.  and yes, prior to the upgrade, i have already done what you suggested above.

You will have to do it again.  I just discovered that Google Search engine had come back.  But the Search extension has stayed gone.  Just delete the search engine from the Search engine list in Options after choosing another default search engine.  

They did modify the Search extension so it does not install in an overwrite install if the the previous version is not present or is disabled.  That is progress.  It would be more progress if Google Search were not placed on the default search engine list, but is left on the additional search engines list.  This would allow those who do want it to add it.

If you do a clean install, everything you got rid of will be back.  Much of  your previous settings wil be restored from the cloud when you log into Passport.  If you overwrite, the previous MaxthonPortable\UserData\ (portable) or C:\Users\loginname)\AppData\Roaming\Maxthon3\ (installer version) will be present and should preserve all settings you've made.

<<SL>>

Link to post
Share on other sites
  • 4 months later...
2 hours ago, ghost z said:

just upgraded to 4.4.8.2000 and it still happens!  maxthon must make money off this, else they wouldn't keep annoying us with this issue.

Speak for yourself. This has never happened to me and I just upgraded from 4.4.8.1000 to 4.4.8.2000 and my search engine, Maxthon Multi Search, is my default search engine and it has been for as many years as MX4 has been out. Upgrading has never changed my default search engine, so I don't think that Maxthon changes "our" default engine or that they make any money off of it and they aren't annoying "us" with this issue, maybe just you. Just to make sure we are on the same page, my Maxthon is the installed version, not the portable, and I am referring to the default search engine that one sets in Maxthon Settings Menu>Search Engine; I don't use the search bar and I have hidden the search box on the Quick Access page, so I only search from the Address Bar and it uses the search engine designated in Menu>Search Engine. I understand that this would be very annoying but please don't assume it is a universal problem.

Link to post
Share on other sites

my advice would be to not delete "google custom search", if you delete it the browser recreates it next update. Set your default search engine to whatever browser you want, and let custom search in the list.

Same with "search extension" (disable it, don't delete it)

Link to post
Share on other sites
2 hours ago, -ody- said:

my advice would be to not delete "google custom search", if you delete it the browser recreates it next update. Set your default search engine to whatever browser you want, and let custom search in the list.

Same with "search extension" (disable it, don't delete it)

I aagree with your ieda for  "Google custom search engine" in the search engine list, but I have deleted the Search extension and it has never returned once deleted.  But disabling also works, so it's also a good fix.

                    <<SL>>

Link to post
Share on other sites
5 hours ago, SnowLeopard said:

I aagree with your ieda for  "Google custom search engine" in the search engine list, but I have deleted the Search extension and it has never returned once deleted.  But disabling also works, so it's also a good fix.

                    <<SL>>

maybe because they do no longer "offer" search extension in maxthon package..

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.