×

Give a tip

Problem with clipboard - unable to paste


Recommended Posts

So when I try to paste images into web pages, it doesn't work. It's like the clipboard is empty. I can paste text fine and I can paste images using other browsers.

If I try to use a menu command "paste" within certain applications (like Javascript rich text editors) I get an error that my browser's security settings are blocking access to the clipboard.

 

What's really annoying is that this used to work. I used to be able to ctrl+v paste images (like in FB comments) with no problem. What happened and how can I get Maxthon to paste images again? Like I said, other browsers work fine.

 

Current version: 4.4.6.1000, but this has been an issue for over a year.

Tip   Give
Link to comment
Share on other sites

So when I try to paste images into web pages, it doesn't work. It's like the clipboard is empty. I can paste text fine and I can paste images using other browsers.

If I try to use a menu command "paste" within certain applications (like Javascript rich text editors) I get an error that my browser's security settings are blocking access to the clipboard.

 

What's really annoying is that this used to work. I used to be able to ctrl+v paste images (like in FB comments) with no problem. What happened and how can I get Maxthon to paste images again? Like I said, other browsers work fine.

 

Current version: 4.4.6.1000, but this has been an issue for over a year.

Maybe try the latest version 4.4.7.1000 you can download from here and see if that works.  http://dl.maxthon.com/mx4/mx4.4.7.1000.exe

post3dmg4_zps398d3651.jpgWindows 10 64-bit build 10525/Windows 10 Mobile build 10512

Tip   Give
Link to comment
Share on other sites

Maybe try the latest version 4.4.7.1000 you can download from here and see if that works.  http://dl.maxthon.com/mx4/mx4.4.7.1000.exe

Installed. Tested. Doesn't work, can't paste images.

(Also the autoupdater told me 4.4.6.1000 is up to date - Maxthon you really gotta get consistent about how you publish new releases.)

 

BTW, I can copy images fine. If I right click on an image and select "copy image", I can go to IE and paste it into whatever website I want. I just can't paste with Maxthon. And like I said, this has been a problem for over a year. Same behavior on 4 different devices: my home desktop and laptop and Surface Pro 3 running Windows 10 (previously 8.1, previously 8.0, all with the same issue), and my work laptop running Windows 7. This problem has occurred across many versions of Maxthon - though I couldn't tell you which version it first happened on. I do remember when it first happened, I did not upgrade Maxthon, it just quit working. Restarting Maxthon or restarting my computer makes no difference.

Tip   Give
Link to comment
Share on other sites

As above, copied the image below and pasted no problems.

 

spring-flowers-yellow-flower-sky.jpeg

 

 

Does the paste command even show up in the context menu? Or is it still grey like there is nothing to paste?

 

Go through the troubleshooting thread and see how you go. Possibly some extension or something else is getting in the way. At minimum  try test #10 to see if it's your install and settings.

Tip   Give
Link to comment
Share on other sites

Must be a setting somewhere on your computer because I just copied this image from a Bing Search and it pasted without a problem.

Sure, I'll buy that! But what setting is it? What global PC settings does Maxthon reference between browser and clipboard?

 

 

As above, copied the image below and pasted no problems.

 

 

Does the paste command even show up in the context menu? Or is it still grey like there is nothing to paste?

 

Go through the troubleshooting thread and see how you go. Possibly some extension or something else is getting in the way. At minimum  try test #10 to see if it's your install and settings.

 

Paste shows up in the right-click menu. I click "Paste" and the menu closes and nothing happens.

Tip   Give
Link to comment
Share on other sites

1 /
Are you running the latest version of Maxthon?

check

 

2 /
Do a forum search
check


3 /
Try changing to Retro Mode
check


4 /
Connection error? 
n/a


5 /
Try disabling AdBlock Plus
check


6 /
Try deleting/clearing cookies 

Opened a new private instance (no cookies/temp files access)

 

7 /

Try disabling all extensions.

Check

 

8 /

Check the advanced options

Check


9 /
Sign out of your Maxthon Passport
Check


10 /
Test with Maxthon Portable

Check

 

No change with any of these tests.

Tip   Give
Link to comment
Share on other sites

Bump. (I get one free one after 3 days :p )

This may not be a problem with Maxthon, but if it's a PC configuration or setting I'd really love some input on what it might be.

As I said, IE 11 works great, and I don't use any other browsers, so this is just with Maxthon for me.

Once again:

Try to download portable Maxthon version.

Unzip somewhere on disk, don't log in to your Passport, don't change change any settings and don't install any extension.

Then try again.

Tip   Give
Link to comment
Share on other sites

Once again:

Try to download portable Maxthon version.

Unzip somewhere on disk, don't log in to your Passport, don't change change any settings and don't install any extension.

Then try again.

I have. It makes no difference, I still can't paste images with ctrl+v or the context menu. See my prior post where I went through all of the troubleshooting steps listed.

Tip   Give
Link to comment
Share on other sites

Said he's already tried that in the post above?

 

The fact that you're still getting issues with that and portable/no passport/private browsing makes me think it's a system issue, not Maxthon - but then you say it's on 3 other PC's as well. As shown above it does work in MX, so it doesn't make sense that it won't work for you.

 

Do you run any utilities that may intercept keystrokes?

 

And is it on any site? Or just a particular ones? does it work here on the forum?

Tip   Give
Link to comment
Share on other sites

Said he's already tried that in the post above?

 

The fact that you're still getting issues with that and portable/no passport/private browsing makes me think it's a system issue, not Maxthon - but then you say it's on 3 other PC's as well. As shown above it does work in MX, so it doesn't make sense that it won't work for you.

 

Do you run any utilities that may intercept keystrokes?

 

And is it on any site? Or just a particular ones? does it work here on the forum?

No key intercepting stuff. Unless there's spyware on my machine >.< and I'm reeaaaaallly OCD about stuff like that.

So I'd say "any site", but apparently as of right now it works here:

5225638554_cf300d91e4_z.jpg

 

Still doesn't work on facebook or numerous other sites.

The only system setting I'm aware of is an IE setting "Allow programmatic clipboard access". On my desktop this is currently set to "prompt". On my work laptop it was set to "Enable" and I just changed it to "Prompt" and restarted Maxthon and I could paste into facebook but not the work-related knowledge base that started this thread in the first place.

What are some other sites that this should work on that I can use to test?

 

For the record, I've never adjusted these IE settings before, and since it's not consistent between PCs, I don't think it's the cause or the fix of this issue.

Tip   Give
Link to comment
Share on other sites

For the record, I've never adjusted these IE settings before, and since it's not consistent between PCs, I don't think it's the cause or the fix of this issue.

 

You're probably right about that, but your test with Facebook doesn't agree. As far as other sites that have the issue I couldn't tell you, but will keep it in mind and see if I stumble across any.

 

It might be one of those weird issues where something like changing the UA allows/disallows certain features of sites.

Tip   Give
Link to comment
Share on other sites

So speaking of UA, that seems to be possibly somewhat related.

 

Found one forum where using the default UA or Chrome gives me a context menu with no paste option, yet using IE11 or Opera it's there and it works. Not quite the same as having it available but it not working, but i'd be playing around with the UA and see there is something there that is causing the problem.

Tip   Give
Link to comment
Share on other sites

  • 1 month later...

So, this is definitely still an issue. I've tried setting a different user agent in Maxthon settings but it's made no difference. But this bug does appear to only happen with certain sites. I can paste images into the forum here, but I still can't paste anything into Facebook. Restarting Maxthon, restarting Mx after each UA change, and restarting my computer all made no difference. There have been no changes to system settings or IE settings.

My workaround has simply been to use Edge or IE11, but on occasions like today where I'm at work without access to my home PC and I'm stuck with IE9, I'm SOL. I'm convinced this is a Maxthon design flaw. When I can use almost any other browser and pasting images and rich content works flawlessly regardless of the site I'm on, Maxthon is severely implicated.

Tip   Give
Link to comment
Share on other sites

Don't know what to tell you but as stated in my previous post, text and images paste just fine in Facebook.  Windows 10 with Maxthon 4.4.8.1000 using either the Context Menu or Ctrl+C or Ctrl+V.  I know that doesn't help you, but at least you know it's not a problem for everyone.

post3dmg4_zps398d3651.jpgWindows 10 64-bit build 10525/Windows 10 Mobile build 10512

Tip   Give
Link to comment
Share on other sites

Don't know what to tell you but as stated in my previous post, text and images paste just fine in Facebook.  Windows 10 with Maxthon 4.4.8.1000 using either the Context Menu or Ctrl+C or Ctrl+V.  I know that doesn't help you, but at least you know it's not a problem for everyone.

Which is why it bothers me and why I asked in the OP about any kind of system settings that might affect it. I also updated from 4.4.6.1000 to 4.4.8.1000 and it made no difference. I'm flummoxed that the solution seems so elusive and the problem seems so inconsistent.  

Tip   Give
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.