×

Give a tip

7twenty

MX Master
  • Posts

    4,695
  • Joined

  • Last visited

  • Days Won

    79

 Content Type 

Profiles

Forums

Release Notes

Bug Tracker

Help page

Help page-CN

Release Note5

Rules and recruitment

Release Note6

Everything posted by 7twenty

  1. Can you test using a portable version? Download, extract, run, save a password and see what happens. Don't sign in to passport .
  2. That's always the case. Unless you're hiding the extension, changing it will always cause issues. As you found out, by default Maxthon only highlights the filename in the download box. So you can just type directly and the extension will stay the same. Will actually make it easier for you as you don't have to worry about selecting anything first. Nice to see you figured out the issue.
  3. Same was mentioned about Microsoft.com. Was mentioned by a bug* that it would be looked into. Hopefully MX5 will have it fixed. Using the pressing space or similar option as workaround is the only option for the moment.
  4. Thank you. Picked a random video and it seems to be working fine: http://www.hitbox.tv/mxbones ABP is on with the default easylist enabled. User agent: Mozilla/5.0 (Windows NT 10.0) AppleWebKit/537.36 (KHTML, like Gecko) Maxthon/4.9.3.1000 Chrome/39.0.2146.0 Safari/537.36 Ultra mode MX4.9.3.1000 Test with a portable version and see if it works on that.
  5. Test with the portable version from here on the forum. And test on both system if possible. Just extract, run and do a test download. Don't sign in to passport or anything else. Try saving to a different location, like desktop. Do you have any anti-virus programs that are set to scan files you download? They could be interrupting Maxthon finishing the file. What error do you get when you try and open them? I'm guessing you tried downloading more than once? Tested the Disk cleaner program and downloaded fine, so it's not the files.
  6. No, you're not dreaming. It's mentioned in the video.
  7. Tested here with ABP and it worked fine. Only using the default easylist. If you're using extra ones, then they could be the cause. Try disabling them to see if that is the case.
  8. Interesting observation. That will definitely fix the issue - i've had the same problem. As i said above, you can mitigate the amount of history data lost by deleting only certain files, as maxthon breaks them up into ~3mb files. Backup, and delete/test/restore till you find the offending one. But going back to your observation, it could be something related to the site font encoding. There was an issue a while back where a particular site would cause the last session data to be lost if it was part of it. Turned out to be a hidden character in the websites title. Could be the same or similar problem here. But to determine it you'd need to go back and find the offending site/s as mentioned above.
  9. Adding an extra slash is the fix. There's no need for the 10x, just 3 (///) works here. You need to enable the screenshot option.
  10. Pretty sure some/one of your history files are corrupt. You need to delete them and then it should start working again. Unfortunately you'll lose any history along with it. Files are found in; %appdata%\maxthon3\UserData\Users\[guest or email address]\History If you do do this make sure you keep a back up of your data! You may not have to delete them all, some trial and error delete/test and see if it starts working properly. If it doesn't then try another history file.
  11. Not a big deal. As i said, i don't think it's related to that as it's only the data for where the box gets displayed. I don't have any crashreports of my own to check with to see how the extension list in the crashfile relates to the extensions installed/running. So bit of a dead end there. Firstly, create a backup of your current Maxthon data before doing anything mentioned next. If you want you can try the following, not sure if it will still work if you use a passport account (as the syncing might screw things up), but shouldn't be an issue for a local only account. Just something to be aware of. Test the settings theory by copying over your current Maxthon userdata folder to the MX portable folder. If the crash then happens running portable then we know for sure it's settings related. From there extract a new portable version, then copy over one folder at a time from the crashing install userdata. Do some testing in between each copy, then when the crash occurs the last folder copied should be the one containing the data causing it. Or you can do a few folders at a time. Depending on how thorough and how much back tracking you're prepared to do. Once you find the offending folder you can just replace the dodgy folder/file in your current install. Unfortunately it's the only way I can think off (still assuming it's settings related) to track down the problem - and not guaranteed. But seeing as portable worked, i think this will lead to the cause. The crashdata reports don't mean much to me, apart from what i've noted above. Option B is wait and maybe a bugsir/miss might be able to offer some insight if someone looks into it. Personally i'd go with option A
  12. Disable address bar Auto-Suggestions Maxthon doesn't offer an option to disable address bar auto-suggestions. To manually disable this feature follow the instructions below. Open Notepad with administrator privileges, add the following line to your HOSTS file and save. 127.0.0.1 api.bing.com The HOSTS file can be found %SystemRoot%\system32\drivers\etc See note #1 Navigate to the \public\SmartUrl folder in your Maxthon install folder (or in appdata\roaming\Maxthon3 for installer version) Rename (or delete) the original update.db file (see image below). Create a new empty text file named update.db and mark it read-only. See note #2 Restart Maxthon and the auto-suggestions won't show up. Before auto-suggest fix After auto-suggest fix note 1: This change won't affect anything else except any other programs that use that address for the same suggestions. All it does is tell the browser the IP address for that URL is the localhost address instead of the correct one, so nothing leaves your computer. note 2: The only caveat is that it seems when typing in the address bar the matched URLs are a little slower than normal. Not 100% on that, but that's what it feels like. And of course i'm unaware of anything else it might break.
  13. Clearing cookies using Developer Tools Open the Developer Tools (F12) Go to the Resources tab, then the cookies section. Right-click on the address you would like to clear cookies from and select Clear.
  14. NOTE: The information below is for Maxthon 4.4.x and earlier releases.For Maxthon 4.9.x and later releases see this post. Update to the most recent version of Flash from here: http://get.adobe.com/flash The page will show that it has detected Chrome. If not, check that the default user agent is in use. Click "Need Flash Player for a different computer?" Select your Operating System from the dropdown menu. Select "FP for Firefox - NPAPI" to install the correct version for Maxthon to use. Press the download button on the right and let the installer run. Close Maxthon. Open up an Explorer window (Win+E) and go to the folder you installed Maxthon to then navigate to the Core\Webkit\Npplugins folder. NOTE: Default install folders are:For 32bit OS - C:\Program Files\MaxthonFor 64bit OS - C:\Program Files (x86)\Maxthon In this folder there should be a file called NPSWF32_XX_X_X_XXX.dll (the X's are the flash version). Rename (eg. append .org to the filename) or delete this file only. Renaming is the recommended option. Restart Maxthon & goto http://www.adobe.com/software/flash/about/ The page should show the current version installed and the most recent version available, both of which should match. Maxthon is now using the current version of Flash. If everything was done correctly you should have something similar to the following image, and a Npplugins folder as below. Should the above not work, you can try copying the NPSWF32_XX_X_X_XXX.dll file from C:\Windows\Syswow64\Macromed\Flash (for 64-bit) orC:\Windows\System32\Macromed\Flash (for 32-bit) and paste it into Core\Webkit\Npplugins.
  15. Any chance of noting your settings so others with issues can compare? And testing on a portable version? That way we might find out if it's something/settings on your install or your system? If portable works, then it's system related, if not then it's settings. If it is settings some testing should lead us to the culprit.
  16. This is one of those issues that is quite subjective. Someone might not see any issue even if there is some slight stuttering, while others will get very aggravated by it. For the most part I think google maps works well in Ultra. But if you change to Retro you will notice it's a little smoother. I think it's something to do with the way the screen is drawn when a page is loading. MX always causes videos playing to stutter when pages are loading in the background. And I think the same is possibly happening with google maps. Maybe it needs another process handling these separately? Not sure...
  17. NOTE: The information below is for Maxthon 4.9.x & 5.x releases. For Maxthon 4.4.x and earlier releases see this post. Update to the most recent version of Flash from here: http://get.adobe.com/flash The page will show that it has detected Chrome. If not, check that the default user agent is in use. Click "Do you have a different operating system or browser?" Select your Operating System from the dropdown menu. Select "FP for Opera and Chromium - PPAPI" to install the correct version for Maxthon to use. Press the download button on the right and let the installer run. Close Maxthon. Open an Explorer window (Win+E) and go to the folder you installed Maxthon to, then navigate to the folder: For MX5: \Core\plugins For MX4.9: \Core\Blink\plugins NOTE: Default install folders are:For 32bit OS - C:\Program Files\MaxthonFor 64bit OS - C:\Program Files (x86)\Maxthon In this folder there should be a file called pepflashplayer.dll. Rename (eg. append .org to the filename) or delete this file only. Renaming is the recommended option. Copy pepflashplayer32_XX_X_X_XXX.dll from the windows folder to the Maxthon \Core\Blink\plugins folder, and rename it to pepflashplayer.dll. The file is found in the following locations:For 64bit OS - C:\Windows\SysWOW64\Macromed\FlashFor 32bit OS - C:\Windows\System32\Macromed\Flash Restart Maxthon & goto http://www.adobe.com/software/flash/about/ The page should show the current version installed and the most recent version available, both of which should match. Maxthon is now using the current version of Flash. If everything was done correctly you should have something similar to the following image, and a plugins folder as below.
  18. Maxthon comes with a version of Adobe Flash to ensure the browser is able to play all Flash content upon installation, although this version isn't always the most recent. This is to ensure that any issues related to new releases of Flash don't cause issues with Maxthon. You can force Maxthon to use the most current version of Flash by following the instructions below. The most recent version of Adobe Flash is available from here: http://get.adobe.com/flash The "Allow all sites to run plug-ins" option must be enabled in Settings > Advanced. The MX Flash Updater is recommended to check and update your system and Maxthon Flash version. An auto-updater tool has also been created by Truuuc which automates the flash install procedures below along with some extra options for languages and other plugins.. If you have any issues with the above, please follow the descriptions linked below. For Maxthon 4.9.x and later follow the instructions in this post. For Maxthon 4.4.x and earlier follow the instructions in this post.
  19. CrashesTo help the Maxthon developers find the cause of crashes, you can send crash reports found in the %temp%\MaxthonCrashData folder. Open a Windows Explorer window and type the path into the address bar. Zip the folders and send the file in an email to: help@maxthon.comYou can also make a post on the forum.Plug-in IssuesFirst test with Retro mode.Ensure the "Allow all sites to run plugins" option is checked in the Advanced Settings page.Use Retro mode as an alternative until it's fixed in UltraAdobe FlashFor information on getting the most recent version of Adobe Flash working Maxthon please see this thread.Maxthon PDF viewerIf you don't want the internal PDF viewer to open PDF files:Open a Windows Explorer window and go to your Maxthon install folder then navigate to the following folder:\Core\Webkit\Rename or delete the pdf.dll file.Smooth scrollingSome advanced options can be changed for smooth scrolling. NOTE: Only available in Maxthon 3.0.1.2 and later versions.Open a Windows Explorer window and go to your Maxthon install folder then navigate to the following folder:\Temp\MxWebkit\The settings are found in the file WKSetting.ini.Find or add the following section:[scrollPage]Add the current default parameters:ScrollPageSmoothly=trueWheelBeginDumping=20WheelEndDumping=50WheelAccel=4WheelStep=140Parameter definitions:ScrollPageSmoothly = true: Enables smooth scrolling (default), set to false to disable. NOTE: this should be set using the option in Maxthon settings.WheelBeginDumping = 20: The amount of smoothing at the start of rolling stage. Range is from 0 to 100WheelEndDumping = 50: The amount of smoothing at the stage the degree of smoothing parameter. Range is from 0 to 100WheelAccel = 4: Roll acceleration factor. Range is 0 to 450WheelStep = 140: Reference rolling step. Range is 0 to 300If it seems that smooth scrolling still isn't working you can add the following paramater to force enable:ForceEnable=trueThanks to kliop00023 for some of the info included above.
  20. This is a basic troubleshooting guide for users to try and find the cause of issues. Following the guide should allow you to hopefully fix the issue, or at least figure out the source that is causing it so that when posting on the forum users have more information available to offer help. 1 /Are you running the latest version of Maxthon? Check the forum for any new releases and update/reinstall. Most issues will generally be resolved in new builds, or just by the reinstall process. Also ensure you have the latest version of Flash and any other plugins you might be using. If an update/reinstall doesn't work, try doing a clean install which removes all userdata during the uninstall process. Your userdata will be restored if you are using a Maxthon Passport. If you're using a local/guest account, make sure you have a backup of your Maxthon userdata folder (Open an explorer window and type the following into the address bar: %appdata%\Maxthon3\Users\guest). Keep a copy this folder, then copy it back once you have reinstalled. 2 /Do a forum search. Chances are someone has had the issue before you and a fix has been found. If you find a solution that works, reply in the thread so others know that it has worked for other users as well. 3 /Try changing to Retro Mode. A great feature of Maxthon that allows you to view a site using the Internet Explorer renderer in case the site has issues with Webkit/Blink. Main Menu > Switch Browser Core, or press the lightning button on the right of the address bar so it changes to a broken blue page. 4 /Connection error? (eg. unable to resolve domain name or can't connect error) try with another browser to see if it also has the same issue. Use a site likehttp://isup.me to check that the site is in fact online. Also check there isn't a problem with your DNS servers. You can try testing with Google (8.8.8.8) or OpenDNS (208.67.222.220) servers. And always provide a link to the site/page in question when posting so others can check to see if the problem is more widespread. 5 /Try disabling AdBlock Plus. Sometimes overly aggressive blocking can cause issues on a site. If this fixes the problem some of your rules may need to be revised. Post on the forum and someone should be able to offer a solution. 6 /Try deleting/clearing cookies There might be a corrupt or invalid cookie causing the problem. Deleting them will ensure new ones are created. Option 1: (Ctrl-Shift-Del) or from the Main Menu > Clear Browsing Data menu option, or toolbar. [Images here] Option 2: To delete cookies for only one site you can use the Developer Tools. [Images here] Option 3: You can also use the following 3rd party programs: -CookieSpy which can show Maxthon cookies, and DB Browser for SQLite which offer more advanced means of working with cookies. [More details here]NOTE: Only option 1 is recommended. Options 2 & 3 are only for advanced users. 7 /Try disabling all extensions. If disabling extensions fixes the problem then one of your extensions is causing the problem. Enable them one by one testing after each until you find the one causing the problem. 8 /Check the advanced options. Ensure you are using the default User Agent (should be unchecked), check with GPU acceleration on/off, and ensure that "Allow all sites to run plug-ins is enabled" if trying to troubleshoot a plugin related problem. These can be found by going to Main Menu > Settings > Advanced. If the above steps don't resolve the issue, follow the next steps which should help determine if the problem is with Maxthon, your account settings or system related and hopefully lead to the cause of the problem. 9 /Sign out of your Maxthon Passport. Check to see if the same problem still occurs. If not signing in fixes the problem, then it's more than likely a settings related issue. Disable all sync options from the menu then enable them one by one, testing for the problem until it occurs again. Once you know which settings are causing the issue make a post on the forum with the details for further assistance. 10 /Test with Maxthon Portable. Download & extract to any folder, run, check for the issue. DO NOT SIGN IN to your Maxthon Passport account. If this works then it's more than likely related to your install. Doing a clean install should fix the problem. If going through the above doesn't fix the problem, then start a thread on the forum to see if someone can help out. Offer as much information as you can, especially the following: - Any error messages; - What version of Maxthon and operating system you are running; - Any out of the ordinary programs (network related like firewalls, or downloaders like Orbit); - What you have tried to fix/find out what the issue was. Otherwise people will offer solutions that you may have already done; - And if applicable link some screenshots if it will make things easier for others to understand the problem. The best case scenario is you will find and fix the issue without having to wait hours or days for a response on the forum. At minimum you will narrow in on the issue allowing others to offer a quicker and more appropriate response for the problem. And you may learn something as well :-) Happy troubleshooting!
  21. Just did a test using a random socks5 proxy. Seems to be working. Test the same with a portable version of Maxthon and see if anything changes. You say "my", does that mean one you've setup? If so, you may need to check your settings. Also make sure that you have actually selected and enabled the correct proxy - there should be a tick to the left of the name in the settings page. And make sure you select the correct type from the dropdown when adding (socks5/4/HTTP etc) NOTE: the below is the proxy IP, not mine!
  22. Can't confirm. Tested with auto and manual mode and both worked. Also with generic profile info. I can only recommend deleting any saved data for that site and entering, saving it again.
  23. These sections don't use the standard forum structure. The links on the front page are only a redirect to this section, and that's why it doesn't quite work the same as the normal sections. Not something that can or will be fixed to my knowledge. You can use the custom option to set that to last comment & descending. Only problem is that the setting isn't saved for future views. @BugSir005 Can that be made the default option?