Archived

This topic is now archived and is closed to further replies.

rick.lane

pc issue Missing External Tools toolbar icon

19 posts in this topic

I only noticed this today with the new 5.0.3.1400. The icon for the external tools is not appearing in the toll bar even though it is checked in Settings>Functions and Addons>Maxthon Tools. Sorry if this has been a known issue that I missed earlier, though I don't recall seeing any discussion about it before. I have added several apps to that function, so it was working not that long ago and just thought I should bring it to your attention. Thanks.

Share this post


Link to post
Share on other sites

What is that supposed to be showing me? I don't have those 3 dots so no dropdown. And I don't have that many icons in my toolbar as I have most disabled. I have ABP, Snap, Download manager, and  Night Mode, but no External Tools and no 3 dot drop down. Just installed new version today. Thanks for trying. 

Share this post


Link to post
Share on other sites

I just turned everything off, then turned on just External Tools and indeed it did not show. But after enabling some of the other items it then did come back. Then turned off all the rest leaving the ET icon there.

So seems that it could be some bug. But if you play around with turning them on/off you should get it back.

1 person likes this

Share this post


Link to post
Share on other sites
28 minutes ago, 7twenty said:

I just turned everything off, then turned on just External Tools and indeed it did not show.

also confirmed here. 

But maybe not the same issue with the OP?

Share this post


Link to post
Share on other sites
8 hours ago, rick.lane said:

What is that supposed to be showing me? I don't have those 3 dots so no dropdown. And I don't have that many icons in my toolbar as I have most disabled. I have ABP, Snap, Download manager, and  Night Mode, but no External Tools and no 3 dot drop down. Just installed new version today. Thanks for trying. 

Aren't you using Wilser's #1 Skin?  That is what I'm using and I have all of the icons showing as well as the three dots.

Share this post


Link to post
Share on other sites
4 hours ago, No.1MaxthonFan said:

Aren't you using Wilser's #1 Skin?  That is what I'm using and I have all of the icons showing as well as the three dots.

I am using Wilser's skin, but I also went back and used the original dat files, went back to original skin and still no External tools icon. Then went back to Wilser's and again no External Tools icon. I will try what what 7twenty suggested and see what happens. 

Share this post


Link to post
Share on other sites
1 hour ago, rick.lane said:

I am using Wilser's skin, but I also went back and used the original dat files, went back to original skin and still no External tools icon. Then went back to Wilser's and again no External Tools icon. I will try what what 7twenty suggested and see what happens. 

That is so strange.  I haven't done anything special and as you can see, all 9 icons are there.  Hope you get yours fixed.

Skin.png

Share this post


Link to post
Share on other sites

This is interesting. I didn't do a complete clean install and therefore this installation is still using the Maxthon5 data file in Roaming. Before renaming that file and starting over, I opened a still installed Maxthon 5.0.2.2000 version, which uses the same Maxthon 5 data file, and lo and behold, the External Tools icon was there, which indicates to me that it is not necessary for me to rebuild that roaming file. Following 7twenty's suggestions did not result in the icon appearing. Next!

Edit/additional: I found that every other available toolbar icon will appear when activated/shown a soon as I put a check in the box but still no external tools. So, I have no idea why No.1 is having it display and I don't and maybe 7twenty and BugSir006 had issues as well (Yes, BugSir006, it seems to be the same issue). At a loss right now.

 

Share this post


Link to post
Share on other sites
25 minutes ago, rick.lane said:

This is interesting. I didn't do a complete clean install and therefore this installation is still using the Maxthon5 data file in Roaming. Before renaming that file and starting over, I opened a still installed Maxthon 5.0.2.2000 version, which uses the same Maxthon 5 data file, and lo and behold, the External Tools icon was there, which indicates to me that it is not necessary for me to rebuild that roaming file. Following 7twenty's suggestions did not result in the icon appearing. Next!

Edit/additional: I found that every other available toolbar icon will appear when activated/shown a soon as I put a check in the box but still no external tools. So, I have no idea why No.1 is having it display and I don't and maybe 7twenty and BugSir006 had issues as well (Yes, BugSir006, it seems to be the same issue). At a loss right now.

 

I had to toggle the external tool addon in functions and addons in settings to get it to show on the tool bar.

Share this post


Link to post
Share on other sites
24 minutes ago, PHYR said:

I had to toggle the external tool addon in functions and addons in settings to get it to show on the tool bar.

Yes, that what's I've been doing a dozen times or more. Where did you think I was enabling/disabling the addons? 

Share this post


Link to post
Share on other sites

Not sure what you are trying to say, Phyr, but I finally got the External Tools icon to appear. I loaded the toolbar with every item that could be enabled and the External Tools finally showed up. Then I went and disabled all but the 5 I wanted and it seems to be sticking, even after a few restarts. I actually reinstalled the 1400 beta into a new folder (I had been installing all of the 3.0.5.x betas and tests over each other in a folder started with the first 5.0.3 beta) and got the same result with no External Tools icon. I loaded that install's tool bar with all of the possible icons and got the Ext. Tools icon to show. Then went back to the original installation and made it work on that installation. No idea why this worked or why it wasn't working in the first place.
However, I still don't see the 3 dots regardless of how many items I have enabled in the tool bar or what setting I have set for the address bar (using Wilser's skin with tabs below address bar). Minor annoyances but the browser still browses just fine.

Share this post


Link to post
Share on other sites
41 minutes ago, rick.lane said:

Not sure what you are trying to say, Phyr, but I finally got the External Tools icon to appear. I loaded the toolbar with every item that could be enabled and the External Tools finally showed up. Then I went and disabled all but the 5 I wanted and it seems to be sticking, even after a few restarts. I actually reinstalled the 1400 beta into a new folder (I had been installing all of the 3.0.5.x betas and tests over each other in a folder started with the first 5.0.3 beta) and got the same result with no External Tools icon. I loaded that install's tool bar with all of the possible icons and got the Ext. Tools icon to show. Then went back to the original installation and made it work on that installation. No idea why this worked or why it wasn't working in the first place.
However, I still don't see the 3 dots regardless of how many items I have enabled in the tool bar or what setting I have set for the address bar (using Wilser's skin with tabs below address bar). Minor annoyances but the browser still browses just fine.

You asked me where I thought you were disabling the extensions from, so I showed you. Try hiding an extension from the tool bar and see if you now see the three dots at the end of the tool bar. If you don't it is likely an issue  with wilsers skin and not with Maxthon.

Share this post


Link to post
Share on other sites
1 hour ago, PHYR said:

Try hiding an extension from the tool bar and see if you now see the three dots at the end of the tool bar. If you don't it is likely an issue  with wilsers skin and not with Maxthon.

I'm using the same Wilser skin as Rick and I have the three dots.

 

Share this post


Link to post
Share on other sites
3 hours ago, No.1MaxthonFan said:

I'm using the same Wilser skin as Rick and I have the three dots.

 

Do you have any extensions hidden?

Share this post


Link to post
Share on other sites

All is well now.The reason that I had no three dots was that I had no extensions "hidden"; they were either enabled and shown, or disabled. So with none "hidden", there is no 3 dots and dropdown. And the External Tools icon now shows all of the time but  it does show up late when the browser is restarted, most likely because I have added several apps to it and they need to load. And all is well with the new beta 5.0.3.2000 with and without Wilser's skin mod. Thanks for the help fellows.

Share this post


Link to post
Share on other sites
20 minutes ago, rick.lane said:

All is well now.The reason that I had no three dots was that I had no extensions "hidden"; they were either enabled and shown, or disabled. So with none "hidden", there is no 3 dots and dropdown. And the External Tools icon now shows all of the time but  it does show up late when the browser is restarted, most likely because I have added several apps to it and they need to load. And all is well with the new beta 5.0.3.2000 with and without Wilser's skin mod. Thanks for the help fellows.

I'll take that as a thank you, so, you're welcome.

Share this post


Link to post
Share on other sites

Just for grins, here is a shot of my desktop/QA using Wilsers "tabs below address bar" skin and with some other color modifications with Mx 5.0.3.2000. QA background is an old custom wallpaper image from earlier Maxthon versions. External tools icon is displayed and the 3 dots are there as I now have an extension "hidden". All is good. Hope you all like the screen shot. And thank you to all that tried to help me out.

Green MX5 QA Desktop.jpg

Share this post


Link to post
Share on other sites