Mr. SS

pc issue Maxthon failing to install

10 posts in this topic

I upgraded to a new computer last week, Ryzen Threadripper with Windows 10, and Maxthon fails to install on this configuration. The previous version installer (5.1.2.1000) would count to 16 and then stop, the new version (5.1.2.3000) goes only to 5. Task manager shoes some activity for the install process (under 1% CPU usage, but some constant memory used changes), yet it never moves past 5. I have tried running the installer with various compatibility settings and with admin privileges, but nothing changes. The portable versions work fine, so this seems to be a purely installer issue.

Anyone have any ideas?

Share this post


Link to post
Share on other sites

Same here, past two official installs, plus the beta get to 5 and stop.

Using portable now also

Attached sysinfo maybe a Ryzen bug?

sysinfo.txt

Share this post


Link to post
Share on other sites

can't past 5% or lagging at 5% then could continue install? 

Please check whether MD5  is correct after downloading.(By using MD5Calc)

Share this post


Link to post
Share on other sites

Posted (edited)

I have the same problem. With Win10(uptodate) + Ryzen I'm unable to install/unistall Maxthon, used versions are 5.1.2.1000/2000 and 3000, it goes up to whatever %(5 or 30 or smth else) and gets stuck there forever. After a while I end the process with task manager and see that there is a Maxthon folder in Program files, but can't start it or uninstall it because it gives me error message that files are missing. Portable version works and Chrome/Firefox/Opera can install itself without error. I even reinstalled Win10 but i'm still unable to install Maxthon.

I can install 5.1.2.1000 without problems on my other PC(Win7+Phenom II)

Edited by Ralf542

Share this post


Link to post
Share on other sites
14 hours ago, Ralf542 said:

I have the same problem. With Win10(uptodate) + Ryzen I'm unable to install/unistall Maxthon, used versions are 5.1.2.1000/2000 and 3000, it goes up to whatever %(5 or 30 or smth else) and gets stuck there forever. After a while I end the process with task manager and see that there is a Maxthon folder in Program files, but can't start it or uninstall it because it gives me error message that files are missing. Portable version works and Chrome/Firefox/Opera can install itself without error. I even reinstalled Win10 but i'm still unable to install Maxthon.

I can install 5.1.2.1000 without problems on my other PC(Win7+Phenom II)

Please check whether MD5  is correct after downloading.(By using MD5Calc)

Share this post


Link to post
Share on other sites
24 minutes ago, BugSir006 said:

Please check whether MD5  is correct after downloading.(By using MD5Calc)

Checked/downloaded multiple times and it's correct.

Share this post


Link to post
Share on other sites

Ok We have marked this issue.Now our develop-team is trying to investigate the reason caused this issue. Thanks for all your feedback.

Share this post


Link to post
Share on other sites

Any news on this, any beta coming up with the problem solved?

Share this post


Link to post
Share on other sites
3 hours ago, Mr. SS said:

Any news on this, any beta coming up with the problem solved?

Here's something I want to confirm with users who met this issue.

Please check Win+R-%Temp%-find a folder named temp_number(like this)

1.png

And then check whether the contents in the folder is complete(like these following images)

If the contents in folder is uncomplete or missing a part of content, that means it have something wrong with computer during install process.

Forward your reply 

)2.png

3.png

Share this post


Link to post
Share on other sites

This is how my last attempted install (latest beta) temp folder looks.

Clipboard01.jpg

Clipboard02.jpg

Share this post


Link to post
Share on other sites