Jubilar

pc issue [5.1.0.1900] default browser

16 posts in this topic

Posted (edited)

mx5 - default browser in my system (win7 32). but if set this checkbox in browser settings

MaxthonSnap20170704111607.png,

after each launch i have pop-up window

Безымянный.png

and also mx5 became the default to open *.pdf, *.jpg, *.png and other pictures formats. its not good :(

 

Edited by Jubilar

Share this post


Link to post
Share on other sites

Posted (edited)

I wrote about this on my Blog. So far, it's all I've found. I think you can live with it.

Edited by Chantao

Share this post


Link to post
Share on other sites
5 hours ago, Jubilar said:

and also mx5 became the default to open *.pdf, *.jpg, *.png and other pictures formats. its not good :(

It's a "feature" of the latest version.

 

Share this post


Link to post
Share on other sites
18 minutes ago, 7twenty said:

It's a "feature" of the latest version.

 

define 'feature' - its far from that - its at best an imposition - at worst arrogance on the part of the devs thinking users would want this

easy enough to sort by going into windows default settings but that should not be needed

what other browser has this 'feature'

1 person likes this

Share this post


Link to post
Share on other sites
14 minutes ago, Tony said:

define 'feature' - its far from that -

I know, hence the quotes to indicate sarcasm... :D 

1 person likes this

Share this post


Link to post
Share on other sites

It is not as if it is bad, but always, when one logs on with the browser, he wants confirmation that he is the main browser and then every time pdf or png is switched to Maxthon. If you have then changed everything by hand everything is then automatically changed all at once.

So: Maxthon NO MORE THE MAINBROWSER:

Share this post


Link to post
Share on other sites
18 minutes ago, Chantao said:

It is not as if it is bad,

True, it's an option that a user might find handy. The problem is that it's been implemented wrong (no user notification) and causes grief for users that want the browser as default and no associations to media files without knowing why it's happening.

For those of you with the issue, are the checkboxes in Settings > Advanced > Default file type > File type association settings checked or not?
MaxthonSnap20170704231958.png

If they are checked (as above), then uncheck them and see if the problem goes away.

If they're not checked and the problem still occurs then it's a problem.

(ignore the red boxes, image was originally used for something else)

1 person likes this

Share this post


Link to post
Share on other sites

and ALL steam-game shortcuts on desctop are changed to Maxthon Url File (.url)

1 person likes this

Share this post


Link to post
Share on other sites

on another my pc with win10 with this checkbox

MaxthonSnap20170704111607.png
and this 

Снимок экрана20170704213523.png

i dont have pop-up window.

all formats back to other programs except *.pdf. manualy change to adobe reader. tomorrow check on another pc.

i think that by default all the checkboxes should be disabled. think about it

1 person likes this

Share this post


Link to post
Share on other sites

Hi Maxthon support,

are you ensure only you list on MX5.

please check you windows, 

the everything is changed, including pdf, rm, rmvb, wmv, mkv.....

 

all the audio, video, pictures, pdf......

too much file is changed......

 

you are a browser, you are not reader...  the internet browser should be work well on internet access.

if you want bring more support feature, please set to options, and default is not turn on it with a notice to user only.

otherwise, you set the function on "set to default browser" to set everything to MX default.

how come? if you create a item to set other file type as MX5 to open it default as good way. 

 

This is BAD BAD BAD BAD version.

 

and it's noway to disable it.

When I set the pdf to adobe reader, then open MX5. the file will set to MX5 again.

it's noway to disable it!

 

everything is set to MX5. including all audio file.....

please fix this big big big big problem ASAP!!!!!!! 

Share this post


Link to post
Share on other sites
11 hours ago, 7twenty said:

If they are checked (as above), then uncheck them and see if the problem goes away.

If they're not checked and the problem still occurs then it's a problem.

Just did this test myself. It's broken.

You can uncheck them but they keep on getting checked again.

The recommendation from me is to not bother with this version. Will hopefully be fixed to work properly in the next version.

Share this post


Link to post
Share on other sites
2 hours ago, 7twenty said:

Just did this test myself. It's broken.

You can uncheck them but they keep on getting checked again.

The recommendation from me is to not bother with this version. Will hopefully be fixed to work properly in the next version.

yep, you need to change the file association in windows,  but it's a lot of work...

besides, my file association window in maxthon looks different than yours (I have more file types than you )

files.png

 

Share this post


Link to post
Share on other sites

Steam links on desktop are broken! To corect this for ".URL" extension change association from "MX5" to "Browser"

Share this post


Link to post
Share on other sites

test on my pc with win7. in contrast to Win10, on Win7 with this checkbox

MaxthonSnap20170704111607.png

i still couldnt achieve the absence of a pop-up window :(

Share this post


Link to post
Share on other sites

Try to once "run as administrator"

Share this post


Link to post
Share on other sites