Archived

This topic is now archived and is closed to further replies.

AndroidDeveloperLB

resolved Bug: can't choose to reply on "medium.com" website

7 posts in this topic

Confirmed here as well.

Share this post


Link to post
Share on other sites
16 hours ago, AndroidDeveloperLB said:

Example:

https://medium.com/@quiro91/sharing-files-though-intents-are-you-ready-for-nougat-70f7e9294a0b#.tgeqropti

Try on MX5 ( 5.0.2.1600) and Chrome. For some reason, on MX5, it doesn't show the textbox of "write a response", or anything similar that can trigger showing it.

works fine using magadalene's user agent 

 

1 person likes this

Share this post


Link to post
Share on other sites
1 hour ago, -ody- said:

works fine using magadalene's user agent 

Doesn't like "Maxthon" in the string. Remove that part and it shows as expected. I expect that will be fixed by them pushing a modified UA for this site.

Surprised I didn't pickup on that when i posted above. UA checks is generally one of the first checks.

Share this post


Link to post
Share on other sites

Why should a website remove such a thing based on UA

Also, since Maxthon still doesn't allow specific UA per website, I think it still is an issue.

Setting a UA of Chrome might fix it here, but might cause issues somewhere else.

Share this post


Link to post
Share on other sites

No idea, but it's not the first time it's happened. More than likely it sees it as an unknown/unsupported browser so somehow things get broken, changed because of it.

MX actually does allow specific UA's per site, as I said above, just that it's not user configurable. The MX dev's can push custom UA's when a certain site is detected, the same way some sites automatically go to Retro mode.

Actually, using a Chrome UA might be the best option as default. Very few sites would care about Maxthon being in the string, Having a more common UA should get you less errors.

Share this post


Link to post
Share on other sites