Archived

This topic is now archived and is closed to further replies.

badnick

winpc issue Many more things about MX5

24 posts in this topic

After about 1 year I return to MX to see if it is some improvements and indeed there are: no more troubles with videos playing  or unexpected autorefreshing and generally browsing is smoothly and fast.

But I'm wonder why that basic(in my opinion) options had complete disappeared: focusing on a new open tab (like in Firefox for example-„When I open a link in a new tab, switch to it immediately”-). This option exists in earlier versions of MX4(Ctrl+click) but best would be if you could do with the right-click menu from mouse.

Also I don’t know why it’s so hard to implement other basic option: the complete session restore (with more than one window).

Other basic option such as when restoring session  to load only active tab not all tabs . This is very useful for not useless charging RAM memory, because generally you don not need instantly for all restored tabs.

Why it’s so hard to implement this basic options, that other browsers have much for a long time?

On the other hand, now I run MX 5.0.2.900 –portable version..wich start every time in a strange mode like when i run an installing patch (see atached pictures). And I see that is a new version 5.0.2.1000 but the browser has no option to update..(chek for updates).What should I do in this case?

Screenshot (69).png

Screenshot (70).png

Screenshot (71).png

Share this post


Link to post
Share on other sites
2 hours ago, badnick said:

This option exists in earlier versions of MX4(Ctrl+click)

Shift+click actually. And Shift+Ctrl+click in MX5.

Add a shortcut for Shift+Ctrl+Click to your mouse if you can and use that to open new links in that fashion if required.

2 hours ago, badnick said:

Also I don’t know why it’s so hard to implement other basic option: the complete session restore (with more than one window).

yep, another one that has been asked about for a while.

2 hours ago, badnick said:

On the other hand, now I run MX 5.0.2.900 –portable version..wich start every time in a strange mode like when i run an installing patch (see atached pictures). And I see that is a new version 5.0.2.1000 but the browser has no option to update..(chek for updates).What should I do in this case?

Make sure the auto-login option is checked in the settings button in the top right. I think one version had an issue where that setting wouldn't stick.

I don't think Portable updates automatically? Only option is to get new updates from the forum. Someone might be able to confirm that.

Share this post


Link to post
Share on other sites
2 hours ago, 7twenty said:

Shift+click actually. And Shift+Ctrl+click in MX5.

Add a shortcut for Shift+Ctrl+Click to your mouse if you can and use that to open new links in that fashion if required.

yep, another one that has been asked about for a while.

Make sure the auto-login option is checked in the settings button in the top right. I think one version had an issue where that setting wouldn't stick.

I don't think Portable updates automatically? Only option is to get new updates from the forum. Someone might be able to confirm that.

Thank you 7twenty!

Share this post


Link to post
Share on other sites
2 hours ago, 7twenty said:

Shift+click actually. And Shift+Ctrl+click in MX5.

Add a shortcut for Shift+Ctrl+Click to your mouse if you can and use that to open new links in that fashion if required.

yep, another one that has been asked about for a while.

Make sure the auto-login option is checked in the settings button in the top right. I think one version had an issue where that setting wouldn't stick.

I don't think Portable updates automatically? Only option is to get new updates from the forum. Someone might be able to confirm that.

But still I can not find this option "auto-login"

Share this post


Link to post
Share on other sites
6 hours ago, badnick said:

But still I can not find this option "auto-login"

snap_screen_20170103084857.png

Share this post


Link to post
Share on other sites
9 hours ago, 7twenty said:

snap_screen_20170103084857.png

I thought it's about "settings" from Maxthon menu, that's why they not found myself. Checked but unfortunatelly Maxthon don't keep this settins.Thank you anyway

Share this post


Link to post
Share on other sites

Update to .1000. One of the older versions had an issue where it wouldn't save the auto-login option. Could be the one you're using.

Share this post


Link to post
Share on other sites
7 minutes ago, 7twenty said:

Update to .1000. One of the older versions had an issue where it wouldn't save the auto-login option. Could be the one you're using.

IF I update to 1000 , I think I loose all my bookmarks/history..etc, because I'm on portable version and has no update option (check for updates) -I should delete this version and install the last -1000

Share this post


Link to post
Share on other sites
3 hours ago, badnick said:

IF I update to 1000 , I think I loose all my bookmarks/history..etc, because I'm on portable version and has no update option (check for updates)

Not sure where you got that idea?! The best part of using a portable version is that you can do whatever you want to the data, and always have a backup to go back to, not relying on installers or other means to update your data.

Do the following and you should be good to go:

Move your current Maxthon folder to another location as a backup. 

Extract the latest version of MX portable.

Copy over the userdata\users\guest and\or userdata\users\[YOUR_EMAIL] folders to the newly extracted Maxthon folder.

When Maxthon starts it should run as though nothing has changed - with all of your data intact - but it will be the latest version.

If for whatever reason something isn't right/doesn't work, just delete that folder and copy back the one that you saved elsewhere as a backup. You'll be back to where you were previously.

Share this post


Link to post
Share on other sites
18 minutes ago, 7twenty said:

Not sure where you got that idea?! The best part of using a portable version is that you can do whatever you want to the data, and always have a backup to go back to, not relying on installers or other means to update your data.

Do the following and you should be good to go:

Move your current Maxthon folder to another location as a backup. 

Extract the latest version of MX portable.

Copy over the userdata\users\guest and\or userdata\users\[YOUR_EMAIL] folders to the newly extracted Maxthon folder.

When Maxthon starts it should run as though nothing has changed - with all of your data intact - but it will be the latest version.

If for whatever reason something isn't right/doesn't work, just delete that folder and copy back the one that you saved elsewhere as a backup. You'll be back to where you were previously.

It worked.Tks again!

Share this post


Link to post
Share on other sites
35 minutes ago, 7twenty said:

Not sure where you got that idea?! The best part of using a portable version is that you can do whatever you want to the data, and always have a backup to go back to, not relying on installers or other means to update your data.

Do the following and you should be good to go:

Move your current Maxthon folder to another location as a backup. 

Extract the latest version of MX portable.

Copy over the userdata\users\guest and\or userdata\users\[YOUR_EMAIL] folders to the newly extracted Maxthon folder.

When Maxthon starts it should run as though nothing has changed - with all of your data intact - but it will be the latest version.

If for whatever reason something isn't right/doesn't work, just delete that folder and copy back the one that you saved elsewhere as a backup. You'll be back to where you were previously.

But the  logins issue remained. Still don't remember the setting. Finally it's not such a big problem.

Share this post


Link to post
Share on other sites
22 hours ago, 7twenty said:

Not sure where you got that idea?! The best part of using a portable version is that you can do whatever you want to the data, and always have a backup to go back to, not relying on installers or other means to update your data.

Do the following and you should be good to go:

Move your current Maxthon folder to another location as a backup. 

Extract the latest version of MX portable.

Copy over the userdata\users\guest and\or userdata\users\[YOUR_EMAIL] folders to the newly extracted Maxthon folder.

When Maxthon starts it should run as though nothing has changed - with all of your data intact - but it will be the latest version.

If for whatever reason something isn't right/doesn't work, just delete that folder and copy back the one that you saved elsewhere as a backup. You'll be back to where you were previously.

Now Maxthon don't remember login names

Share this post


Link to post
Share on other sites
1 hour ago, badnick said:

Now Maxthon don't remember login names

Some more info would be handy.

Which sites? Is it for sites that used to work? Are the details saved in passkeeper but don't fill? Are they just not being saved? Is it all sites or just one?

 

Share this post


Link to post
Share on other sites
1 hour ago, 7twenty said:

Some more info would be handy.

Which sites? Is it for sites that used to work? Are the details saved in passkeeper but don't fill? Are they just not being saved? Is it all sites or just one?

 

For the moment I tested just in facebook. I made no change in Maxthon  "settings". Before I made the installation of MX 5.0.2.1000 from you suggestions, the sites (Facebook) remember the login name after exit from Maxthon and reopen the browser. But after installing new version Maxthon don;t remember login names if you exit from Maxthon and reopen.

Share this post


Link to post
Share on other sites
1 hour ago, 7twenty said:

Some more info would be handy.

Which sites? Is it for sites that used to work? Are the details saved in passkeeper but don't fill? Are they just not being saved? Is it all sites or just one?

 

To be clear, I don'have magic fill enabled neither before nor now because I dont' want to save passwords. Before instalation of new version If I clicked in the Facebook window for login name, a drop-down menu with the login names used is open and you  could choose  from them. Now if I click in the window for login names It does not appear anything.

   

Share this post


Link to post
Share on other sites

one day a guy was complaining here, that even when magicfill wasn't enabled you could have last entered usernames proposal.

when you change a portable version last names are not available that the point.

now if nothing appears that's probably because of this guy complaint

to be confirmed

Share this post


Link to post
Share on other sites
13 minutes ago, karajan said:

one day a guy was complaining here, that even when magicfill wasn't enabled you could have last entered usernames proposal.

when you change a portable version last names are not available that the point.

now if nothing appears that's probably because of this guy complaint

to be confirmed

Tried with magic fill enabled(manual) and still dont't work. I think something is broken when I installed the new version after the method suggested by 7twenty

Share this post


Link to post
Share on other sites

 

6 hours ago, badnick said:

Before instalation of new version If I clicked in the Facebook window for login name, a drop-down menu with the login names used is open and you  could choose  from them. Now if I click in the window for login names It does not appear anything.

Just to be certain, your issue isn't that you need to login to sites every time you restart Maxthon, it's that the dropdown of previously used logins no longer shows. Correct?

1 hour ago, badnick said:

Tried with magic fill enabled(manual) and still dont't work.

That makes sense, as it was determined that the dropdown you want wasn't related to MagicFill/Passkeeper.

Have you since logged in to facebook? And does it remember that most recent entry? Sounds like it's just all the logins since the "update" that have been lost.

I tested on mine and the dropdown is still there, but it seems to be per session. So if you exit Maxthon it removes those details. Which is what MagicFill/Passkeeper should be used for.

I think you may have been stuffed around by utilising a work-in-progress feature and the current change has affected your workflow.

Could be a bug that may be fixed at some stage. Or this could be the fix for issue that karajan mentioned.

Your options at this stage would be go back to your previous version. Or start using Passkeeper for login details.

Share this post


Link to post
Share on other sites
24 minutes ago, 7twenty said:

 

Just to be certain, your issue isn't that you need to login to sites every time you restart Maxthon, it's that the dropdown of previously used logins no longer shows. Correct?

That makes sense, as it was determined that the dropdown you want wasn't related to MagicFill/Passkeeper.

Have you since logged in to facebook? And does it remember that most recent entry? Sounds like it's just all the logins since the "update" that have been lost.

I tested on mine and the dropdown is still there, but it seems to be per session. So if you exit Maxthon it removes those details. Which is what MagicFill/Passkeeper should be used for.

I think you may have been stuffed around by utilising a work-in-progress feature and the current change has affected your workflow.

Could be a bug that may be fixed at some stage. Or this could be the fix for issue that karajan mentioned.

Your options at this stage would be go back to your previous version. Or start using Passkeeper for login details.

Yes, you described correctly! Now, the dropdown don't remember previous entryes if I logout from Maxthon. In the previous version was not so, the dropdown remembered the previous entry even if I logout from Maxthon and even with the magic fill unchecked.

Share this post


Link to post
Share on other sites
2 hours ago, badnick said:

and even with the magic fill unchecked

Again, this isn't related to magicfill/passkeeper.

You will have to wait for a response from a bugsir/miss to see if this is a bug or a fix from the previous issue mentioned.

@BugSir006

Share this post


Link to post
Share on other sites
6 hours ago, badnick said:

Yes, you described correctly! Now, the dropdown don't remember previous entryes if I logout from Maxthon. In the previous version was not so, the dropdown remembered the previous entry even if I logout from Maxthon and even with the magic fill unchecked.

No it didn't, unless you had previously logged in while logged out of your account.

Share this post


Link to post
Share on other sites
6 minutes ago, PHYR said:

No it didn't, unless you had previously logged in while logged out of your account.

I think he meant "exit" as stated in an earlier post, rather than logout. Either way exiting/logging out deletes any entries when going back to the same account.

I still think this is a fix for the privacy issue mentioned earlier.

Share this post


Link to post
Share on other sites
On 05.01.2017 at 6:52 AM, 7twenty said:

I think he meant "exit" as stated in an earlier post, rather than logout. Either way exiting/logging out deletes any entries when going back to the same account.

I still think this is a fix for the privacy issue mentioned earlier.

Yes, it's about "exit" not "logout". But it's really annoying. Even with the "magic fill" enabled (manual)..still don't work. One step forward , 2 steps back.

Share this post


Link to post
Share on other sites
On 04.01.2017 at 11:50 PM, 7twenty said:

 

Just to be certain, your issue isn't that you need to login to sites every time you restart Maxthon, it's that the dropdown of previously used logins no longer shows. Correct?

That makes sense, as it was determined that the dropdown you want wasn't related to MagicFill/Passkeeper.

Have you since logged in to facebook? And does it remember that most recent entry? Sounds like it's just all the logins since the "update" that have been lost.

I tested on mine and the dropdown is still there, but it seems to be per session. So if you exit Maxthon it removes those details. Which is what MagicFill/Passkeeper should be used for.

I think you may have been stuffed around by utilising a work-in-progress feature and the current change has affected your workflow.

Could be a bug that may be fixed at some stage. Or this could be the fix for issue that karajan mentioned.

Your options at this stage would be go back to your previous version. Or start using Passkeeper for login details.

Reinstalled MX5 without the trick with the bookmarks/history folder from the previous version. Now Maxthon remember login names after exit, but only in normal mode not in private.

Share this post


Link to post
Share on other sites