What has happened with this glorious browser


Recommended Posts

After recent updates it works as slow as a snail. I remember times when this  browser was as fast as rabbit and now it works like an old retard guy. My CPU is quite good, it always has been working very fast but maxthon is using all CPU capacity. Opening multiple tabs at once takes forever. Even opening empty tab with speed dial takes a sec or 2 to load. What has happened with this browser. It became totally slow and unoptimized. I remember when this browser was the best about smooth scrolling. Even doint multiple things at once, opening tabs etc the scrolling was always smooth, and now, It works as slow as blind guide dog with no paws and no head. Sorry, do something with that. I don't know why this browser need 100% of my processor to open 2 simple tabs. Edge is working must faster and is becoming more reliable than this. Please, bring back maxthon's glory back.

Link to post
Share on other sites
6 hours ago, CorbanWolf said:

I don't know why this browser need 100% of my processor to open 2 simple tabs.  

there's obviously something wrong there...

same questions as above : what is your version ? did you perform a clean install ? extensions ?

see here please :

 

 

 

Link to post
Share on other sites

I'm using the newest version 5.1.0.3000. But it is not only about this version, Previous ones also were slow. I tried to change to retro mode but it's still the same. For example. When I go to deviantart.com. And the open 3 new tabs in the background of deviantart site, as I counted, it takes 4second of 100% usage of my CPU to go to normal about 10%. And when I open only 2 tabs, it takes 2seconds of 100% CPU usage. On your forum on this site, it takes some seconds but my CPU is used in only 65%. But again, for example in Furaffinity opening 3 tabs takes 100% of my CPU. Also there happens a hangs. When I open some tabs etc, and then closing one causes a serious delay. For about 2 seconds I wait till my tab is closed. I'll try clean install.

 

Just tried it. When I open 3 tabs and then they are still loading and i try to open 2 new tabs for example. it is not opened, i have to wait 3 seconds till previous tabs are opened and loaded and then another 2 tabs cannot be opened, i mean, even the "literal" tabs on the top of window of maxthon doesnt show up. I just have to wait those seconds to have them appeared in tab section. It is very frustrating 

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.