Archived

This topic is now archived and is closed to further replies.

Eightysevens

Adblock enabled but ads not blocked in google

Recommended Posts

i found an easier way to solve the problem, or at least it worked for me:

 

just go to "menu" -> extensions  and disable or uninstall the "search" extension.

 

 

 

no more ads in google!

 

Anyway i have to say i'm quite disappointed with maxthon :\

Share this post


Link to post
Share on other sites

I described this problem, reasons and solution in new topic about this specific issue - so the solution will be more visible to users.

 

It confused me a lot. I thought I got some kind of malware on my PC and I got worried :/ 

 

http://forum.maxthon.com/index.php/topic/15788-maxthon-inserts-graphic-advertisements-on-google-search-page/

Share this post


Link to post
Share on other sites

here search extension is disabled, but I didn't delete any rules (as described above), and I have no ads either.

so it may be related to search extension, even if deleting those global rules probably helps.

Share this post


Link to post
Share on other sites

On my main install i have disabled the extension & removed the ABP exceptions = no ads.

On a test install the extension is enabled and the ABP exceptions were not deleted = no ads

 

Only difference is one is on Win8.1 other is Win10 Preview. There are no other adjustments made to HOSTS or otherwise. So it seems there's more to it than just the exceptions and the extension?.

Share this post


Link to post
Share on other sites

No. Ads are added by the extension ONLY. Adblock has nothing to do with this. Please do not confuse users more then they are already!

 

I described it in a separate thread linked above that explains everything.

 

-- if you have Search extension enable and don't see ads, why do you join the chat? The problem is not "ads are not showing", but opposite.

It may be that this extension has no ads to display in your area for example, but will show many different ads in other areas. Settings of the extension load data (ads settings) could already be changed on a server - so it depends of how, when and IF ads are displayed and it has nothing to do with the user... you can not influence that.

 

 

One more time: ADS are added to a page (after page load!) by extension called "Search". This extension is installed and enabled out of the box with newest Maxthon version.

 

http://forum.maxthon.com/index.php/topic/15788-maxthon-inserts-graphic-advertisements-on-google-search-page/

Share this post


Link to post
Share on other sites

No. Ads are added by the extension ONLY. Adblock has nothing to do with this. Please do not confuse users more then they are already!

 

Not trying to confuse anyone, just offering the results from my testing, that is - the extension has no effect and only removing the ABP exceptions makes a difference to the look of the page. How or why that is the case I can't say at this time. Also that fact that -ody- said the same means it's not 100% confirmed for all users.

 

 

I hope a rep or dev sees this post!

 

Remember this is a browser that is flaunting ABP as a major feature. If a user is on the verge of uninstalling because they think ABP isn't working, or there is something wrong with the browser, then maybe it should be reassessed if these default exceptions are worthwhile.

 

Is the few clicks gained from the ads worth the potential loss of users?

 

Going back to this, looking at the comments for this extension it seems there are quite a few unhappy users, so it's clearly causing some grief to users.

 

Again, to the devs/reps - people are actively uninstalling Maxthon due to these ads. Surely there are better ways without forcing ads onto users and ultimately to another browser. Not the best way to build up a customer base.

Share this post


Link to post
Share on other sites

I can confirm what 7twenty said.

 

Just by erasing the few lines in adblock settings , the ads are not shown anymore.

 

The extension "search" was  still active.

Share this post


Link to post
Share on other sites

I have followed steps to "clear up" the Maxthon/Adblock Plus Ad Attacks several times. Maxthon and/or Adblock Plus eventually resets and I get Ad Attacks again. I am uninstalling Maxthon from all computers I maintain because I am tired of this nonsense. It is with regret, Maxthon was for a while the Perfect browser!

 

No more. Adware infected garbage it has become. Very sad. As much as I hate to do it, back to freaking Firefox I go.

 

I delete the Search extension and it is re-installed next time I start Maxthon. I delete the lines from Adblock Whitelist Global rules as suggested, and after a few days they return.

 

If Maxthon/Adblock ever pulls their heads out of their asses and restores proper AD FREE function, please send me an email. MAYBE I will try it again.

Share this post


Link to post
Share on other sites

Hmmm well that's at least 3 people in the forum removing Maxthon after this debacle. I'm wondering if the Chinese forum is getting the same feedback, and not to mention the countless users who don't even use the forums.

Share this post


Link to post
Share on other sites

Hmmm well that's at least 3 people in the forum removing Maxthon after this debacle. I'm wondering if the Chinese forum is getting the same feedback, and not to mention the countless users who don't even use the forums.

looks like they've listened to us :)

http://forum.maxthon.com/index.php/topic/15788-maxthon-inserts-graphic-advertisements-on-google-search-page/?p=85840

 

now let's wait for next update !!

Share this post


Link to post
Share on other sites