Can not share links to Maxthon cloud


Recommended Posts

Beggining yesterday I noticed I can't share pages using cloud functionality between my devices. I tried it on my PC, android tablet and smartphone and it doesn't work on any of it. I tried reinstalling Maxthon, reloging Passport account, repeating sending the links. Nothing worked. Basic cloud function is not working for me and it makes me sad.


Devices: Samsung Galaxy SIII mini, Samsung Galaxy Tab S and PC with Windows 7 64bit

Link to comment
Share on other sites

Hi Huma22,

Really sorry for the inconvenience.

Today i received your facebook feedback about your problem.

I conducted a test with my galaxy S3 and my widonws7 PC and i couldn't reproduce your problem.

Sharing links(right click on tab--cloud push) from my PC to my Android works fine.

Please make sure you internet is working fine and if you are running any antivirus or particular extension that might blocking this feature, please disable them for a while and try again.

Also i suggest you to check and make sure you are not browsing in private mode. Sometimes private mode does not support cloud push.

Please try these approaches and let us know if there is anything wrong again.

Thanks for your support.

Have a nice time.

Link to comment
Share on other sites

I have made a few more tests today and here is what I noticed.

1. My internet connection is perfectly well on all the devices involved.

2. I don't use private mode browsing on any of the devices.

3. The problem described in my previous post occurs when trying to send link directly to any of my devices that is not online at that moment. Example: I try to send link of a page I'm watching on my tablet to the PC that it turned off. "Can't send to the cloud". When I open my PC and Maxthon and try sending link from tablet again it opens on the PC immediatelly. Two days ago that was not an issue. I was sending links to my PC (turned off) and checking them out later (links were opening in the browser automaticly or a popup box showed up to tell me I have links waiting for me).

4. Problem does not occur when sending link from any device to the cloud, not to another device.

5. Two days ago I have updated Maxthon to beta on my PC. Coincidence?

Link to comment
Share on other sites

  • 2 weeks later...