• Poor performance and render problems (Discord App Blog)


    Problems with render and performance at:
    https://blog.discordapp.com

    The reason for poor performance:
     During scrolling each "position" written to the browser history.

    I know that it is the site developers fault, but this works fine in Microsoft Edge.

     

    Version: 4.9.3.400
    OS: 10.0.14342.
    IE: 11.1000.14342.0

     

    12412414124.png


    User Feedback

    Recommended Comments

    Vivaldi Browser Test:
    Good performance, but each "positions" write to the browser history too.

    I think the problem with the browser's history can not be corrected, but it is possible to improve performance for history writing and fix render problems.

    Discord Blog uses"infinite-scroll" script, I think this script is a complete garbage.

    Link to comment
    Share on other sites
    On 26.05.2016 at 0:11 PM, BugMiss006 said:

    Does the "poor performance" mean QQ截图20160526171017.jpg?

    I think this because the website has no site icon. Same situation in History and Favorites.

    I also tried in Chrome, it looks same.

    QQ截图20160526171547.jpg

    QQ截图20160526171602.jpg

    This means that the website work slow in Maxthon Browser.

    Link to comment
    Share on other sites
    On 2016/5/27 at 7:24 PM, Hedgehog Fog said:

    This means that the website work slow in Maxthon Browser.

    This because the website has no default site icon. Usually, browsers catch the site icon automatically from website information. However, if some websites have no site icon in itself website information, browsers can't get it. You will see all places, where need site icon, have no site icon display for this website. This also happen in tab site icon display.QQ截图20160530091620.jpg

    Link to comment
    Share on other sites
    4 hours ago, BugMiss006 said:

    This because the website has no default site icon. Usually, browsers catch the site icon automatically from website information. However, if some websites have no site icon in itself website information, browsers can't get it. You will see all places, where need site icon, have no site icon display for this website. This also happen in tab site icon display.

    missing icons may also be related to this (numerous posts about this issue): 

     

     

    cakebox, hanjie and dropbox have site icons, and they show using Edge.

    siteicons.png

    Link to comment
    Share on other sites
    19 hours ago, -ody- said:

    missing icons may also be related to this (numerous posts about this issue): 

    cakebox, hanjie and dropbox have site icons, and they show using Edge.

    siteicons.png

    How the CakeBox tab looks like on your computer? could you give me a screenshot?

    Does its tab look like the below picture?

    QQ截图20160530091620.jpg

    Link to comment
    Share on other sites
    3 hours ago, BugMiss006 said:

    How the CakeBox tab looks like on your computer? could you give me a screenshot?

    Does its tab look like the below picture?

    QQ截图20160530091620.jpg

    no site icon either on tabs (hanjie, cakebox, dropbox... )

    drop.png

     

    and below you can see hanjie and dropbox site icons on Edge...drop.png

     

    Link to comment
    Share on other sites
    2 minutes ago, -ody- said:

    no site icon either on tabs (hanjie, cakebox, dropbox... )

    drop.png

    and below you can see hanjie and dropbox site icons on Edge...

    I think This should be the different issue.

    ody, do you use proxy?

    Link to comment
    Share on other sites
    On 2016/5/30 at 1:57 PM, -ody- said:

    missing icons may also be related to this (numerous posts about this issue):

    cakebox, hanjie and dropbox have site icons, and they show using Edge.

    siteicons.png

    I feel find some rule of this issue. Ody~ could you help me take a screenshot of cakebox, hanjie and dropbox's site icons on web tabs and history in Edge? and their site icons in history in Maxthon. Thanks a lot.

    On 2016/6/3 at 4:20 AM, Hedgehog Fog said:

    The problem isn't solved. Performance slightly increased and there are still problems with rendering.

    maxthon.png

    edge.png

    I tried and it also happen on my computer. I will transfer to test team to confirm.

    Link to comment
    Share on other sites
    4 hours ago, BugMiss006 said:

    I feel find some rule of this issue. Ody~ could you help me take a screenshot of cakebox, hanjie and dropbox's site icons on web tabs and history in Edge? and their site icons in history in Maxthon. Thanks a lot.

    I tried and it also happen on my computer. I will transfer to test team to confirm.

    ( cakebox icon is missing in both maxthon and edge)

     

    maxthon

    icomax.png

     

    Edge

    icoedge.pngedgebar.png

    Link to comment
    Share on other sites

  • Pending = We are still working on this report.

    Solved = The issue has been fixed and the resolution will be available in the recent version.

    Closed = Feedback or opinion better posted on our forum for discussion.