Archived

This topic is now archived and is closed to further replies.

Pokey1

winpc issue Want To Remove Google CSE

27 posts in this topic

I've searched and reviewed your forums, and don't see a suitable answer, so felt I should ask.

I've been able to change the browser for Google to come up with google.com, not your Google CSE, when I type in Google in the URL line.

However, Google CSE still comes up on startup, and in various situations.  I want the Google CSE supplied with my browser to be gone.  In addition to providing fewer results than regular Google, the implication of pointing to a site someone else set up is, in itself, a security flag for any thoughtful user.

So, (1) how do I remove Google CSE from your settings so I only and forever get google.com when I want a Google search engine, (2) how to I prevent Google CSE from being my homepage in future, and (3) can you please consider removing the Google CSE settings completely from your browsers?...they're a reason I would consider not continuing to use your browser in future.

Share this post


Link to post
Share on other sites

Settings > General >  Manage Homepage - remove the google cse link in the popup that shows.

And delete the search option from settings:
Untitled.png

 

Share this post


Link to post
Share on other sites

I'm using version 5.0.1.3000, I believe.

When I go to Settings > General >  Manage Homepage, I do not get a Search Engines Management section to the window.

I've attached a JPG of what I see, and changed the URL there for Google already, but there isn't an apparent option to do as you directed.

Do I need to upgrade to a different version to get this?  If so, what is the recommended method?

Or, am I missing something to get to the options you've suggested?

 

CaptureCSE.JPG

I think I should be a little clearer on one point.

There is a link for Search Engines Management, but it gets me something else.  Another screen cap attached here, and the Google URLs there were also changed already.

CaptureCSE2.JPG

Share this post


Link to post
Share on other sites

Sorry, should have been more clear.

Settings > General >  Manage Homepage - remove the google cse link in the popup that shows.  This is to stop it from being opened as a homepage.

The image showed how to remove it from the search engine list.

What you have done is basically what I had described, just that you changed the URL instead of deleting the items.

Share this post


Link to post
Share on other sites

Having deleted both the Google and Google Search links, as it seems you were recommending, I am still coming up with a Google CSE screen when I open a new tab within the browser, and as the page that opens when I open the browser itself.  What does change is the list of available search engines next to the address/URL box at the top of the browser window.

Perhaps, in framing my desires here, I should also say I want to be able to set not just my home pages, but the page that will be displayed within a new tab.  And, at this point, since that Google CSE page link is obviously still resident within the browser somewhere, what must I do to destroy that link?  Is that something hidden in Hex code for the browser somewhere?

A large part of my concern is this is something lurking within the browser and accumulating data...doing what *it* wants with it, potentially, rather than leaving me secure.  And, frankly, in doing anything with the data, it's using resource and slowing speed.  I want no part of any browser that will not leave my data alone.  And, frankly, if I want to do a search, I want to be able to see everything I can that a search engine provides, rather than a censored list from a "customized" browser.  So far, this is really troubling.

Share this post


Link to post
Share on other sites

Go to Menu/Tools/Extensions/Functions and Add ons/Search. Untick enable. Clear cache.

Share this post


Link to post
Share on other sites
1 hour ago, Pokey1 said:

Having deleted both the Google and Google Search links, as it seems you were recommending, I am still coming up with a Google CSE screen when I open a new tab within the browser, and as the page that opens when I open the browser itself.  What does change is the list of available search engines next to the address/URL box at the top of the browser window.

Perhaps, in framing my desires here, I should also say I want to be able to set not just my home pages, but the page that will be displayed within a new tab.  And, at this point, since that Google CSE page link is obviously still resident within the browser somewhere, what must I do to destroy that link?  Is that something hidden in Hex code for the browser somewhere?

A large part of my concern is this is something lurking within the browser and accumulating data...doing what *it* wants with it, potentially, rather than leaving me secure.  And, frankly, in doing anything with the data, it's using resource and slowing speed.  I want no part of any browser that will not leave my data alone.  And, frankly, if I want to do a search, I want to be able to see everything I can that a search engine provides, rather than a censored list from a "customized" browser.  So far, this is really troubling.

Did you also remove the Search extension from Settings > Functions & Addons?  I can't give you a screen shot to  show in which of the 3 sections of that page you would find it.  I deleted it long, long ago and don't remember where it eas.  So just search all 3 sections.  If you  find it, disable or delete it  It should remain disabled/deleted through future updates.

 

The go back and delete Google cSE (aka "Google Searcch") from the search engine list as described previously above.

 

It has never come back for me since I deleted it.

                          <<SL>>

Share this post


Link to post
Share on other sites

what have you already done ?

try to delete with malwarebytes or the smallest adwcleaner for example

Share this post


Link to post
Share on other sites
2 hours ago, Magdalene said:

Go to Menu/Tools/Extensions/Functions and Add ons/Search. Untick enable. Clear cache.

I'm pretty sure I'm either not following this correctly, or have misunderstood.

When I go to the Menu and into the Tools section, none of the choices in this version seem to be for Extensions or Functions.

2 hours ago, SnowLeopard said:

Did you also remove the Search extension from Settings > Functions & Addons?  I can't give you a screen shot to  show in which of the 3 sections of that page you would find it.  I deleted it long, long ago and don't remember where it eas.  So just search all 3 sections.  If you  find it, disable or delete it  It should remain disabled/deleted through future updates.

 

The go back and delete Google cSE (aka "Google Searcch") from the search engine list as described previously above.

 

It has never come back for me since I deleted it.

                          <<SL>>

I'm not finding Functions, Add-Ons, or Extensions either in the Tools sub-menu or anywhere in the Menu or Settings.

I've gone through Favorites and have manually deleted all google.com listings there.

There was never actually a listing for Google CSE.  There was Google and Google Search, which both originally pointed to what was the Google CSE URL, starting https://google.com... and ending with custom settings extensions there from Maxthon.

2 hours ago, karajan said:

what have you already done ?

try to delete with malwarebytes or the smallest adwcleaner for example

What I've already done is listed in this thread.

Where this is supposedly involved with infesting my machine with ads, as well as unwanted manipulation of data, I think Malwarebytes is a good idea, so will try that next.  However, as this was essentially put here under the Maxthon shell, I suspect Malwarebytes won't deal with this as we might want.  Maxthon really should not implement such things if it wants worldwide use of its tools.  This is a lot of grief to go through for simply trying to get a working browser in place.

Much appreciate the advice and support received so far...now, off to try Malwarebytes.  Any other suggestions still welcomed.

Share this post


Link to post
Share on other sites

Go to Settings/Functions & Addons/ Utility/Search. Diable Search.

If you still have problems do a clean install or when reinstalling try "Fix" not "Uninstall".

Share this post


Link to post
Share on other sites

Nothing at all found with a trial version of Malwarebytes Premium.

Go to Settings/Functions & Addons/ Utility/Search. Diable Search.

If you still have problems do a clean install or when reinstalling try "Fix" not "Uninstall".

I've already adjusted Search Engine Management, as detailed above.

I don't see Add-ons or Utility or another related Search.

I see no option to disable Search.

I can't delete the last option in Search Engine Management, as the window seems to force me to keep whatever is the last one in there.

Share this post


Link to post
Share on other sites

1. Anti-malware programs are not the fix for the issue. Not sure why that was even brought up.

2. It seems you are using MX4.9 not MX5 which is what everyone is giving directions for. Partly my fault as I moved this thread here. Always handy to offer as much info as possible, especially the version of whatever you are using.

So now that we've got that sorted.

About the search extension:
Menu > Extensions - look for one called "search" - Delete it.

The rest stays as above. If you don't have a link in the homepage or Search settings for the Google CSE search and the extension noted above is deleted, there is no reason for it tor return.

Share this post


Link to post
Share on other sites

I don't seem to have the same windows you're all showing.

I can't get there from here.

I agree, some of this is dead simple...if I had the options...which I don't.

 

CaptureCSE3.JPG

Share this post


Link to post
Share on other sites
4 hours ago, 7twenty said:

About the search extension:
Menu > Extensions - look for one called "search" - Delete it.

 

Found this (Extensions button, which points to a page of various extensions) at the bottom of the Menus page.  Deleted search.

New tabs and new sessions still coming up with the Google CSE page.  

Share this post


Link to post
Share on other sites

So here's a full rundown of what needs to be done. Mind you I don't know why or if all of this is required (probably not), but in my testing the CSE search hasn't come back. Could be that if one setting hasn't been changed then it's designed not to delete the search, or restore it.

Note the search bar top right in the last image, this will update once the search options have been changed in settings.

Reading your last post again, I think all is set correctly, but the QA page search hasn't changed. This one has to be set manually (shown below) as it isn't connected to the search options in settings.

Easiest thing to do in situations is just click stuff and see what options there are. If it's not set to what you want change it, if that's no good change back.

QA.pngsettings homepage.pngsettings search.pngimax.png

 

7 hours ago, Pokey1 said:

I can't delete the last option in Search Engine Management, as the window seems to force me to keep whatever is the last one in there.

Not an issue. If you're deleting all the search options it defeats the purpose of having a search option. So long as at least the google URL that you want is there.

1 person likes this

Share this post


Link to post
Share on other sites

Many thanks for the careful and detailed explanation!

However, I just called up a new tab and am still concerned that I am seeing a different version of what I'm trying to steer away from.  And I have one last reservation about one setting you offered.

Let me make some notes here, both as a sanity check for myself and for anyone else coming in and trying to do the same thing here.

I deleted the Initial Configuration homepage link, and already had a Google link to http://www.google.com.

I had already deleted all search engines under Search Engine Management other than a Google link to http://www.google.com, which I had changed from the default link provided. I left this in place instead of using the full URL you provided.  Should this matter?  (More below.)

As I had previously deleted the Search Extension, I don't get Searches as a Quick Tools option at all for Searches.  There's nothing there to set as a default.

A new tab comes up with https://www.google.com/webhp?client=aff-maxthon-maxthon4&channel=t39.  (This is despite me not having this exact link in anything I can find still within the browser.  So, no clue where this is coming from.)  It seems to open a Google window, but not quite the vanilla one at www.google.com.  I can't get to http://www.google.com by typing it in at the URL; I'm pointed to the secure server version (https://www.google.com or https://www.google.com/webhp?client=aff-maxthon-maxthon4&channel=t39) every time, and this time I don't know enough to understand if that's an issue.  The https://www.google.com/webhp?client=aff-maxthon-maxthon4&channel=t39 link seems to include icons/links for Maxthon-preferred sites (eBay, Amazon, YouTube, &c.) if it's called in a new tab, which I'm hoping isn't an issue, and can be adjusted, but after getting this far, I'm a little skittish about what is lurking in these links with "maxthon" in the URL, especially when the same URL in opening a new tab gives a different display than when I try to type something in on the URL line.  Page source code on this window actually shows a comment with a string of Chinese characters that Google's translation util seems to be saying are "hidden elements," or "for those who can't see," so I'm fairly certain this isn't the safe, vanilla Google page I want...and something is still being hidden.

From documentation on Google, a CSE window can be unbranded, so it doesn't show up as a Custom (CSE) window.  I'm not really sure what I'm getting here.

The link you provided for Google to be used in Search Engine Management comes up with a much longer page of source code than the other page I'm finding, no comments using Chinese characters, and there's enough of it to just be way over my head for a quick read.

At this point, if I had my choice, I'd really rather just come up with http://www.google.com.

Would some kind of upgrade be a better choice here, or do I have it the way I want it and just don't know it yet?

 

CaptureCSE4.JPG

Share this post


Link to post
Share on other sites

HTTPS is a more secured kind of web links that's why it often replace http

Share this post


Link to post
Share on other sites
6 minutes ago, karajan said:

HTTPS is a more secured kind of web links that's why it often replace http

I understand the "S" literally is supposed to indicate a secure line.  However, with all the other junk in the URLs here, apparently hidden features, and who-knows-what-else going on in the background, I really don't know what I'm seeing.

You can have a pointer to a "secure server" in an on-line transaction, but if that server is sending your data (maliciously, by infection, or whatever) to where you don't want it to go, "secure" only meant that the data didn't leave that server before being processed...then was still hijacked.  It's just jargon.  I trust google.com to be a bit better than all these custom pointers that I fear are compromising me.  Whomever set up Maxthon to a custom environment that compromises my speed and user experience did the browser a grave disservice.

Share this post


Link to post
Share on other sites

https is a protocol that add a encryption layer to the data transit. it use ssl certificate (now tls) provided by let's encrypt which prevent users from getting their data easily readable.

you can make a search on the subject 

it's new and it's recommended by all the host companies.

a .htaccess file on the web site tell your browser to choose only https

Share this post


Link to post
Share on other sites

I appreciate the information...though don't want the Admins to be too put out with too much of a side topic...will try to keep my response short.

I use other browsers that don't exhibit this behavior, so am curious what is different.  Will look at your suggestions

In the Page Source for the Google page I'm now getting, wherever it's really pointing, I'm seeing in actual text the same thing I saw in my censored searches previously: "No Results Found"...with no clue why that would appear in a window where I hadn't yet done a search, except to prepare for a response for a text string found in a data table somewhere that is part of the censorship.

The question becomes whether I trust the security of a portal that has already censored my data or a response to that data.  And if it's censored Google search results, what else has it done?  I'd like to solve this mystery and get the browser Maxthon is supposed to be.  It shouldn't be so hard.  Not for anyone.

Seems I have more reading to do...thanks for the tips.

Share this post


Link to post
Share on other sites

The Chinese characters you mentioned earlier indicate you downloaded and installed the Chinese version of Maxthon. This has the Chinese version of search engines which are only allowed to search for what the chinese government allows them to. Get the version of the browser you use from http://forum.maxthon.com/index.php?/release-notes4.9/ or http://forum.maxthon.com/index.php?/release-notes5/ and do a clean reinstall.

Share this post


Link to post
Share on other sites

I think you're being a little too paranoid about this.The web has changed a lot since the days of just a standard URL in the address bar. Everything now adds queries of some description to the URL be it for tracking or other means.

I might be wrong, but the extra stuff in the URL is just info so Maxthon can track where a search came from (there may be a financial incentive as well...)

But let's try and sort this out.

The image in the last post helps immensely as up till now I thought you were talking solely about the search settings and searches from the search bar. But I think I understand where you're coming from now.

It seems your issue stems not from the search engine settings as they've been fixed, but from the search on the Quick Access page. (new page/tab by your terminology).

This page is an internal Maxthon page with it's own search URLs. Apart from choosing a search provider in the dropdown, you can't change any settings. And it doesn't use any of the search options used in settings as I noted earlier.

So to ensure you're using the google.com site that you want, either use the search bar or address bar with your preferred google.com search address that's set in settings.

1/ you'll get the site you want.
2/ it's easier and simpler than opening a new tab just to do a search.

Note you can do a google search directly from the address bar if that is your default search setting, try it! Also the link you've noted in your search management settings "http://www.google.com" won't work as a search query. It has to be http://www.google.com/search?q=%us

-- 

Out of curiousity I did a google search in Opera/Chrome/FF. And every single one of them had similar extras added to the URL when using their default/built-in google search on their equivalent of Maxthon's Quick Access:

Chrome: https://www.google.com.au/search?q=test&oq=test&aqs=chrome..69i57.370j0j8&sourceid=chrome&es_sm=93&ie=UTF-8

FF: https://www.google.com.au/search?q=test&ie=utf-8&oe=utf-8&client=firefox-b&gfe_rd=cr&ei=cSqFWJDJKMXr8Af7hr64Bg

Opera: https://www.google.com.au/search?client=opera&q=test&sourceid=opera&ie=UTF-8&oe=UTF-8

Maxthon: https://www.google.com.au/search?q=test&client=aff-maxthon-maxthon4&channel=t28&gws_rd=cr&ei=kyyFWKSOMoac0gTBxZ6IAw

Also did a bit of testing and apart from a few references to maxthon in the webpage, they're exactly the same as using a plain URL. So every browser is in the same boat.

If you're getting Chinese text as noted, do a clean install of the correct international version as noted by Magdalene.

Otherwise I think we can say CASE CLOSED!

Share this post


Link to post
Share on other sites
2 hours ago, Magdalene said:

The Chinese characters you mentioned earlier indicate you downloaded and installed the Chinese version of Maxthon. This has the Chinese version of search engines which are only allowed to search for what the chinese government allows them to. Get the version of the browser you use from http://forum.maxthon.com/index.php?/release-notes4.9/ or http://forum.maxthon.com/index.php?/release-notes5/ and do a clean reinstall.

I'd been asking if this kind of thing might be a better solution.

And, I'm aware the Chinese government has an arrangement with Google to censor results...and I've no clue what else.  But, didn't know there were Chinese and other versions of the browser, both with framework in English text, and I think I downloaded from a US site, so relieved to hear about this.

1 hour ago, 7twenty said:

I think you're being a little too paranoid about this.

You may be entirely correct, but it's also the principle of the thing.

Especially in light of what I feel are fact-based concerns Magdalene raised...which is what was on my mind.

1 hour ago, 7twenty said:

-- 

Out of curiousity I did a google search in Opera/Chrome/FF. And every single one of them had similar extras added to the URL when using their default/built-in google search on their equivalent of Maxthon's Quick Access: <snip>

This is part of what bothered me.  I'm using Chrome and Opera as well, and do NOT get those extras!  For me, this has been unique to Maxthon.

I found something similar in the past with another browser...I think Baidu, but not 100% sure...then found articles saying it was data mining and removed it from my machine.

I think the exact quote of  http://www.google.com/search?q=%us is going to answer some questions about how I need to implement this, as I get ready to do a reinstall.  (It actually comes up as a search for the text string "us"...but I'll figure it out from here.)

Thanks again to everyone for a bit of an education, and your patience as I asked a bunch of nit-picky questions with lots of details.  I believe I have what I need at this point to handle it from here.

Share this post


Link to post
Share on other sites
1 hour ago, Pokey1 said:

I think the exact quote of  http://www.google.com/search?q=%us is going to answer some questions about how I need to implement this, as I get ready to do a reinstall.  (It actually comes up as a search for the text string "us"...but I'll figure it out from here.)

The %us or %s is a placeholder for the search term when used as part of a search query from the browser.

If you don't use that, or instead use what you had previously www.google.com, then you get sent to www.google.com/[whatever you searched for] which will always be an error page or the page with no search term. It defeats the purpose of the having the address/search bar searches.

On the other hand if you want to use it as an alias, then that is correct, except that it should be setup in Settings > Address bar > url alias.

But having multiple types of searches available at the press of a button, is one of the best features of the current batch of browsers. No need to go to google.com then enter your search term, then bing.com add your search term. Just g search term [enter], b search term [enter]

Also just to confirm the chinese version thing, can you go to the C:\Users\[your user account]\AppData\Roaming\Maxthon3\Public folder and post the contents of the install.ini file.

Share this post


Link to post
Share on other sites

Had already done an install of MX 5 when I saw this.

There was no file on the path you gave, probably because I placed the files elsewhere.

What I think I have for a related install.ini is:

 

[main]
Folder=C:\Program Files (x86)\Maxthon\
pn=max4
reg=0
open=1
open_pn=max4
ueip=0
DefaultProgId=OperaStable
show_uninst_feedback=1
 

 

Not sure if this is what you were after or not.

Share this post


Link to post
Share on other sites