SueKrueger13

Members
  • Content Count

    24
  • Joined

  • Last visited

Community Reputation

4 Neutral

About SueKrueger13

  • Rank
    Freshman

Contact Methods

  • Skype
    Teamspeak is better

Profile Information

  • Gender
    Female
  • Location
    Coruscant in Canada
  • Interests
    Engineering. Gaming. Etc (CHECK ABOUT ME FOR CONTACT INFO).

Recent Profile Visitors

2,568 profile views
  1. I'm using Chrome at the moment for things like FB and such. used Opera before. I hope they do get their stuff together soon, since I happen to like Maxthon. and I hope they add online history that is more than a few days, since I lost links in the past due to it; pc stopped working, had to get a new one and forgot to bookmark the things on the old pc before it stopped working so I lost those things. oh well... I just hope they are in fact working on fixing these current issues. until then, Chrome it is...
  2. videos don't load very well for me actually. I do believe it is a flash problem, however, updating and replacing does absolutely nothing.
  3. so, I noticed I am not the only one having this problem: http://forum.maxthon.com/index.php?/topic/20245-facebook-photos-not-uploading/#comment-105170 I have actually tried those suggestions on that post, and nothing changed. thought I would add that, in case someone suggests me to try them.
  4. so.... a little more testing, it seems it is not only FB but also Mega.nz I cannot access the cloud drive section where my uploads are. I will keep reporting anything else I find.
  5. Maxthon is the latest version (it's up to date) I have Windows 10.
  6. when trying to click on ADD PHOTO it does not do anything. I tried another browser and it's fine. so it's a browser bug. was wondering if there's a way to fix it? thank you!!