Archived

This topic is now archived and is closed to further replies.

Chemodan

resolved Default search engine

11 posts in this topic

Привет!
Есть старый баг. Если в Maxthon использовать поиск от kinopoisk.ru, то в результате запроса на кириллице сайт показывает ошибку. Это повторяется от версии к версии, только в Maxthon. Это не зависит от режима, баг проявляется в режиме ретро и в режиме ультра. Очень хочется чтоб разработчики исправили эту ошибку. Строка поиска для всех браузеров выглядит так: https://www.kinopoisk.ru/index.php?first=no&what=&kp_query=%s

Translation from Google:
Hello!
There is an old bug. If you use search in Maxthon from kinopoisk.ru, then as a result of the query in Cyrillic the site shows an error. This is repeated from version to version, only in Maxthon. It does not depend on the mode, the bug is shown in retro mode and in ultra mode. I'd like it so that the developers have corrected this mistake. The search string for all browsers looks like this: https://www.kinopoisk.ru/index.php?first=no&what=&kp_query=%s 

MX5 (& MX3)  ed1f9f77f1fbe74c423e081c878d5630.png

Here is the search string in browsers:

 

Opera 45

081f75c93a1109c14c17e8c373c03965.png

 

Opera 12.18

2703d8491c237510123ade0b2647486b.png

 

Vivaldi 1.10

b2b5c115227e3985a725b91c7165bca4.png

 

Internet Explorer 11

0e5a084bb889cdfec43500d8713894b4.png

Share this post


Link to post
Share on other sites

Hi, I can't reproduce your issue. Kinopoisk works ok in MX5 and it worked fine in maxthon 4.4 and 4.9. I suppose you have some encryption or font issues. May be some changes in web page font settings could help.

Clip2net_170602003821.png

Share this post


Link to post
Share on other sites

This is strange. Incorrectly works only in the Maxthon browser. I also gave an example of other browsers. No settings with fonts have ever been performed. It was earlier in Windows XP and it is now in Windows 7. So I do not know where else to look for the cause.

And it's not in the fonts. Because the site gives the answer: Unfortunately, your search did not match any documents. This means that Maxthon initially interacts incorrectly with the site. I'll put it now on Windows 8.1 and look there.

Share this post


Link to post
Share on other sites

I mean font settings in browser, not in your system. 

Clip2net_170602011013.png

Share this post


Link to post
Share on other sites

Most likely the case is in character encoding. Look at the search bar in your screenshot. Look at the search for other browsers. And now look at the search line in Maxthon from me. I do not know how to fix this. Changing the encoding in the browser settings affects the entire site and does not correct the error in the search box.
P.S. In Windows 8.1 is the same :(

a3541e6db7b6533ce5c3b2b1b8e472c6.png

Share this post


Link to post
Share on other sites

Лень читать, но краем глаза заметил поисковую строку... 
Попробуй %us вместо %s. Это из-за кодировки.
Кстати, если сделать скрипт для поиска и загнать его в расширение, то работает всё нормально. 
P.S. Если не поможет, пиши. Почитаю... 

Share this post


Link to post
Share on other sites

Да, кодировка. Только что просто стёр из строки последние  %s и всё стало нормально :) Умная мысла приходит опосля... на всякий случай прописал %us , спасибо, A.S. Но всё же странно, что клинило только в МX

Problem resolved, thanks to those who tried to help ;)

Share this post


Link to post
Share on other sites
14 minutes ago, Chemodan said:

Да, кодировка. Только что просто стёр из строки последние  %s и всё стало нормально 

Надо прописать %us. Без этого может глючить. По-моему, у MX все вшитые поисковики так прописаны. 
А вот DuckDuckGo в старых версиях даже с %us выдавал иероглифы, только из расширения нормально работал.

1 person likes this

Share this post


Link to post
Share on other sites

Дописал. на всякий :) спасибо ещё раз!

Share this post


Link to post
Share on other sites