rick.lane

MX Master
  • Content count

    359
  • Joined

  • Last visited

 Content Type 

Profiles

Forums

Release Notes

Bug Tracker

Help page

Help page-CN

Release Note5

Rules and recruitment

Everything posted by rick.lane

  1. Parallel Beta Versions?

    Fair enough.
  2. Parallel Beta Versions?

    Maybe you have a wrong impression of just what the portable versions are. They are every bit as "real world" versions as the install versions. They are all that I use any more and they perform just as the install versions do such that I can not tell the difference while using them. I haven't installed a version for my regular use in over 2 years; I installed one to help a user with a question to see if the installed version acted differently than what I was experiencing with my portable version, but found that that user's problem was not related to which type of version was installed and then I simply deleted the installed version. I also never get warned that my desktop icon is abnormal using the portable version, an added benefit. Please don't let the title "portable" turn you away from using it in "real world use".
  3. Parallel Beta Versions?

    What you are referring to as the "pre-release channel" is formally called the "Early Access Area" and it still exists, and is only accessed by those that have special clearance. Unfortunately, the developers are not using that area as much as they used to and in my opinion that is where the first versions of the 5.3.8.x releases should have been posted so as not to confuse regular but knowledgeable and concerned users, like yourself. Also in my opinion, there have been way too many complaints concerning these versions but the only ones that seem to understand what is going on and how to deal with betas are from long time testers and insiders that know not to install betas such as these onto their computers. Most non-tester users aren't aware that when one installs a new version of the MX5 series that one's previous version is over written or even if one installs it into a new folder, the previous one is deleted, so there is no going back without re-installing the older version, hence my suggestion to use portable versions for testing. So, you are correct that the Early Access Area is most of the time these days mostly dead and it is disappointing that these 5.3.8.x versions were posted on the public forum way before they were ready, without having first been posted on the Early Access Area, and unfortunately many users joined the ranks of those that have left Maxthon behind.
  4. your default browser is at risk maxthon

    And just to be sure, make sure that the checkboxes at Menu>Settings>General>Default browser are NOT checked.
  5. Web page sign in issues

    I am using 5.2.7.2300 portable and do not have that problem, though I purposely log out of most sites when I leave them for security reasons. But the sites I stay logged into remain so when I restart the browser. Plus I also use Passkeeper which auto fills my user name and passwords on those sites that require a new sign in. Possibly your data file at %appdata%/Maxthon5 has been corrupted during your testing of the various beta versions. That is why I always use the portable version to try beta versions since the data file is contained in the folder for each version and not used by other versions, as the installed versions do. And also, if using just portable versions and one encounters problems such as this, one still has the version that they were using to simply go to and use instead with no necessity of reinstalling an earlier version.
  6. what is going on

    I seem to stay logged in on the very few sites that I do that with. Like Karajan says, I log out for security reasons on most sites that I need a password for to log in and on many they log me out automatically if I haven't made any moves in a while. But I just checked on the two sites I don't regularly log out on, and after 3 days since I went there, I was still logged in. So now the question is, why does it happen to you, Tony? And why does that make it "unusable"? Passkeeper works for me on most sites so logging back in isn't a big deal.
  7. what is going on

    How are the 5.2.7.2100 and 2200 unusable? They both work fine for me and I am using 5.2.7.2200 portable right now to write this and view the forum.
  8. desktop shortcut anomality

    Also, in Menu>Settings>General>Default browser that both the options are NOT checked. And I never see any of these when using the portable version.
  9. Works fine for me in both 5.2.7.1000 and 5.2.7.1100; haven't tried 5.2.7.2000 yet. I'm guessing that these are the versions you are referring to as there isn't any 5.7.2.x versions yet. The new core versions are 5.3.8.x. Edit: Just extracted 5.2.7.2000 portable and 'drag and drop' works as usual for me; used it to get to this thread. Can't speak for the install version; I don't use it anymore.
  10. In regard to the returning to the top of a page, would a mouse gesture that returns the page to the top work for you? That is what I have one set for and it works fine for me.
  11. 5.3.8.300 is a beta version which contains a new upgraded core and is not for regular users daily use as their default browser. 5.2.7.1000 is the current final release with 5.2.7.1100 released recently is a beta upgrade of that series.
  12. 5.3.8.300 gone?

    I brought all of this up when it was first posted but Tony told me it was "not a big deal". So, I just waited to see who else might find it interesting. All I ever wanted was an explanation from someone other than us users. I only brought it up here because since it was originally posted in a thread titled 5.2.8.300 it might be why Kilmitar couldn't find it; that thread it appears has now been edited to be titled 5.3.8.300 and everyone can find it now.
  13. 5.3.8.300 gone?

    Remember that it was first posted under the heading 5.2.8.300.
  14. new beta problems

    I have noticed this as well but didn't relate it to the new beta at first, just thought it was me. Thanks for posting this.
  15. [5.2.3.800] youtube pauses on start

    Just what version are you talking about? There is no version 5.2.3.800, unless you have a very old version; we've been on 5.2.7 for a while now. The latest beta release was advertised as 5.2.8.300 but in actuality the download file is 5.3.8.300 and it shows up in Help> About as 5.3.8.300 (also that is the version number for the maxthon.exe file)
  16. PASSKEEPER DOESNT WORK

    Well, that makes more sense; I don't have it tied to my phone so just my password is all that is required and that is why I have never experienced this problem. Thanks for the response.
  17. PASSKEEPER DOESNT WORK

    Maybe I'm not doing what you are or understanding what you are talking about, but I just accessed Passkeeper from the menu and from the QA page link and was able to login using my longtime password with no problem and have never had any issue with that. ( Not sure what you, No.1, are referring to with regards to "the same code I was sent")
  18. 5.2.8.300

    Is it not a big deal because you didn't discover it? I don't think most of what you complain about are big deals either as I don't experience any of them, such as your complaint that the download file is corrupt, which I have never experienced, but I don't tell you that your concern is "no big deal" It's not that bugsir had a finger problem, it's that the version is miss numbered. Bugsir had it right in that the version should be numbered 5.2.8.300 as that is in line with all of the numbering over the last 15 years. If in fact it is going to a new series of 5.3 versions, then it should be 5.3.1 as this would be the first one in a new series.
  19. 5.2.8.300

    How about the version number discrepancy? Am I the only one that noticed it? Did no one read my post above? All the talk here is about a 5.2.8.300 version (that doesn't exist) when the actual version download file and the resulting Maxthon version is 5.3.8.300. What's up with that? Please acknowledge BugSir006.
  20. 5.2.8.300

    First download of portable worked fine for me, but I find that the actual version number is 5.3.8.300, not 5.2.8.300, both in Help>About and hovering over the maxthon.exe in File Explorer, which made me wonder why a jump from 5.2 to 5.3 as well as jump from .7 to .8. Now it looks like it might be that a mistake was made rather than an intentional version number update from .2 to .3 with the update to .8 being because of the core change. The download files, both install and portable, also indicate 5.3.8.300 though title of the page is 5.2.8.300. I also notice that the default user agent (using What's my user agent at https://www.whatsmyua.info/) has Maxthon as 5.3.8.300. "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.81 Safari/537.36 Maxthon/5.3.8.300". Note also that the Chrome version is not up to date (72.0.3626.109 is the latest Chrome on my installation). However I am using the default Maxthon User Agent because I had problems with some sites when I used a custom User Agent with Chrome set to 71.0.3578.98 a few weeks ago.
  21. Skins for MX 5.1.2.3000 [Customizables]

    Thanks for your quick response. Don't know what you did, but re-downloading the file and applying the extracted files solves this issue! Thank you very much.
  22. Skins for MX 5.1.2.3000 [Customizables]

    I'm starting a new post so as not to be lost if I edit a previous post. Wilser, I have found that applying your "Alpha Tab Bar below The Bookmarks Bar" skin to Mx 5.1.0.1400 causes my Maxthon Multisearch to display improperly. It displays the proper results but it is only in the right hand side of the results window and can not be moved via the lower scroll bar or stretched by dragging. Using a single search such as Google or Bing results in a properly displayed search result, filling the whole window. Hope this screenshot helps explain the issue. Not sure why this happens only when I apply your skin. I discovered that the skin affects this because I was testing a newer 5.1 internal release and Multisearch worked fine right after installing. But after I decided it was okay to apply your skin, that's when I discovered this issue was still there. I can post some other screenshots if that helps with your being able to diagnose this issue. Thanks as always for your skin work.
  23. Skins for MX 5.1.2.3000 [Customizables]

    Thanks for the updates AND for the detailed answer to my query showing all of the file changes in the new versions files. Above and beyond.
  24. Updated User Agent

    After pasting in the new updated UA, uncheck the box to Use Customized User Agent and then check it again; the settings are saved message will appear at the top of the page
  25. Skins for MX 5.1.2.3000 [Customizables]

    Chiming in with something that occurred to me and I see that there has been some recent activity on this thread. I was curious if you, Wilser, or anybody else knows if the folder and files used in these skins (start;UIHuge.dat;UIMain.dat) have significantly changed in their original form in these 5.1 versions such that using one of your skins (I like to use the Alpha-Tab Bar below the Bookmarks Bar one) by replacing these files with your modified files and folder might remove a new feature or something that I won't see if I use your skins? I haven't dug into these files and folder to know just what they do control so I'm just curious if these files and folder are updated in these new core versions, 5.1.0.x, which I have been testing for a few weeks now and that have now been released in beta to the forum, and subsequently will need to be updated for your skins. The skin I like to use appears to work fine for me in this latest beta, 5.1.0.1400, but I don't know if something new is being left out by using the old modified files and folder. As always, your skin work goes above and beyond and are greatly appreciated. Hopefully you are able to shed some light on this issue.