Turn on TLS x.x?


Recommended Posts

Hello all,

When I was accessing a secure page, Maxthon replied with this message:

"This page can’t be displayed

Turn on TLS 1.0, TLS 1.1, and TLS 1.2 in Advanced settings and try connecting to https://xyz  again. If this error persists, it is possible that this site uses an unsupported protocol or cipher suite such as RC4 (link for the details), which is not considered secure. Please contact your site administrator."

The same website can be accessed normally through Chrome.

May i know how to turn them on because I don't know where they are after searching through settings page?

Thanks in advanced.


Link to comment
Share on other sites

I think I found out the answer. It's at Maxthon settings -> Advanced -> System -> Open Proxy Settings -> Advanced tab of Internet Properties 😌

But it doesn't solve my problem that the secure website can't be loaded in Maxthon 😢

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.