×

Give a tip

Can't sign in to account, some sites are unreachable


Recommended Posts

I had a powerloss (meaning no clean shut down), and now I can't sign in to my Maxthon account in browser (Win 6.2.0.2000 x64), it returns error:

-118 net::ERR_CONNECTION_TIMED_OUT

What's strange, is that if I type incorrect password - it will return corresponding error, so authentification server should be reachable. So I proceed without signing in (and loosing access to my tabs and favorites), but a lot of sites are unreachable too, like gmail.com with same ERR_CONNECTION_TIMED_OUT! It works fine in Chrome. More over, all works fine on other PC in another network. 

So I've tried to reinstall Maxthon with deleting user data, but problem remains. It's as if there is some broken DNS cache, or Maxthon silently tries to use proxy or whatever.

Any suggestion on how to proceed? I've been using this browser for almost 20 years, but if I won't be able to login to my account and use sites normally on my working PC, I'll be forced to migrate elsewere.

Tip   Give
Link to comment
Share on other sites

I've performed OS diagnostic, it showed gmail is online but unreachable on port 80 within my network. I've tried to explicitely specify https and port 443, and now it works. 

Upd: Problem was fixed, issues with my local network port forwarding (ports 80 and 443 opened on server gateway for one of the network interfaces). Devs might wanna do somethign about it thought, because it's abnormal no other browser breaks from that.

Tip   Give
Link to comment
Share on other sites

 Share