Archived

This topic is now archived and is closed to further replies.

Skeez

Maxthon wants to make changes to my computer

Recommended Posts

I'm using   v4.4.6.1. I searched the archives but can't find anything on this. Every time I open Maxthon browser the last few days, I get a message "Do you want to allow the following program to make changes to this computer?"

C:\Program Files\Maxthon\Bin\Maxthon.exe 

-SetDefault -SetSkinFileAssoc -CallByBrowser

I always choose "NO" because the 'Publisher's Certificate expired 7/14/2015.'

Is Maxthon just trying to tell me to upgrade to v5? It could've done that in a much better way, I think. I'm extremely cautious about downloading.  Version 5 is still in beta, isn't it? Doesn't that mean it's not finalized, that it still is liable to have issues? I'm not sure I want a "beta" browser. If v5 isn't finalized, why has support for v4 been closed? I'm so confused!! How long can I continue to use v4? I know this is the wrong forum, but I can't find these answers elsewhere. Any help would be much appreciated. Thank you!

Share this post


Link to post
Share on other sites
14 minutes ago, Skeez said:

I'm using   v4.4.6.1. I searched the archives but can't find anything on this. Every time I open Maxthon browser the last few days, I get a message "Do you want to allow the following program to make changes to this computer?"

C:\Program Files\Maxthon\Bin\Maxthon.exe 

this is windows UAC : set maxthon as your default browser to get rid of this warning

Share this post


Link to post
Share on other sites
7 hours ago, Skeez said:

I'm using   v4.4.6.1.

Any reason you're still using such an old version? You should at least move up to the 4.4.8 versions, or preferably 4.9, which only recently had an update. You can find the installers here: http://forum.maxthon.com/index.php?/release-notes/#

7 hours ago, Skeez said:

Is Maxthon just trying to tell me to upgrade to v5?

No, as ody said above it's just a windows UAC prompt. Why it only recently started showing is a bit of a question though.

7 hours ago, Skeez said:

why has support for v4 been closed?

As above it's still getting updates on the 4.9 branch. Although 5 is where most effort will be going in the future.

7 hours ago, Skeez said:

How long can I continue to use v4?

As long as you want.

Share this post


Link to post
Share on other sites
On Thursday, October 20, 2016 at 10:52 PM, 7twenty said:

Any reason you're still using such an old version? You should at least move up to the 4.4.8 versions, or preferably 4.9, which only recently had an update. You can find the installers here: http://forum.maxthon.com/index.php?/release-notes/#

Thanks. I will check that out. I guess I assumed Maxthon would let me know when updates are available. 

On Thursday, October 20, 2016 at 10:52 PM, 7twenty said:

No, as ody said above it's just a windows UAC prompt. Why it only recently started showing is a bit of a question though.

I changed the Windows default (back) to Maxthon. I don't know why it changed in the first place, though. I no longer get that annoying message box!

 

On Wednesday, October 19, 2016 at 3:19 PM, -ody- said:

this is windows UAC : set maxthon as your default browser to get rid of this warning

I've always had Maxthon set as default; don't know why it suddenly changed. I set it back to Maxthon and no longer get that message. Thanks -ody-. I don't think I ever would have figured that out!

Share this post


Link to post
Share on other sites
4 hours ago, Skeez said:

I've always had Maxthon set as default; don't know why it suddenly changed.

Are you using Windows 10? That has caused some issues of late where default programs would revert back to the Microsoft defaults for some reason.

Share this post


Link to post
Share on other sites