×

Give a tip

7twenty

MX Master
  • Posts

    4,695
  • Joined

  • Last visited

  • Days Won

    79

 Content Type 

Profiles

Forums

Release Notes

Bug Tracker

Help page

Help page-CN

Release Note5

Rules and recruitment

Release Note6

Posts posted by 7twenty

  1. On 22/02/2019 at 7:00 PM, BugSir006 said:

    :Tears_of_Joy_Emoji_Icon_42x42:

    Yep it does make you cry doesn't it...

    Seems it's not fixed, the issue is back although doesn't seem to be as repeatable as it used to be. Might have been a one off or something.

    Given the number of posts of issues of the most recent beta, it seems the core upgrade has caused a lot of issues.

    Being a user who used to use MX everyday as my only browser, i've now gone to Vivaldi, using MX for various things like logins that i haven't moved over yet. But this bug could well be the one that pushes me right off the edge. It's just too annoying having to close the browser just to make something else work properly, even though that program isn't even at fault.

  2. Not sure what the video will show,  but anyways...

    7sec Kodi.exe is started using a keyboard combination
    Video is selected and starts to play on 2nd screen (not shown)
    21sec Maxthon.exe restores from being minimised to a window and steals focus

    NOTHING is pressed or done between 7sec > 21sec

    If Maxthon.exe isn't running Kodi.exe keeps focus as it should.
     

    From the focus detection program shown in the video:
    41608:C:\Users\me\Desktop\focus\focus.exe | Mon Dec 17 22:30:14 2018 << FOCUS.exe started
    6412:C:\Windows\explorer.exe | Mon Dec 17 22:30:16 2018
    54016:C:\Program Files (x86)\Kodi\kodi.exe | Mon Dec 17 22:30:32 2018 << KODI.exe started
    No foreground application | Mon Dec 17 22:30:46 2018
    1920:C:\Maxthon5\Bin\Maxthon.exe | Mon Dec 17 22:30:47 2018 << MAXTHON.exe steals focus!!!
    18592:C:\Users\me\AppData\Local\WebLaunchRecorder\Screen Recorder Launcher.exe | Mon Dec 17 22:31:09 2018
    1920:C:\Maxthon5\Bin\Maxthon.exe | Mon Dec 17 22:31:12 2018
    18592:C:\Users\me\AppData\Local\WebLaunchRecorder\Screen Recorder Launcher.exe | Mon Dec 17 22:31:12 2018
    41608:C:\Users\me\Desktop\focus\focus.exe | Mon Dec 17 22:31:48 2018

     

    Recording #1.mp4

  3. how interesting, and concerning.

    there's no reason why you can't unpack the extension and have a look at the code, even better if you've got the dodgy chrome version to compare against.

    As you said, many MX addons were user created/ported rather than official versions from the dev, so depending on how up to date the uploader kept it, it could still be safe.

    At this stage probably best not to use it if anyone is at all worried about these revelations.

  4. Being unable to comment has been like that for ages. Was answered by a bug* when i questioned it some time ago. Apparently something to do spam i think, so they disabled comments to counter it.

    As for does it work? Well depends on what you deem "work" means. It does show and allow you to download the available extensions. In that respect, yes it does work. As for a means of being a place for user feedback - it's now useless, and developer information - it has never been any good for that.

    9 hours ago, A.S. said:

    Now I hope MX Team just preparing big update for Extensions Center

    While that would be something to hope for, i really, really, really don't think that's happening. Nothing has been done on the site for years. They have no intention of adding any developer info to the site despite the feedback given.

    They want to be seen as something more than the other browsers, but they can't even offer something as simple as a decent website with a nicely laid structure for developer information.

    I've said it before, it would take a decent coder 1/2 a day to add what is currently in the SDK documents into a workable, easily navigable, searchable website. But apparently that's not a priority. Instead the extension sits there dormant with almost nothing of note added ...

  5. 4 hours ago, No.1MaxthonFan said:

    Ok, if I have never had a problem with fonts of any kind, why would I go looking for a setting to change something and create a problem? 

    You wouldn't, nor was it ever implied that you should if you didn't have the problem.

    Seems you're the only one making more of this than what there is. There was a problem, a new setting change seems to be related to it, reset it and it's all back to normal.

     

    3 hours ago, Tony said:

    thats how they seem to work - add something that nobody wants whilst old bugs go on

    While there's some truth to that, i don't think we need to turn this thread into another "they don't listen to us" thread.

  6. had the same happen. 

    it's due to the new font sizing feature they added.

    Go to settings > Advanced, Web page display. For page font size, select Medium (even if it is already), and it should fix itself. Reset to default should fix it as well.

    Must be some sites reading the setting differently initially or something.

  7. 45 minutes ago, DARKSTORM said:

    The interface is completely different.

    yeah, i've said this many times for a long time. But i'm referring to the backend of how it actually works, that should be the same. But if using the same rules works in one and not the other then there is something else going on.

  8. 7 hours ago, joemax said:

    Maybe because the portable version doesn't have access to spotify web helper???

    I've never seen that file running, nor is it running now, yet i'm streaming spotify perfectly right now. Sounds like it might be related to the app rather than the webplayer.

    I'm still thinking it's to do with the way MX is setup to download the extra DRM components, possibly using the mxup.exe program which portable doesn't include. And speaking of which I was just reading this comment again:

    On 20/04/2017 at 3:57 PM, BugSir006 said:

    And the core reason that Maxthon doesn't support well for Spotify (Netflix, Amazon video, etc.) is that Maxthon is lack DRM plug-in, which is 6m big.

    Our PM decides to begin to program the plug-in for Maxthon, but will not add it to the install pack, since it will increase the size. They plan to make it cloud download when first time running Maxthon.

    And i'm thinking, why?

    Why would they not include the extra 6mb (2.4mb when compressed!) in the download package? If it gets downloaded at first start the data still gets used? It doesn't save MX, nor does it save the user any data, seeing as in both cases the extra data is downloaded anyway!! If that isn't the most stupidest idea, i don't know what is.

    They used the same reasoning for not including all the language files in portable as well, also only adding <5mb to the package. In a world of UHD video, always on internet and unlimited data plans, an extra ~5mb isn't going to hurt anyone except the unlucky few who might still be on dialup. And there's no gain in trying to keep a very small minority happy compared to the majority.

    Obviously I don't have the usage data that MX does - maybe it shows the only people that download portable are on slow connections? Maybe none of them are using streaming media that require the DRM files? Maybe they're all only english and chinese? Maybe for these reasons they decided not to include them... (I highly doubt it) who knows

    I know i'd rather download a file that says it's 100mb complete, rather than a 50mb file, which then surreptitiously downloads another 50mb in the background.

    At the end of the day, i'm happy my spotify issue is fixed (at least for now). Just a little annoyed that this could have been resolved much earlier with a simple response saying "portable doesn't include the DRM files".

  9. 9 hours ago, jseeley said:

    But changing the colors of the tabbar and active/inactive tabs and toolbar are a mystery as well as making the default tab wider.

    There's a setting in the skin3.ini file (in UImain.dat) for maxTabWidth = 220,232

    Based on it's name i'd say it will do what you want, but can't be certain. Haven't played around with it.

    And the tab colours can be changed in the constants.css file (or skin_c_dark_const.css if using a dark skin), also in UImain.dat

    @const TAB_ACTIVE_BG:
    @const TAB_BG:

    Set those to whatever colour you want. Again, not tested, but looks to be what you want.

  10. 5 hours ago, 7twenty said:

    Might be time to try the installer version...and see if that is the difference.

    And there it is...

    So it looks like the installer version auto-downloads the widevine DRM components which allows it to play. For whatever reason the same doesn't happen with portable. Why that is the case i'd be interested to know.

    Copying over the files downloaded/installed from the installer version allows it to work. I had to refresh the page even after a restart before it worked, but got there in the end.

    So for anyone with the issue you can:
    1 / use the installer version;
    2 / install the installer version, copy the files in core\plugins to the same folder in the portable version, delete the installer version;
    3 / download and copy the files attached to the maxthon\core\plugins folder.

    I'm not sure how this will affect any updates to the files.

    Hopefully the dev's can fix this problem with the portable version.

    @7x3twenty1

    widevinecdmadapter.dll

    widevinecdm.dll

  11. 1 hour ago, joemax said:

    Tried Spotify with M5.1.3.100 without issue.

    This is what doesn't make sense to me. I've tried every new version released (all portable, all clean extracts with no userdata) and they all have the same issue.

    Might be time to try the installer version...and see if that is the difference. Although still doesn't explain what the difference is, or why it's happening.

  12. 2 hours ago, 7x3twenty1 said:

    some developer told me that maxthon's webkit is 10 version behind:(

    10? i don't think so. MX4 is I think. MX5 is only 6 from what i can gather. And think there is an update coming in the coming months, so that should close the gap slightly.

    Although, while the spotify issue is still occurring, i'm not sure if it's the old blink version that is causing the problem - only for the fact that PHYR is saying that it's working.. Still confused.

    Although i have to say i've been looking around for another browser, in part because of this issue... not a happy camper!

  13. 20 minutes ago, nTrophy said:

    Are there other video settings I'm missing?

    I think there might be some confusion as to what the extension does. To my knowledge there's no option on YT that does what you want. So if the extension can be converted it should work, assuming that it also works with the new YT update.

    I've had a quick look at it, it's a little beyond what i know as there's a couple of chrome API's that i'm not exactly sure how to to implement in MX. It might entice me to learn something more, so I might spend some time poking around.

    • Like 1