Archived

This topic is now archived and is closed to further replies.

Blinderson

pc issue Default browser

5 posts in this topic

I'm using 5.2.0.1200, and it won't keep it as the default browser.

I need select it every time I launch this version of Maxthon.

I also get this prompt every time I launch the latest Maxthon (and when I choose Maxthon as my default browser). I always get this when I'd update to a new release, but never just opening the browser to use.

Thanks for any help!

MVIMG_20180307_070727.jpg

1 person likes this

Share this post


Link to post
Share on other sites

Are you using Windows 10? I find that Win10 really likes people to use Edge browser as their default browser and also that setting Maxthon to be default in the Maxthon settings doesn't always actually set in Windows 10. I go to Settings>Apps>Default Apps and see what Win10 is set to for default browser. Many times it has been reset to Edge, so I change it there back to MX5. Maybe that is what is happening to you.

1 person likes this

Share this post


Link to post
Share on other sites

Thanks so much rick.lane....it was set to Edge and I made the change, and it took care of the problem.

Appreciate the help!

1 person likes this

Share this post


Link to post
Share on other sites

Remember this as I find that it happens more than I would like it to, though I am a Maxthon tester and am switching back and forth between different Maxthon versions quite often and have to check on that all of the time.

1 person likes this

Share this post


Link to post
Share on other sites

The most of Win10 updates will reset default browser back to Edge so procedure needs to be repeated often.

Share this post


Link to post
Share on other sites