Geoff_W

Members
  • Content count

    7
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Geoff_W

  • Rank
    Freshman
  1. v5.2.4.2000 Very slow startup

    Yes, if you tell me what to do. Don't know if we have a time zone issue as I'm in the UK.
  2. v5.2.4.2000 Very slow startup

    Could my slow start-up issue have anything to do with having 128 favourites?
  3. v5.2.4.2000 Very slow startup

    Sorry Zork, I don't understand the process. My Settings page doesn't have the Access Page tick box shown in your post, see picture. If I follow the link to https://pc-newtab.maxthon.com I just get a new page opened in MX5. Would you please explain the process in a little more detail to someone who is not an expert with Maxthon. Thanks.
  4. v5.2.4.2000 Very slow startup

    @SnowLeopard Yes, as you say, it's at first run, logged-in and syncing. I'm using a Sony Vaio 17" VPCEC3S0E running Win7 64bit with 6Gb RAM and 500Gb HDD (No SSD when this was made!). As I tend to use the laptop sporadically during the day (switching it off after use each time), almost every run of MX5 is a first run, so it's always slow to start up. Tested it just now by closing MX5 and restarting it and the start-up time is around 6 seconds as you said. Just a bit of a pain then, on first start-up.
  5. I used to think that my previous v4.9.5.1000 was a slow starter, but having upgraded to the latest version, I have to say this is the worst yet. From the first splash screen to displaying my home screen takes a full minute! Chrome takes about 5 seconds and even IE manages 15 seconds, so why is MX5 so slow?