OddHominem

Members
  • Content count

    7
  • Joined

  • Last visited

Community Reputation

4 Neutral

About OddHominem

  • Rank
    Freshman
  1. Thank you! That's exactly what I was looking for Edited to add: I can't seem to find the setting in my General tab though Instead of "Protect Startup Icon", it says "Default Browser" underneath my search engine settings. I also searched the settings for "protect" and "icon", which turned up nothing. My Maxthon version is v5.2.1.6000 and the About window says my browser is up to date. Is there a newer version maybe? I'm using the PC version, not a mobile one.
  2. A moment ago, I was in the middle of a game when suddenly my game window was gone and I found myself back on the desktop. Fearing that I had lost hours of progress to a crash, I had a medium-sized nervous breakdown accompanied by a sharp pain in my left chest area when I suddenly saw a tiny window in the bottom right of my third monitor that read "The desktop icon of Maxthon browser is abnormal". What had happened is that this most annoying and utterly unnecessary popup minimized my game, which was still running in the background. Had this been an online gaming session, my entire group could have been wiped out. This simply cannot happen. Also, it's really creepy that Maxthon keeps doing this without any visible background process or service. I like to have full control over my system and be aware of all things that run in the background. If I were the paranoid type, I'd wonder what else Maxthon is doing when it's not running. I love this browser and trust that it's not doing anything shady, but I really, really need to turn off this particular feature. Yes, I could simply add a Maxthon shortcut to my desktop, but I don't like unnecessary clutter. And I'm sure I'm not the only one who would rather see this feature gone or have the ability to disable it. Thanks for considering our feedback.