Archived

This topic is now archived and is closed to further replies.

leeuniverse

SOLVED - How to make ALT Image Text show in Panel?

Recommended Posts

In old Maxthon Classic the window panel was a simple webpage, so things would work like they should, but the new versions of Maxthon nothing works like it should, so to even get basic things to work you have to be a Programing expert. :(

Anyway, my ALT text will no longer show when I mouse over images. So, how do I get that to work?

Also, if anyone knows how when clicking the image and the tab window pop's up, how to force it in the foreground instead of background that would be good also.

Thanks

Untitled1374966007782.png

Share this post


Link to post
Share on other sites

Anyway, my ALT text will no longer show when I mouse over images. So, how do I get that to work?

Is this just for the image shown that displays in a sidebar panel? Or are you talking about on webpages?

I have no idea about any of this, but am willing to poke around to see what I can learn.

EDIT: just noticed your last post in the other thread. Seems this is for your sidebar extension. Can you upload what you have at the moment so I can have a look? Just stumbled across some stuff and what to see if/how it might work in your file.

Share this post


Link to post
Share on other sites

So all you need to do is change alt to title, unless you are actually using alt for it's intended use, which is descriptions of images in a text only browser.

But given the way it looks, you are just using the wrong command and Maxthon is displaying the html as it should. ALT text being displayed is actually a bug in older IE versions after doing a little bit of reading.

Now if you need it to be using ALT instead of title (to just show the tooltip), there might be ways around that. But i'm thinking the above is all you want.

Share this post


Link to post
Share on other sites

hmmm..... Weird. ALT command is standard HTML for image description display.

But, I'll try to change it to Title and see what happens. Just a sec....

WELL ALL BE DANGED....!

It worked.... Changing ALT to TITLE actually now displays the name when hovering.

That fixed it. Thanks much! :) I swear, 12 years ago I learned HTML, and so much has changed it's depressing. The HTML itself has changed, and everybody's using complicated CSS.

------

Okay, that's fixed.... Now does anyone know how to make the page that pop's up only show up in the Foreground, i.e. to be the active tab?

Share this post


Link to post
Share on other sites

Weird. ALT command is standard HTML for image description display.

As I wrote, it was never meant to be used in the way you are using it, title is the command for that. ALT is to be displayed only when an image doesn't show. Just one of the bugs that IE brought about, which people got used to without realising it was doing it wrong.

But at least it's working for you now.

EDIT:

Nice explanation of the why and how. www.worcestershirewebdesign.co.uk/blog/why-doesnt-alt-text-show-up-in-firefox/

Now does anyone know how to make the page that pop's up only show up in the Foreground, i.e. to be a active tab?

That one has been asked for ages... since around MX3 days IIRC. To date I don't think it can be fixed. Needs to be changed by the devs.

Share this post


Link to post
Share on other sites

Thanks....

Actually there is a way because other plugins do it, such as ViolentMonkey and others when clicking their links in the Panel.

Also, I do still have the code that our old friend Tara made for me which made that work under MX Classic. Of course, the code will be slightly different, but there might be some similar "calls" in it. I'll post that and see if anyone has an idea.

Share this post


Link to post
Share on other sites