call with --single-argument fail to open link while Maxthon is running


Recommended Posts

If Maxthon is running already. when click a link, the --single-argument call to Maxthon fail to open link in Maxthon. But If I don't run Maxthon, by clicking same link, it will run Maxthon and open that link. Why?

I'm using Maxthon 7.1.8.9600 under win11.

Link to comment
Share on other sites

13 hours ago, scottchu.tw said:

If Maxthon is running already. when click a link, the --single-argument call to Maxthon fail to open link in Maxthon. But If I don't run Maxthon, by clicking same link, it will run Maxthon and open that link. Why?

I'm using Maxthon 7.1.8.9600 under win11.

Hi scottchu.tw, could you try with the latest version instead? https://forum.maxthon.com/index.php?/topic/28452-maxthon-pc-7189800-beta/

 

Link to comment
Share on other sites

Posted (edited)
33 minutes ago, BugSir009 said:

Hi scottchu.tw, could you try with the latest version instead? https://forum.maxthon.com/index.php?/topic/28452-maxthon-pc-7189800-beta/

 

Actually, I already did and it doesn't change things. By the way, to make clear that why I doubt Maxthon, I changed default browser to Chrome and did same test, it works just fine. Could it be some registry keys pertaining to Maxthon get wrong?

Edited by scottchu.tw
Link to comment
Share on other sites

36 minutes ago, scottchu.tw said:

Actually, I already did and it doesn't change things. By the way, to make clear that why I doubt Maxthon, I changed default browser to Chrome and did same test, it works just fine. Could it be some registry keys pertaining to Maxthon get wrong?

Hi scottchu.tw, could you provide us with the link so we could do a further check?

Link to comment
Share on other sites

On 5/24/2024 at 10:50 AM, BugSir009 said:

Hi scottchu.tw, could you provide us with the link so we could do a further check?

Whenever Maxthon is not running, When I open any  chat room of LINE, click any link, it won't open this link in Maxthon. So it's not about what the link is. The symptom is just: While Maxthon is already running, when one click any link in any LINE chat room, it won't open that link in Maxthon.

Link to comment
Share on other sites

11 hours ago, scottchu.tw said:

Whenever Maxthon is not running, When I open any  chat room of LINE, click any link, it won't open this link in Maxthon. So it's not about what the link is. The symptom is just: While Maxthon is already running, when one click any link in any LINE chat room, it won't open that link in Maxthon.

Hi scottchu.tw, could you check on your PC settings and make sure that the link type are pointed to Maxthon as the default app?

 

image.png

Link to comment
Share on other sites