×

Give a tip

Maxthon 7.0.0.1000


BugSir006
 Share

Recommended Posts

  • Like 1
  • Thanks 1
Tip   Give
Link to comment
Share on other sites

So, this version is final or still beta? Some sites give it as final, others as beta.

https://forum.maxthon.com/index.php?/release-notes6/

but...

https://www.softpedia.com/get/Internet/Browsers/Maxthon-3.shtml
or
https://www.softexia.com/web-browsers/maxthon 
... etc ...

Maybe because the .1000 milestone is usually considered as a final version?

Edited by Massor
Tip   Give
Link to comment
Share on other sites

2 hours ago, Massor said:

softpedia

article is written 1.5 years ago and, as i can suppose, just version # and url is periodically updated. it does not state that .1000 is the final version.

 

2 hours ago, Massor said:

definitely they know something. they know more then developers :)

Tip   Give
Link to comment
Share on other sites

Hello!

The previous beta (7.0.0.901), didn't update & said it was up-to-date...

Surely a 'stable' release is considered better than a 'beta'!?

Obviously (v6 did it for it's entire life & v7 isn't really a new product, being built on v6), the download manager still has missing or incorrect icons for ".exe" files

Astoundingly, I see you're still using Chromium 103 (109 is latest stable) - that really is poor, 1 update in a year!

All major web browsers (Maxthon has 100's of millions of users, so they're not that 'little') see keeping Chromium up-to-date as a critical requirement, for obvious reasons (stability, bug fixes, security fixes, features, etc)... Maxthon MUST do the same as anything else is simply unacceptable - you're just creating problems for yourselves that were probably fixed ages ago in a new Chromium!

Edited by MichaelC362
  • Like 1
Tip   Give
Link to comment
Share on other sites

1 hour ago, MichaelC362 said:

Hello!

The previous beta (7.0.0.901), didn't update & said it was up-to-date...

Surely a 'stable' release is considered better than a 'beta'!?

Obviously (v6 did it for it's entire life & v7 isn't really a new product, being built on v6), the download manager still has missing or incorrect icons for ".exe" files

Astoundingly, I see you're still using Chromium 103 (109 is latest stable) - that really is poor, 1 update in a year!

All major web browsers (Maxthon has 100's of millions of users, so they're not that 'little') see keeping Chromium up-to-date as a critical requirement, for obvious reasons (stability, bug fixes, security fixes, features, etc)... Maxthon MUST do the same as anything else is simply unacceptable - you're just creating problems for yourselves that were probably fixed ages ago in a new Chromium!

I surely second that
when is it time to be the first browser that lead other browsers not really fall behind
getting beta testing on new chromium while still maintaining a stable release 
Or i'm just dreaming

  • Like 1
Tip   Give
Link to comment
Share on other sites

4 hours ago, MichaelC362 said:

Hello!

The previous beta (7.0.0.901), didn't update & said it was up-to-date...

Surely a 'stable' release is considered better than a 'beta'!?

Obviously (v6 did it for it's entire life & v7 isn't really a new product, being built on v6), the download manager still has missing or incorrect icons for ".exe" files

Astoundingly, I see you're still using Chromium 103 (109 is latest stable) - that really is poor, 1 update in a year!

All major web browsers (Maxthon has 100's of millions of users, so they're not that 'little') see keeping Chromium up-to-date as a critical requirement, for obvious reasons (stability, bug fixes, security fixes, features, etc)... Maxthon MUST do the same as anything else is simply unacceptable - you're just creating problems for yourselves that were probably fixed ages ago in a new Chromium!

Nah, they ARE "that little"...  Those "millions" are mostly "downloads" and are over the entire LIFETIME of MyIE2, Maxthon Classic, and Maxthon's existence.

You just have to look how much activity the Forum get's, especially in comparison to the Classic days.  Maxthon is almost entirely DEAD as to users.
That's why it takes so long for development, cause they simply don't make as much money, having so few developers, why more than 2 years now with 6.0 now 7.0 and there are SO MANY MAJOR features still missing.

Sadly, they made a huge mistake going to WebKit or whatever as the Browser Engine when they went standalone after Classic which was a shell over IE, instead of going to Chromium.  So, we lost all that Development Time.... and lost so many users due to losing good Extension support, and Maxthon became a hog as a Standalone.

Maxthon should be where Vivaldi currently is as far as features had that time and users not been lost.
I would actually be using Vivaldi if it wasn't for a couple of massive irritations, such as:
- the Menu being on the Left of the browser instead of the Right as normal.
- the GreyScale Favorite Icons etc. that can't be changed.
- the Favorites dropdown being one column you have to scroll unlike Maxthon which has multiple columns.
- missing double-click to close tab (though can be added with an Extension) (or is it "Drag n Drop" that's missing?  Can't remember now?).
- one or two other things I can't remember.

But, Vivaldi has essentially EVERY other feature a person could want, and all kinds of small Configuration options.  Several long time Maxthon users have went to Vivaldi.
I hope Maxthon starts adding most of that stuff, especially the ones I've added to the Feature Requests, they are the biggest.  I was actually using 360Chrome for years after Maxthon Classic, cause it was almost like Maxthon Classic, though Chromium, but then it started having issues, and Maxthon 6.0 finally got good enough for me to at least start using again.

So, I'm here trying to help Maxthon like I did with Classic years ago, hoping it can get to being much the same and better, and not take too long doing it.
I also like Maxthon's look and feel, always have.

Edited by leeuniverse
  • Like 2
Tip   Give
Link to comment
Share on other sites

I have been using Maxthon since the beginning (MyIE2) and I can affirm that it is currently the best browser that a user can use. I got very frustrated during the time when some versions of Maxthon 6 crashed frequently, and all this despite the Chromium version.
The differential fact for me is having at my fingertips all my bookmarks, my accessories and my configuration in general.
I use it on several computers and even several versions without problems, except for one (the office at work) because it belongs to a domain that, for some reason, has not allowed me to run Maxthon since a few months, although it does allow me to run any other Internet browser. It's something I can't control and I can't think of a way to use it there. I have tried to change the name of the EXE file, but the powerful security system catches it and refuses to execute it without any warning message and without entering into the Task Manager.
I have tried the most widely used browsers in the world (Chrome, Firefox, etc.) and I have also tried other minority ones such as Aloha, Vivaldi, Slimjet or Brave. However, with none of them I feel as comfortable as with Maxthon. Being free software, I am very grateful to the developer team and, although there is always some improvement to be made, I prefer Maxthon over any other. I wholeheartedly thank the team and its engineers.

  • Like 3
  • Thanks 1
Tip   Give
Link to comment
Share on other sites

Issue with the last many updates....  Not sure if it started with 7.0 or when?

I used to be able to DRAG a TAB to the side of the screen and it would SNAP creating a NEW WINDOW filling HALF of the Screen.
However, with 7.0 now when I do it, the tab just wants to drag and drop to my other Screens creating the new window there, I have two Monitors and one TV Screen, does it both Left and Right.

I don't know if a Windows update caused this, or if it's an issue with 7.0?  (TESTED...  Other browsers this function works fine still.)
- Windows 10 updated, 64bit.
I noticed that the new window created WILL snap filling half the screen as it's supposed to after it's been moved and created on the other screen.
There also seems to be a weird instance in which it WILL work on the main screen, but I can't duplicate it save extremely rarely.  Seems to just do it when it wants?

Anyway, wanted to report this issue I'm having...  The New Window creates, it's just there's an issue with the SNAPING function, that makes the window fill half the screen like it used to do, which it doesn't now do at least properly.

Edited by leeuniverse
Tip   Give
Link to comment
Share on other sites

2 hours ago, leeuniverse said:

Issue with the last many updates....  Not sure if it started with 7.0 or when?

I used to be able to DRAG a TAB to the side of the screen and it would SNAP creating a NEW WINDOW filling HALF of the Screen.
However, with 7.0 now when I do it, the tab just wants to drag and drop to my other Screens creating the new window there, I have two Monitors and one TV Screen, does it both Left and Right.

I don't know if a Windows update caused this, or if it's an issue with 7.0?
- Windows 10 updated, 64bit.
I noticed that the new window created WILL snap filling half the screen as it's supposed to after it's been moved and created on the other screen.
There also seems to be a weird instance in which it WILL work on the main screen, but I can't duplicate it save extremely rarely.  Seems to just do it when it wants?

Anyway, wanted to report this issue I'm having...  The New Window creates, it's just there's an issue with the SNAPING function, that makes the window fill half the screen like it used to do, which it doesn't now do at least properly.

Have you tried that function with other browsers to check if it's a windows issue or not?

Tip   Give
Link to comment
Share on other sites

2 hours ago, Mhzayer said:

Have you tried that function with other browsers to check if it's a windows issue or not?

Ya, doesn't appear to be a Windows issue....  Seems it's the browser.

Other browsers work like they should in moving a Tab to create a new window and moving it so it positions as half the screen.

  • Like 1
Tip   Give
Link to comment
Share on other sites

4 hours ago, caligula73 said:

how to transfer qa pictures from mx6 to mx7?

I know...  I like that SAME Pic as my background, the Night Skyline.

I've asked them to add them as an "Option", but like everything else they consider "small" and not important, it will either never happen, or take another 2-5 years.
If you have 6.0 installed maybe you can find them somewhere in the Maxthon folders, they are "Local".  If you can find them, then you can just copy them to your local drive, and then select in 7.0 the "Local" option in 7.0 and select what pic you want to use.

If you DO find them, Zip them and upload them for us to any free upload site (one that doesn't remove too quickly) so the rest of us can have them.  (or for free to your Google Drive or Microsoft OneDrive)
I'm too lazy atm to do this myself...  😉  Thanks

Edited by leeuniverse
Tip   Give
Link to comment
Share on other sites

Is it possible to have the weather widget use the current location?
I don't know why it's not using that though I'm using accuweather
Is it because of the accuweather site not detecting the current location automatically?

 

Tip   Give
Link to comment
Share on other sites

14 hours ago, Mhzayer said:

Is it possible to have the weather widget use the current location?
I don't know why it's not using that though I'm using accuweather
Is it because of the accuweather site not detecting the current location automatically?

 

Mine didn't work the first time I tried to change it, but I went back a few days later and it worked and has continued to work ever since.

 

Weather.png

  • Like 1
Tip   Give

post3dmg4_zps398d3651.jpgWindows 10 64-bit build 10525/Windows 10 Mobile build 10512

Link to comment
Share on other sites

On 1/12/2023 at 12:41 PM, No.1MaxthonFan said:

Mine didn't work the first time I tried to change it, but I went back a few days later and it worked and has continued to work ever since.

 

Weather.png

Mine unfortunately is showing SA but not my city

Tip   Give
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share