×

Give a tip

Maxthon beta version 7.0.0.500


MaxthonJeff
 Share

Recommended Posts

+ Improved UI and theme
+ New settings page and quick access page
- Fixed some known bugs
 

Download from:

https://github.com/aoyiteam/maxthon/releases/tag/v7.0.0.500

  • Like 5
  • Thanks 2
Tip   Give

??Set your payment address in profile if you have not. Let's reward people who contribute to Maxthon community. ❤️❤️ Click Here ❤️❤️

Link to comment
Share on other sites

Sadly, lots of issues...  Win10 Pro, 4k Monitor, fully updated, Maxthon 7.0.0.500, 64bit Install version.

1. While I could likely get used to the new default black/grey theme, please bring back Mx's 6.0 default Blue whatever theme as an option.
Believe it or not, one of many reasons I'm using Maxthon is BECAUSE of that theme, which is pretty much the theme that's been used since the beginning of Maxthon.  It just feels good.

2. Background Images of the Quick Access Page are "blurred", they ALL are even when changed.
Also, please bring back the "default" Images as an option.  I really liked the STARRY Night one, whatever it was called.

bUJx1Ix.png

3. Error Page issue STILL exists when opening "Multi-Tabs"...  Had like 5 of them this time when my Extensions were installing.

- Err Connection Closed
- Err Socket Not Connected
- Err Connection Reset (or Err Socket Reset?)

BTW, I might not have worded the above errors all correctly?

Here's a video of when I've recorded the issue before for you with Chromium test version.  Same thing occurs with Maxthon, have another video of that too, if you want that one instead, but same exact issue.

4. Don't know how the "Weather" thing on the Quick Access is supposed to work.  Not in China, and I'm Fahrenheit, not Celsius.

This is what I have so far...

Will report any additional issues on usage.

Edited by leeuniverse
Tip   Give
Link to comment
Share on other sites

4 minutes ago, MaxthonJeff said:

Thanks. A quick note, you can change how background image is handled in QA’s settings sidebar.

Yes, I know...  But the "default" backgrounds are no longer there.  I really like the Starry Night or whatever it's called one from MX 6.0.

Also, there's a BUG in the SEARCH of the Quick Access Page when I "Add" a Search option in Settings, and change it's Default.
This occurs BOTH in the QA's sidebar (as image shows) and also on the page itself.
There is no "dropdown".

RiJoiJV.png

Edited by leeuniverse
Tip   Give
Link to comment
Share on other sites

I spent over 10 minutes on my first clean launch of the browser. As in previous versions, after logging into your account, the browser launches everything! plugins. Even those that are usually disabled. This takes a lot of time and system resources. In this case, each plugin opens its own page. I tried to stop them from loading by selecting Close All from the menu on the right - but that acted like a "restart" on them and they reopened. It ended up that after another attempt to close all unnecessary tabs, the browser crashed. Further ... Big empty field on the start page. How to disable Notes? Do not hide from the panel, namely disable?

It is very good that now you can change the number of tiles on the main page. But around them, especially on top, there is a lot of empty space. It is better to change the search engine in the main search bar, then the search from the start page could be disabled (now you can turn it off!).

Win 7-64. Mx portable x32 (because it eats less memory)

 

4444.png

Безымянный2.png

Безымянный3.png

555.png

Edited by Chemodan
  • Like 1
Tip   Give
Link to comment
Share on other sites

29 minutes ago, Chemodan said:

I spent over 10 minutes on my first clean launch of the browser. As in previous versions, after logging into your account, the browser launches everything! plugins. Even those that are usually disabled. This takes a lot of time and system resources. In this case, each plugin opens its own page. I tried to stop them from loading by selecting Close All from the menu on the right - but that acted like a "restart" on them and they reopened. It ended up that after another attempt to close all unnecessary tabs, the browser crashed. Further ... I have not noticed anything new yet. Only blurred background of the start page. The same big empty field on the start page. Unswitchable search bar... why? How to disable Notes? Do not hide from the panel, namely disable?

Win 7-64. Mx portable x32 (because it eats less memory)

I have over 30 plugins and like 14 of them pop-up webpages when the Extension is Installed.

This is NORMAL and has nothing to do with Maxthon.  It's the Extension developers that pop-up webpages on install of their extension.

Also, for me on the 64bit Install version all the Extensions installed on my "second" Start of the browser, which hasn't happened before.  I don't know if this is a "new" feature or just some nuance with this new browser?
Normally all my extensions install on the first launch...

Tip   Give
Link to comment
Share on other sites

24 minutes ago, Raniw said:

Remove the padding between the active tab and the browser window (indicated in red).

Отступ.JPG

The right mouse button does not close the tab, the mouse cursor steps on this indent.

1. I actually like the "padding"...  It looks like a TAB as it should.  Also, it helps better tell the difference between the Active Tab and the non-active.

2. I have no problem closing the Tab with the Right Mouse Button.  How are you putting your mouse JUST on that "tiny" little space?
Also, WHY are you using the Right Mouse button anyway to close, rather than "Double-Click" to Close Tab, which is FAR easier and faster?

You should request a New "Setting" if you want to remove the space, cause this is actually the normal "default" way Chromium Tabs work, and tabs have worked forever for near all browsers.
I know 6.0 was doing it different, removing that space, but that's an unusual not-normal thing.  I actually made a request to have the space as default since that's the default for near all other browsers (if I remember right), then to add a setting for those who don't want the space.

  • Like 1
Tip   Give
Link to comment
Share on other sites

7.0? Nice! Congratulations! But, why no fireworks? No special article for new milestone or something?

One question? Is it independent install from 6 or upgrade? I'd prefer to have 5, 6 and 7 in different paths and they don't know they are all installed in my Windows.

Edit: OK, I got answer, it's upgrade. I'd prefer portable version then. 

Thank you for new version. From loyal Maxthon user.

Edited by Xahi4475
Upgrade
Tip   Give
Link to comment
Share on other sites

13 minutes ago, Xahi4475 said:

7.0? Nice! Congratulations! But, why no fireworks? No special article for new milestone or something?

One question? Is it indeprendent install from 6 or upgrade? I'd prefer to have 5, 6 and 7 in different paths and they don't know they are all installed in my Windows.

There's really nothing to write home about...

What they've mostly done is allowed MORE of Chromium's default formatting and functionality instead of as much "customization" in design changes as MX 6.0 had.

- Settings is now considerably Chromium's design.
- Themeing is considerably Chromium's design.
- Quick Access page and settings are considerably Chromium's design, etc.

They seem to be trying to keep as much of Chromium's basic design as possible now, things that don't have to be "modified" to give them a bit less work.
So, they've "streamlined" more, likely to also help them update the "Core" more often.

7.0 is really mostly just a "formatting" change in a lot of the "design" of the browser, and then the Quick Access Page having several improvements in settings.
Hopefully this is a sign we'll start getting more substantive changes coming in the future, i.e. features and functionality many of us are still waiting for, such as my several as indicated "Feature Requests" Forum.

Edited by leeuniverse
  • Like 1
Tip   Give
Link to comment
Share on other sites

Yeah, I thought so. Basically, I think it's safe to upgrade it from 6. It's like new 6 build. Because, I was afraid to upgrade it.

Edit: yeah, I upgraded. And, for now everything looks fine.  :)

Edited by Xahi4475
Tip   Give
Link to comment
Share on other sites

Quote

Yes, Mx7 is a fully compatible evolution of Mx6.

Can I have both Mx6 and MX7 installed or does MX 7 install directly into 6's location C:\Users\User\AppData\Local\Maxthon\Application?

X64 Portable version is working fine. I just copied over user data from x64 Mx6 Portable.

Edited by Magdalene
Tip   Give
Link to comment
Share on other sites

13 hours ago, Raniw said:

Remove the padding between the active tab and the browser window (indicated in red).

Отступ.JPG

+1. Now switching tabs has become inconvenient. Returned to version 6.2.0.2600. Please remove this indent or add an option to turn it off in the settings.

  • Like 3
Tip   Give
Link to comment
Share on other sites

6 hours ago, DiMkA said:

+1. Now switching tabs has become inconvenient. Returned to version 6.2.0.2600. Please remove this indent or add an option to turn it off in the settings.

Agree. This new tabs are terrible. Sometimes if i use doubleclick tab won't close but just minimize broswer! ####ing space above tab!!! And this new quick access page has annoying 1 sec delay. + Old chromium. Back to 6.2.0.2600.

  • Like 2
Tip   Give
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share