×

Give a tip

Bug report: GMAP can't drag-n-move


Recommended Posts

Reproducing: open www.google.com, click 2nd result(url: https://www.google.com.tw/maps), I CAN'T drag and move around. If click 1st result(url: https://www.google.com/maps/@25.0171709,121.1544756,6346a,20y,90h/data=!3m1!1e3?hl=zh-TW), I CAN.

Current version used: Maxthon version is 6.2.0.1200 portable.

O.S. used: Win10 and Win7.

Special phenomena: When first installing a clean verison, it doesn't appear this bug. But after using a period of time, this bug comes up. Weird but true.

Doubt of cause: Lack the ability to deal with newer-ability version of Javascript codes.

Tip   Give
Link to comment
Share on other sites

1 hour ago, scottchu.tw said:

Reproducing: open www.google.com, click 2nd result(url: https://www.google.com.tw/maps), I CAN'T drag and move around. If click 1st result(url: https://www.google.com/maps/@25.0171709,121.1544756,6346a,20y,90h/data=!3m1!1e3?hl=zh-TW), I CAN.

Current version used: Maxthon version is 6.2.0.1200 portable.

O.S. used: Win10 and Win7.

Special phenomena: When first installing a clean verison, it doesn't appear this bug. But after using a period of time, this bug comes up. Weird but true.

Doubt of cause: Lack the ability to deal with newer-ability version of Javascript codes.

Hi scottchu.tw, could you download and install the latest version V6.2.0.1500 and try again?

Tip   Give
Link to comment
Share on other sites

Posted (edited)

I've downloaded and tried v6.2.0.1500 PORTABLE version. As I write before, If it has clean UserData folder, it's ok. But if I unzip 6.2.0.1500 into the current portable version I've used for a while (by overwriting Maxthon.exe, chrome_proxy.exe, and add a new folder 6.2.0.1500), bug still happens. The problem comes from the Userdata folder in my current used version. Actually, I believe most of the bugs I reported before are all because of something stored in the old Userdata folder. By the way, I always use guest account.

 

Edited by scottchu.tw
Tip   Give
Link to comment
Share on other sites

On 10/3/2022 at 2:00 PM, scottchu.tw said:

I've downloaded and tried v6.2.0.1500 PORTABLE version. As I write before, If it has clean UserData folder, it's ok. But if I unzip 6.2.0.1500 into the current portable version I've used for a while (by overwriting Maxthon.exe, chrome_proxy.exe, and add a new folder 6.2.0.1500), bug still happens. The problem comes from the Userdata folder in my current used version. Actually, I believe most of the bugs I reported before are all because of something stored in the old Userdata folder. By the way, I always use guest account.

Hi scottchu.tw, did you enable any extensions? Please try to disable the extensions then check this issue again.

Tip   Give
Link to comment
Share on other sites

  • 2 weeks later...
On 10/8/2022 at 4:18 PM, BugSir006 said:

Hi scottchu.tw, did you enable any extensions? Please try to disable the extensions then check this issue again.

I tried this workaround many times. It mostly doesn't help! Even so, Those extensions works fine in Chrome. Since Maxthon uses same core as Chrome's, it shouldn't have these bugs. Maybe your developers need work harder to make it be more compatible with extensions. Currently my only solution is as follows:

(Note:I'm always using portable version and guest identity.)
1) Export bookmarks to be an html files.
2) backup Qaconfig.dat.
3) Kill folder Userdata\ completely.
4) Reopen Maxthon portable.
5) Login using guest.
6) Import bookmark.
7) copy back and overwrite Qaconfig.dat.
8.) Open New page and refresh screenshots of all quickacess items.
9) Go to webstore and reinstall previous-used extensions.
9) Exit and rerun Maxthon.

These procedures are very tedious, so I've given up doing these steps now.

This make Maxthon run normally for a while. But after using Maxthon for a long time, bugs will mostly appear again, e.g. keystroke and mosue action will become not-worked on many webpages. 

Edited by scottchu.tw
Tip   Give
Link to comment
Share on other sites

4 hours ago, scottchu.tw said:

I tried this workaround many times. It mostly doesn't help! Even so, Those extensions works fine in Chrome. Since Maxthon uses same core as Chrome's, it shouldn't have these bugs. Maybe your developers need work harder to make it be more compatible with extensions. Currently my only solution is as follows:

(Note:I'm always using portable version and guest identity.
1) Export bookmarks to be an html files.
2) backup Qaconfig.dat.
3) Kill folder Userdata\ completely.
4) Reopen Maxthon portable.
5) Login using guest.
6) Import bookmark.
7) copy back and overwrite Qaconfig.dat.
8.) Open New page and refresh screenshots of all quickacess items.
9) Go to webstore and reinstall previous-used extensions.
9) Exit and rerun Maxthon.

These procedures are very tedious, so I've given up doing these steps now.

This make Maxthon run normally for a while. But after using Maxthon for a long time, bugs will mostly appear again, e.g. keystroke and mosue action will become not-worked on many webpages. 

Hi scottchu.tw, if that issue happens again, please try to clear the cache then try it again.

Tip   Give
Link to comment
Share on other sites

21 hours ago, BugSir006 said:

Hi scottchu.tw, if that issue happens again, please try to clear the cache then try it again.

It's still there. No matter what I do. The only work-for-a-while way is what I wrote in last reply.

Edited by scottchu.tw
Tip   Give
Link to comment
Share on other sites

22 minutes ago, scottchu.tw said:

It's still there. No matter what I do. The only work-for-a-while way is what I wrote in last reply.

Hi scottchu.tw, are you able to record a video on this issue so we could forward it to the team for further check on it?

Tip   Give
Link to comment
Share on other sites

  • 2 weeks later...

I finally find the main "murderer" that causes the mouse action problem is from this chrome extension: Simple Allow Copy https://chrome.google.com/webstore/detail/simple-allow-copy/aefehdhdciieocakfobpaaolhipkcpgc.

This extension not only cause mouse can't drag and pan around, it also causes mouse can't click on video player progress bar. Please suggest further Maxthon users avoid downloading and using this extension.

Edited by scottchu.tw
  • Like 1
  • Thanks 1
Tip   Give
Link to comment
Share on other sites

1 hour ago, scottchu.tw said:

I finally find the main "murderer" that causes the mouse action problem is from this chrome extension: Simple Allow Copy https://chrome.google.com/webstore/detail/simple-allow-copy/aefehdhdciieocakfobpaaolhipkcpgc.

This extension not only cause mouse can't drag and pan around, it also causes mouse can't click on video player progress bar. Please suggest further Maxthon users avoid downloading and using this extension.

:5884970a7da3a_1:

Tip   Give
Link to comment
Share on other sites

 Share