×

Give a tip

Maxthon still hijacks CTRL+F1 shortcut


Recommended Posts

The shortcut for CTRL+F1 is still being hijacked by maxthon even if not set. I use shortcut CTRL+F1 for snapping screen regions with ShareX. But if i start Maxthon before ShareX it cannot register the shortcut, because Maxthon is blocking the global handler for CTRL+F1 shortcut.

I've reported this issue over a year ago and it is still present in 6.2.0.900.

 

Please fix.

Tip   Give
Link to comment
Share on other sites

6 hours ago, sajphon said:

The shortcut for CTRL+F1 is still being hijacked by maxthon even if not set. I use shortcut CTRL+F1 for snapping screen regions with ShareX. But if i start Maxthon before ShareX it cannot register the shortcut, because Maxthon is blocking the global handler for CTRL+F1 shortcut.

I've reported this issue over a year ago and it is still present in 6.2.0.900.

 

Please fix.

Hi sajphon, you might want to change the shortcut command for snap region in settings so there wouldn't be any clash in the command. 

Tip   Give
Link to comment
Share on other sites

Posted (edited)
1 hour ago, BugSir009 said:

Hi sajphon, you might want to change the shortcut command for snap region in settings so there wouldn't be any clash in the command. 

If you have read what I wrote carefully and/or clicked the link to the last thread i made about it over a year ago you may find out i don't have the CTRL+F1 hotkey actually set in maxthon yet it still hijacks it.

Edited by sajphon
Tip   Give
Link to comment
Share on other sites

52 minutes ago, sajphon said:

If you have read what I wrote carefully and/or clicked the link to the last thread i made about it over a year ago you may find out i don't have the CTRL+F1 hotkey actually set in maxthon yet it still hijacks it.

Hi sajphon, can you show us a screenshot of your shortcut management in settings?

 

image.png

Tip   Give
Link to comment
Share on other sites

Posted (edited)

image.thumb.png.d173c4da82ff7fcdde5f637ccce757f6.png

Here you go..

I have removed all references to CTRl+F1. No other command uses CTRL+F1. I suspect maxthon registers the CTRL+F1 by default because it thinks it might be used. It does the same with CTRL+` even if its not set. Changing snap region and boss key to a different shortcut doesnt help either. Only thing that works is to actualyl close Maxthon then let the other software register the global hotkey for itself and only after that you can start maxthon again.

Edited by sajphon
Tip   Give
Link to comment
Share on other sites

16 hours ago, sajphon said:

image.thumb.png.d173c4da82ff7fcdde5f637ccce757f6.png

Here you go..

I have removed all references to CTRl+F1. No other command uses CTRL+F1. I suspect maxthon registers the CTRL+F1 by default because it thinks it might be used. It does the same with CTRL+` even if its not set. Changing snap region and boss key to a different shortcut doesnt help either. Only thing that works is to actualyl close Maxthon then let the other software register the global hotkey for itself and only after that you can start maxthon again.

Hi sajphon, this issue was fixed in the previous version 6.1.2.2000, and we tried to test it in the latest version 6.2.0.900 but haven't reproduced it. Please try to disable all the extensions and then try this issue again.

Tip   Give
Link to comment
Share on other sites

On 8/16/2022 at 4:50 AM, BugSir006 said:

Hi sajphon, this issue was fixed in the previous version 6.1.2.2000, and we tried to test it in the latest version 6.2.0.900 but haven't reproduced it. Please try to disable all the extensions and then try this issue again.

It still does it. Steps to reproduce:

1. Install ShareX

2. setup CTRL+F1 as a global hotkey in ShareX

3. Close ShareX

4. Start up maxthon without CTRL+F1 set in it.

5. Start up ShareX

sharex.png

Tip   Give
Link to comment
Share on other sites

On 8/19/2022 at 8:04 PM, sajphon said:

It still does it. Steps to reproduce:

1. Install ShareX

2. setup CTRL+F1 as a global hotkey in ShareX

3. Close ShareX

4. Start up maxthon without CTRL+F1 set in it.

5. Start up ShareX

sharex.png

Hi sajphon, did you launch Maxthon 5 or other portable Maxthon 6 browser? 

We tried to test this issue many times but haven't reproduced it, could you please provide a short video of it?

Tip   Give
Link to comment
Share on other sites

5 hours ago, BugSir006 said:

Hi sajphon, did you launch Maxthon 5 or other portable Maxthon 6 browser? 

We tried to test this issue many times but haven't reproduced it, could you please provide a short video of it?

Haven't had MX5 in my pc for few years now and i have never used portable MX versions. Sure, I will make video tomorrow.

  • Thanks 1
Tip   Give
Link to comment
Share on other sites

 Share