×

Give a tip

BROWSER VERSION'S OLD, MOST SITES WON'T ALLOW MAXTHON FOR THIS REASON


Recommended Posts

More and more of the sites I use for banking utilities, etc. won't lt me use maxthon browser to access my account pages. I've been using Maxthon since 2003 and never had any issues but I guess with the advancement of technology they can tell what I am using and will not allow older browser versions which appears to be what Maxthon uses. 

Looks like I am going to need to change browsers to one that is always up to date. It really sucks because I've been using this browser for so long and  never wanted to switch. 

If anyone knows how to overcome the version they/we are using to get past these security checks please let me know.

Thanks,

JM

Tip   Give
Link to comment
Share on other sites

2 hours ago, josephmx2007@yahoo.com said:

More and more of the sites I use for banking utilities, etc. won't lt me use maxthon browser to access my account pages. I've been using Maxthon since 2003 and never had any issues but I guess with the advancement of technology they can tell what I am using and will not allow older browser versions which appears to be what Maxthon uses. 

Looks like I am going to need to change browsers to one that is always up to date. It really sucks because I've been using this browser for so long and  never wanted to switch. 

If anyone knows how to overcome the version they/we are using to get past these security checks please let me know.

Thanks,

JM

Hi josephmx2007, may I check which version of Maxthon are you using? We have just released the latest version: V6.1.2.3000

Tip   Give
Link to comment
Share on other sites

 Share