×

Give a tip

Maxthon 6 still uses MX5 as program ID!


Recommended Posts

I find this problem cause I'm using MX6 and MX5 portable versions on my Win7-64bit PC together. Today I decide to set MX6 as default browser but later when I click a link on my LINE chat window, it still brings up MX5. I open control panel to check default program, I find the program ID is MX5, there's no MX6 (the one named Maxthon Cloud Browser is MX4, I've tried it already). See my 1st and 2nd screenshots. Then, curiously, I open Windows Firewall and check the setting and find the program ID is MX5, too. But go deeper, I find the program path is 'Maxthon 6' (The path is where I put MX6 portable version, so I know it). See my 3rd and 4th screenshots. I believe your developers never come up with this issue since it's really too deep. I would suggest your developers change the program ID to MX6 ( or MX7, 8, ... , etc. in later versions).

1_2021-09-16 10_22_09-Clipboard.png

2_2021-09-16 10_24_16-Clipboard.png

3_2021-09-16 10_28_22-Clipboard.png

4_2021-09-16 10_28_55-Clipboard.png

Edited by scottchu.tw
Tip   Give
Link to comment
Share on other sites

  • scottchu.tw changed the title to Maxthon 6 still uses MX5 as program ID!
On 9/16/2021 at 10:40 AM, scottchu.tw said:

3_2021-09-16 10_28_22-Clipboard.png

4_2021-09-16 10_28_55-Clipboard.png

Hi scottchu.tw, could you let me know how to enter this interface? I tried to open the Windows Firewall and checked the settings but haven't found this interface. 😥

Could you do me a favor to help us to check the specific version number of this folder?

81180778_4_2021-09-1610_28_55-Clipboard.png.f0b9227473630609d1a945c8b145c9fa.png

Tip   Give
Link to comment
Share on other sites

On 9/23/2021 at 6:13 PM, BugSir006 said:

Hi scottchu.tw, could you let me know how to enter this interface? I tried to open the Windows Firewall and checked the settings but haven't found this interface. 😥

Could you do me a favor to help us to check the specific version number of this folder?

81180778_4_2021-09-1610_28_55-Clipboard.png.f0b9227473630609d1a945c8b145c9fa.png

Note:I use Win7 Chinese version, so I'll do my best to translate them to English, the name here might be a bit different from that in English version but the meaning should be same.

1.Open Control Panel>Click Windows Firewall>Click advanced setting on left panel> Click input rule> Find MX5 item> Click properties/contents on right panel and you'll see the interfaces.

2. I always try to update Maxthon 6 to newest one. Currently it is Mx6 6.1.2.2800.

Edited by scottchu.tw
Tip   Give
Link to comment
Share on other sites

I download .3000 and set it as default but it doesn't work. The default is still my MX5 3.1.8. I think I have to delete all MX5 entries in registry and all other entries that has connection with MX5 first cause the FancyAppName is set to MX5. Anyway, this problem doesn't prevent from using Maxthon. You can just skip my question. Thanks a lot for your strong attention.

 

Edited by scottchu.tw
Tip   Give
Link to comment
Share on other sites

On 9/28/2021 at 4:00 AM, scottchu.tw said:

I download .3000 and set it as default but it doesn't work. The default is still my MX5 3.1.8. I think I have to delete all MX5 entries in registry and all other entries that has connection with MX5 first cause the FancyAppName is set to MX5. Anyway, this problem doesn't prevent from using Maxthon. You can just skip my question. Thanks a lot for your strong attention.

 

@scottchu this might apply to you.........If you have Mx5 set to 'Keep Maxthon as default browser' then it will always reinstate itself when reopened. I successfully have Mx5 and Mx6 in use with 6 being the default. Sometimes I have to go into Windows default programs and set Mx6 as default.
Strangely it does not show as Maxthon 6 it is just Maxthon so that is the one to click on.

Tip   Give
Link to comment
Share on other sites

Posted (edited)

Ok, thanks! I'll give it a try. I've thought twice. I believe the main reason is because I always use portable versions. If One happen to use installed version, I think it might have no this issue.

Edited by scottchu.tw
Tip   Give
Link to comment
Share on other sites

Posted (edited)

I finally get things done. The cause is the old Maxthon 4 portable occupies registry items such as Maxthon Cloud Browser. Setting default browser in MX6 can't affect these items. I open regsitry editor and find all items containing Maxthon 4 execution path and replace them with Maxthon 6 execution path, and it's done. Just like that. By the way, I never check 'Keep default browser' option in MX5 from very beginning.  I don't know what does 'Setting default browser' function in MX6 do but it seems that it doesn't or not be able to change anything related in registry. Maybe your developers should double review this function and test portable versions in detail.

 

Edited by scottchu.tw
Tip   Give
Link to comment
Share on other sites

On 10/6/2021 at 4:59 PM, scottchu.tw said:

I finally get things done. The cause is the old Maxthon 4 portable occupies registry items such as Maxthon Cloud Browser. Setting default browser in MX6 can't affect these items. I open regsitry editor and find all items containing Maxthon 4 execution path and replace them with Maxthon 6 execution path, and it's done. Just like that. By the way, I never check 'Keep default browser' option in MX5 from very beginning.  I don't know what does 'Setting default browser' function in MX6 do but it seems that it doesn't or not able to change anything in registry. Maybe your developers should double review this function and test portable versions in detail.

Hi scottchu.tw, thank you for your information! I have forwarded this issue to the dev team. 😊

Tip   Give
Link to comment
Share on other sites

 Share