Maxthon update viciously discarded my browser data

Recommended Posts

I am really upset about this. Yesterday I updated from Maxthon to, and it took a wrecking ball to my data.

It discarded DuckDuckGo search engine completely and imposed Google Search on me as default.

It wiped out most of my collection of add-ons, including all third-party add-ons and most crucially, wiped out Last Session Manager.

It wiped out my configuration of New Tab. It eliminated Wikipedia and LastPass shortcuts and imposed websites of no interest to me.

It killed my History, which I use extensively. That horrifies me.

It killed the saved Last Tabs, where I had many websites for later perusal to determine whether to bookmark them, print them, or discard them. That hurts.

Worst of all, it killed thousands of bookmarks I had saved on Maxthon. And to add insult to injury, it replaced them with a couple of dozen new unwanted bookmarks.

This is appalling! A user shouldn't be subject to this kind of affliction as the price for updating!

I am most interested in help on the latter three items.

I downgraded back to Maxthon

I had a very recent backup of the C:\Documents and Settings\[user]\Application Data\Maxthon5\Users\[Maxthon account name]]\History folder. This folder of course has both the Last Tbs data and the History data. I copied the backup to that folder so as to replace what the update had put there. When I did this, the config.ini file in the C:\Documents and Settings\[user]\Application Data\Maxthon5\Users\[Maxthon account name]]\Config folder indeed showed all my lost Last Tabs once again. Therefore I expected to see them come up on mx://last-visit/ when I reopened the browser. However that page just showed blank space below its headings at the top. "Earlier Session" was of no use. What can I do to get that Last Tabs data to manifest again in my browser itself as well as in the config.ini file?

I went to the extensions store and restored Last Session Manager, but the old sessions data was gone. Where is it kept? How can I restore it?

I don't understand why in spite of the restoration of the History data to the History folder the History entries are still not showing. I did a restoration from backup like this once previously that did restore the History entries. What can I do to restore them now?

Where did my bookmarks go? I thought they were safe in the cloud. I can't imagine using Maxthon without my bookmarks.

I would suggest until Maxthon fixes this mess that nobody update it without first turning on a program like Shadow Defender that can be used to eliminate all changes at system shutdown.

I want to see Maxthon succeed as an independent browser that's not a Chromium clone like untold numbers of browsers or a Firefox clone like a handful. I find Maxthon's History feature to be the best, and I love the Last Tabs page feature; it perfectly suits my browsing style. I do wish Maxthon would make browser data more stable and secure. It's too frequent that Maxthon alters some of my settings. On those other browsers if one makes use of extensions one is assured of never permanently losing session data, and I've never had problems with History getting destroyed on them.

OS: Microsoft Windows XP Home Edition Build 2600 Antivirus: Advanced SystemCare Ultimate Firewall: Windows XP Firewall Ad Blocker: Universal Ad Blocker Default Browser: Maxthon

Link to comment
Share on other sites

Thank you for your response. I am using the installed not portable version.

I think it was an overwrite installation. I installed the program to an external hard drive which has a lot more space than my system drive. (I've been doing that for ages.) As I indicated above, the Application Data folder is on my system C drive. I might have reinstalled to a folder that was empty because of my deletion of the 5.7.3 subfolders. I can't check on that just right now because explorer.exe is malfunctioning.

Link to comment
Share on other sites

I tried to test in Windows XP and Windows 10 but could not confirm. :(

Did you set the last session as your homepage or open the v5.2.7.2000 then overwrite installation the v5.2.7.3000? Can you reproduce this issue?:Frowning_Face_with_Open_Mouth_Emoji_42x42:

It will be great if you can describe the operating steps in detail or provide a short video. 

Link to comment
Share on other sites

2 hours ago, BugSir006 said:

Hi @conceptualclarity, you created the subfolder when installing the new version every time?

No. Previously Maxthon had installed itself into a folder entitled simply "Maxthon". When I ran the setup file mx5.2.7.3000.exe it chose instead to install into a folder entitled "Maxthon5". After this calamity, I deleted the subfolders mx5.2.7.3000.exe had created in "Maxthon5" and left it as an empty folder. My subsequent reinstallation of chose to install in that empty "Maxthon5", but of course I could have intervened to direct it elsewhere.

2 hours ago, BugSir006 said:

Did you set the last session as your homepage or open the v5.2.7.2000 then overwrite installation the v5.2.7.3000? Can you reproduce this issue?:Frowning_Face_with_Open_Mouth_Emoji_42x42:

I'm pretty sure mx://last-visit/ was not set as my homepage, but the browser was and is configured to open on it rather than on any homepage.

My best recollection of the sequence of events:

I shut down Maxthon and ran mx5.2.7.3000.exe. When it came up it had all these horrible changes.(Seems like if you can't first reproduce that, what follows is a lot less useful to you.)

I might then have tried copying the backup History folder to the C:\Documents and Settings\[user]\Application Data\Maxthon5\Users\[Maxthon account name]]\History folder without succeeding in changing what appeared in the browser.

I deleted the subfolders in "Maxthon5" to get rid of Maxthon as best I could.

I would have again copied the backup folder to the C:\Documents and Settings\[user]\Application Data\Maxthon5\Users\[Maxthon account name]]\History folder to overwrite it. (And by every appearance, that folder has appeared successfully overwritten. See the screenshot of the History data I can no longer get to appear in Maxthon since the disastrous update.)

Then I reinstalled in the emptied "Maxthon5", so I wouldn't describe that as overwriting

I did the copying of the backup to the C:\Documents and Settings\[user]\Application Data\Maxthon5\Users\[Maxthon account name]]\History folder again after going back and ensuring that none of the minor new last tabs data was left, not only crossing/graying it out but hitting reload to wipe it out completely.

One thing I haven't mentioned is I wasn't logged in. Every time I used Maxthon I got some kind of error message saying there was something "abnormal" about the login, but when I responded to that it wanted to shut down the browser, which stinks, frankly. I found that the browser functioned quite well without me responding to those messages. Most of the time when I opened the browser it would show the correct bookmarks on my bookmarks bar. Sometimes the bar would be blank. When that happened, I would right-click on the bookmarks bar and get the context menu, from which I would choose "Set Favorites Bar display folder". When I clicked on that, it always offered me my correct set of bookmarks, and when I clicked on the correct folder, they would load.. That indicated to me that  the browser was operating properly in spite of the "abnormal" message. It appeared the Maxthon cloud was working. Now when I click on that menu it does not offer me my genuine bookmarks, but just the handful that have been imposed on me. I have hopefully enclosed a screenshot of these new imposed bookmarks. I suggest you ask the developers where do these imposed bookmarks come from? Because I didn't choose them. I had thousands of my own bookmarks, so there was no reason to start me from scratch.

About the only data of mine that weren't wiped out by this update were my Downloads record and a lot of my Settings.

I try to log in now on Maxthon using the password that worked on March 6 of this year, according to a note I saved in LastPass. I get the error message "Current account not found(error code10)". i believe that is because after that login on March 6 I chose to change the name of my Maxthon Password account from my old email account obsolete since mid-2015 to my current email account's name. (I was sick and tired of seeing that old email name. Unfortunately that old email name hung around as the name of my account in the Maxthon application data folder.) This botched login message says: "Welcome, [old email account name]" when it should be giving the name I changed it to in March. See screenshot. I don't know how I can force it to stop prompting for the wrong account name instead of the right account name. Can you help on this?

I can try later today to reproduce the issues by creating a new tabs session and new bookmarks, then updating again and seeing if it again destroys my data . That wouldn't be a great comparison, because it would be a small amount of data versus a large amount of data previously.

One more thing: I am wanting to make a bug report on this to Maxthon. I copied and pasted from my original post above, and trimmed it, but I can't submit it. It says:


! Please fill in your bug report (Less than 1000 words)

According to Jarte word processor the message I'm trying to send is under 400 words. Is this thing trying to limit me to <1000 characters rather than <1000 words?



imposed Maxthon favorites.png

Maxthon login mess.png

History folder.png

Link to comment
Share on other sites

Thank you again for taking up my concerns. I think it would be a good idea for me to try to reproduce the debacle. Maybe I can do a video. It would be a pretty long video or set of videos. I probably can't get this done till 2 or 3 days.

I hope you are bringing this to the attention of the developers. As I said, it's disturbing to me that Maxthon was ready to go with a particular set of two dozen bookmarks to substitute for the ones of mine it wiped out. I would expect a wipeout to just leave me with no bookmarks beyond the very few that Maxthon had already given me previously.

Please help me with getting a bug report. I was able now to enter a very short bug report about the fact that my last two bug reports would not go through. The one that won't go through now, concerning the matters of this thread, is significantly longer than the one that just went through, but it is under 400 words, far short of 1000 words.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.