Archived

This topic is now archived and is closed to further replies.

30492798

American Express gives 'cannot connect to internet' error messsage

Recommended Posts

Hi I just had a long and lengthy discussion with one of American Express's Indian tech reps that said that Maxthon (which is the least popular browser, you would do better to use Chrome) is considered by AMEX to be unsafe and there fore give the error message "cannot connect to the internet....  Error code 502 (Bad Gateway)" And sure enough when I use IE it connects with no problem and I can pay my CC. By the way he was very condescending in his 'superior' technical knowledge and kept on talking over me... a thoughly unpleasant tech call.

I asked him why AMEX did not post a message to the effect of please 'please use another browser'. The 502 error message is totally misleading.

Any help so that I don't have to use IE?

Share this post


Link to post
Share on other sites
4 hours ago, 30492798 said:

Hi I just had a long and lengthy discussion with one of American Express's Indian tech reps that said that Maxthon (which is the least popular browser, you would do better to use Chrome) is considered by AMEX to be unsafe and there fore give the error message "cannot connect to the internet....  Error code 502 (Bad Gateway)" And sure enough when I use IE it connects with no problem and I can pay my CC. By the way he was very condescending in his 'superior' technical knowledge and kept on talking over me... a thoughly unpleasant tech call.

I asked him why AMEX did not post a message to the effect of please 'please use another browser'. The 502 error message is totally misleading.

Any help so that I don't have to use IE?

I have been using Maxthon for my American Express account activities for many years and have never received any "unsafe" messages from American Express.  A 502 error code (Bad Gateway) is a server problem, not a software problem.

Share this post


Link to post
Share on other sites

So have I been using Maxthon to pay my bills with AMEX, but Sunday was the first time the 502 came up and then again last night. So I called AMEX and that was their explaination. Have you tried connecting lately?

@ 7twenty - Yes main page works fine, the problem is after the login, after entering SN and PWD and cliking continue.

Share this post


Link to post
Share on other sites
2 hours ago, 30492798 said:

So have I been using Maxthon to pay my bills with AMEX, but Sunday was the first time the 502 came up and then again last night. So I called AMEX and that was their explaination. Have you tried connecting lately?

@ 7twenty - Yes main page works fine, the problem is after the login, after entering SN and PWD and cliking continue.

Aha, apparently I paid my American Express bill before the last internal build of 5.1.3.200 last Thursday because I just now checked and I do get the same as you.  Should have checked before posting.  Sorry.

Share this post


Link to post
Share on other sites

My build is 5.1.1.1000 so I'm not sure it is Maxthon. I experienced this kind of problem with other websites so that when I log in I get a 'you need to update your brower', I found a workaround for Chase here, but there are still some where I need to use an alternate. Is that what we will have to do with AMEX?

Share this post


Link to post
Share on other sites