×

Give a tip

Twitter videos and twitch streams won't play


Recommended Posts

This has been happening for months and I've simply been using chrome whenever I want to watch a stream/twitter video but it's getting so annoying at this point I might completely change browsers if I can't find a solution.  

In short, twitter videos won't ever play (GIFs will,) and will display a message saying "The media could not be played." On top of that, every single twitch stream never starts playing, and the little circle keeps spinning forever. As I said as soon as I change browsers those problems disappear.

I'd really appreciate some help.

Tip   Give
Link to comment
Share on other sites

Just now, Skyleft said:

v5.0.4.3000

However it says that my browser is up to date and I've tried downloading the latest version a couple times and it keeps happening.

Have you tried the version I mentioned?  I just watched a few minutes of a video on Twitch and as I said, had no problem.

1 minute ago, Skyleft said:

v5.0.4.3000

However it says that my browser is up to date and I've tried downloading the latest version a couple times and it keeps happening.

Have you tried the version I mentioned?  I just watched a few minutes of a video on Twitch and as I said, had no problem.  Here's the link to the version I'm using.  http://forum.maxthon.com/applications/core/interface/file/attachment.php?id=17977

post3dmg4_zps398d3651.jpgWindows 10 64-bit build 10525/Windows 10 Mobile build 10512

Tip   Give
Link to comment
Share on other sites

  • 2 weeks later...
8 hours ago, BelieverZ said:

even update my maxthon. 

To what version?

8 hours ago, BelieverZ said:

 Twitter vidoes don't play, twitch livestreams don't play only the said broadcaster videos load.

Can you link to some videos that don't work for you so others can check.

Tip   Give
Link to comment
Share on other sites

51 minutes ago, DeStilleGast said:

So I got this problem too with live streams and video's, example: https://www.twitch.tv/videos/156163214

I don't get an issue playing it. Not sure if things change with live streams.

Also, my testing is without logging into twitch. It could be only an issue that shows when logged in.

Try without logging in and see if the same happens.

Tip   Give
Link to comment
Share on other sites

10 hours ago, DeStilleGast said:

current a live stream, not working as logged in or logged out: https://www.twitch.tv/sethbling

side note, I cannot make the window's any smaller, even if there are no buttons next to the url bar)

You have ABP turned on, turn it off. I had no issue viewing your twitch link, although it was not live. I have ABP turned off.

11 hours ago, DeStilleGast said:

So I got this problem too with live streams and video's, example: https://www.twitch.tv/videos/156163214

and I think that this is the problem: some more scrolling downwards)

I have tried bettertv with userscript, didnt work either (same error)

No issue with stream or dev tools with apb turned off.

Edit: There are issues shown in console but don't appear to be related to the stream.

Tip   Give
Link to comment
Share on other sites

Twitter Media will not play and has not for a very long time when using Maxthon .. I do not want a newer version of Mx so do not want to hear to change the browser. Seems like Mx could surely do something to fix this. I am using Windows 7 but it did the same thing  on my Windows 8 .. the media plays fine on the other browsers .. just not Maxthon :( I disabled the adblock extension  and that did not help. I disabled the  HTML 5 YT extension and that likewise did not help .. I like Maxthon and will continue to use it w/o twitter media playing .. but would be nice if Mx would check it out and FIX this :(

Tip   Give
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.