Major issue with Maxthon 5 and 4.9.300 and 4.9.200 HELP PLEASE READ!


Recommended Posts



Greeting Maxthon Community.  Its been a long time since I needed to sign in about any information or help. But as Of Today I was running Maxthong 4.9.200 like I have been for MONTHS and Months..

I LOVE MAXTHON!! ITs my GOTO browser.  Well I updated the Flash , thinking maybe that would help with the 2 issues im having but it has not.. I have Maxthon on my DELL PC desktop and my Laptop, 

The issue that just started out the blue overnight is 

1. On the 1st startup page where it shows all your fav Tiles, News Temp etc, Below tword the Bottom it had a BUNCH of broken Links to Images.


2. and MAJOR ISSUE... Everytime I would try to go to one of my websites that I have as a FAV saved to the tile section it would Throw up a POP UP saying 

Invalid certificate

This site's certificate has expired or has been issued for a different website's address.
This problem may indicate an attempt to intercept the data between you and a remote serv


It also shows this at the bottom of the Maxthon startup main screen.. 

I hated to uninstall my Maxthon browser and restart to see if it would hlp because I knew I would loose all my Passwords and the sites with Auto fill, along with all my sites saved to My tiles..


Well I did it anyway in hopes, I tried re installing the same version and it keeps saying the same thing, I am going to provide u a screen shot of the popup issue as well..

  I then tried Installing the newer 4.9 version and NO GO still..   So now even though I really did not want to use Max5 yet Went ahead and Installed it.. SAME ISSUE..


On my LAPTOP I am running 4.9.200 and have NO ISSUE AT ALL, AND IT runs great!!    What in the world can be causing this?? I have a great antivirus (Bitdefender) So I dont  think I am infected with anything , I have run scans, etc and ABOUT 6 days ago Bitdefender Showed it blocked a few dangerous Sites that I guess were no good , I was doing surveys for Points on a site called LISTIA.wHICH has been around 6+years..


I even went to use my Chrome browser and it was telling me on a page UNSECURED CONNECTION, WHICH i dont get , My internet is PW protected to the fullest and has plenty of antivirus,firewall and Internet security Software.  


So I truly do not understand whats going on and im hoping SOMEONE here can shred somelight on what I can do to fix this issue. My Desktop is a little bit older but still in great shape Inernal and out.

Its a dell, AND I want at this point to just try and restore it to FACTORY settings but cant find out how, I even have a WIN7 HOME 64BIT disc I was sent with my Elitebook awhile back and it wont seem to take it to restore/restart WIN 7 FROM scratch..


Please help or Give advice on what the reason behind this is, It does it to every site I try to Visit on my PC at this point and again it just started today. NOTHING new has been added at all. Last night after Midnight it worked Great..Then out the Blue The certificates issue has become a problem..




Thank you..

Certificate issues.JPG

Issue s wth certificate.JPG

Pics of Issue.JPG

Link to comment
Share on other sites

I only had an issue with the walmart site. Is it accessible with other browsers? I wasn't able to.

Did you update flash on your laptop? Maybe revert to previous version of flash. I know the latest flash versions don't work on xp. You might also check both your user agent and that you are using standard rendering mode in advanced settings.

Check that you are using IE proxy settings.


Link to comment
Share on other sites

8 hours ago, dlaw74 said:

I even went to use my Chrome browser and it was telling me on a page UNSECURED CONNECTION, WHICH i dont get ,

A little confused by this? So Chrome is getting errors as well? or not?

As ody noted above, check the date/time on your system.

Clear cache.

Link to comment
Share on other sites

  • 3 weeks later...

I fixed the error. I'm not sure exactly what was causing the issue, but I did all the above mention and No luck. So since I didnt have much on these Laptop I just Factory reset and after redowloading Maxthon browser it Works fine now.


Cant Pinpoint the issue as I said but it was very annoying. Sorry for the Late reply back about this issue.


Thanks for the help and Input. 

O btw I dont think Any of the above mention was a issue, I thought at first it may have been due to Flash as PHYR had mention but it was not. I'm on WIN7 not winXP btw. I saw PHYR mention something about XP. 


Everything is good to go now though. No clue what caused this..


Any one else? Important thing is its fixed. Actually PC is running allot better since the system restore.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.