Issue report: Maxthon 5 not appearing in the system's browser list


Qua

Recommended Posts

I am using Windows 10 and I found Maxthon 5 simply does not appear in my system's browser list as you can see below:

Image 3.png

And as a result 'Set as default browser' button in the menu is not working - after clicking it and choosing to allow the browser to make changes to the device, the system's default web browser becomes empty.

I have tried reinstall Maxthon 5 but it's still not showing up in the list.

And since the default browser function is not working I have to turn off the 'Keep Maxthon as the default browser' setting to avoid that annoying user account control notification.

Anyway thank you for your guy's work and hope this issue will be fixed soon.

Regards

Link to post
Share on other sites
  • 2 weeks later...

Hi Qua, thanks for reporting and your encouragement.

May I ask which Maxthon version are your using?

Look forward to your reply and then I'll let our test team to test this issue on their Win10 device. 

Wish you a nice day, dear. (Smily face:1f60a:)

Link to post
Share on other sites

I am facing much the same issue after this week's large Windows 10 update.

I'm running v5.0.1.1200. I've tried manually setting M5 as the default browser within Windows Settings but it does not save the setting; likewise the 'Set as default browser' option in Maxthon's menu doesn't work.

Everything is opening in Edge by default! Save me!

Link to post
Share on other sites
20 hours ago, QIK5L said:

Maxthon appeared in the default browser list after a restart for me after I upgraded to the anniversary update on both of my computers.

It appears in my list, but won't set.

Then again, I just tried to set Chrome as the default and that doesn't seem to actually set, either.

Link to post
Share on other sites
On Monday, September 12, 2016 at 5:41 PM, Qua said:

I am using Windows 10 and I found Maxthon 5 simply does not appear in my system's browser list as you can see below:

Image 3.png

Have you tried this method? It works for me well.

Set your default programs             Win10.2.png

     For Edge you have to deselect Win10.3.png

Link to post
Share on other sites
On 9/22/2016 at 3:48 AM, BugSir006 said:

Hi Qua, thanks for reporting and your encouragement.

May I ask which Maxthon version are your using?

Look forward to your reply and then I'll let our test team to test this issue on their Win10 device. 

Wish you a nice day, dear. (Smily face:1f60a:)

I am using MX5 v5.0.1.1200, and it seems this issue happened after some Windows 10 updates. (don't remember which one specifically)

Anyway as far as I know some apps don't have this problem in the latest Windows 10 such like Potplayer, which can choose file association during/after setup and won't get reset by the system, and it also appears in the default app list. So I think maybe it can be a good sample for your guys to figure out the solution.

Regards

Link to post
Share on other sites
On Friday, September 23, 2016 at 8:43 PM, QIK5L said:

Maxthon appeared in the default browser list after a restart for me after I upgraded to the anniversary update on both of my computers.

I found a temporary solution that should fix these problems. As long as Microsoft will not fix it. Apart from that, there are more interesting articles about Winows 10 :D  http://winaero.com/blog/prevent-windows-10-from-resetting-your-default-apps/    Here, a similar description   http://www.winhelponline.com/blog/edge-hijack-pdf-htm-associations/

Note that this also hides Microsoft Edge in the Open With dialog boxes for the corresponding file types, but still shown in the Default Programs (Classic) listing.

And that's a better way. This can be done using group policies and program Dism. In this way, you can force a permanent setting of default programs.

https://technet.microsoft.com/en-us/itpro/internet-explorer/ie11-deploy-guide/set-the-default-browser-using-group-policy

http://www.tenforums.com/tutorials/8744-default-app-associations-export-import-new-users-windows.html

Link to post
Share on other sites
On 24/09/2016 at 10:09 PM, Galileusz said:

Have you tried this method? It works for me well.

Set your default programs             Win10.2.png

     For Edge you have to deselect Win10.3.png

Thanks for sharing this method. Somehow I'd missed that set of options. After selecting them it's solved the problem for me: Maxthon is the default browser again, and remains so after restart, shut down, and even a further Windows update today.

 

Hopefully the issue does not reoccur.

Link to post
Share on other sites

Hi all, our developers are looking into it now. It seems a problem in Microsoft system, and we are still investigating. So thank you all for posting and discussing. 

Thanks for your patience, we are searching for a solution and will tell you later. 

Wish you all a nice day. :1f61c:

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.