Archived

This topic is now archived and is closed to further replies.

abkoshi

MX5 Beta2 v5.0.1.1200 missing many components

Recommended Posts

Looks like the developers forgot to include certain modules with this release of Mx5 beta2.

- Mouse Gestures
- Shortcuts  (Ctrl-F, Ctrl-S etc)
- Translation
- Snap
- Night Mode

Translation & Night Mode was missing in Beta 1 also. Beta2 was released after a long wait. But the release is disappointing. To find a certain text in the page, now I have to use the mouse. Quick Access is like dumping a folder of shortcuts into the page without proper title or description. There is no advantage in shifting to Mx5 from Mx4.

Share this post


Link to post
Share on other sites

They are all there in latest beta, have you done a clean install of MX5?

- Shortcuts  (Ctrl-F, Ctrl-S etc)

- Translation
- Snap
- Night Mode

Have you enabled them under settings / functions & add-ons?

 

Share this post


Link to post
Share on other sites

Missing most of the good features of Maxthon 4. I fear that you may have wasted your time and resources in making Maxthon 5. Passkeeper and UUMail are not needed and Infobox is unfathomable in my opinion. Maxthon 4 (4.4.1.800) was working fine and the updates just make Maxthon 5 too complicated, why fix something that is not broken? 

Share this post


Link to post
Share on other sites

Qik5l, I use portable Maxthon. I do not prefer to install. In fact, I carry the same browser in most places in a USB drive. If you go to Settings-> Gestures & Shortcuts, I find nothing there and there is no provision to create my own. Translation & snap is also a required feature which I cannot locate now and how do I enable them in Addons? Please help.

 

Share this post


Link to post
Share on other sites

Hi abkoshi, could you provide a screenshot for us?

I'm also using a protable 1200 version, please make sure these functions are enabled in setting-addons.

components .png

Share this post


Link to post
Share on other sites
30 minutes ago, abkoshi said:

 

This is how I get. Is there something wrong with my installation?

 

Try here please

components errors.png

Share this post


Link to post
Share on other sites

yes i have downloaded a new version. Deleted all old ones and it is working fine now. All functions, add-ons, gestures all ok. Thank you very much for your help. 

Share this post


Link to post
Share on other sites