×

Give a tip

Lastest version™


Olgir

Recommended Posts

Well, it started years ago, I just never complained about it. Everytime I check for Maxthon updates, i get the same message. It says that I use the lastest version available, which is not true. So I have to go to the forum and check for updates manually.

2016-02-29_13-44-22.png?dl=0

As you can see on the screenshot (it's in Russian, but rather obvious), suddenly, there is a final version released officially, but not for my Maxthon auto updater. Is this somehow related to that i'm using beta version? No sense in not seeing final versions though. 

 

Just messing with BB codes, screenshot will be here soon...

Tip   Give
Link to comment
Share on other sites

On 2/29/2016, 5:54:18, Olgir said:

Well, it started years ago, I just never complained about it. Everytime I check for Maxthon updates, i get the same message. It says that I use the lastest version available, which is not true. So I have to go to the forum and check for updates manually.

2016-02-29_13-44-22.png?dl=0

As you can see on the screenshot (it's in Russian, but rather obvious), suddenly, there is a final version released officially, but not for my Maxthon auto updater. Is this somehow related to that i'm using beta version? No sense in not seeing final versions though. 

 

Just messing with BB codes, screenshot will be here soon...

You didn't download the right version.  I downloaded from the 4.4.8.1000 post here http://forum.maxthon.com/index.php?/topic/18956-maxthon-browser-for-windows-v4911000-officially-released/&do=findComment&comment=98197.

My About screenshot is this:

About4_4_8_1000_MaxthonSnap2016030514171

 

                                      <<SL>>

 

 

Tip   Give
Link to comment
Share on other sites

Just now, SnowLeopard said:

You didn't download the right version.  I downloaded from the 4.4.8.1000 post here http://forum.maxthon.com/index.php?/topic/18956-maxthon-browser-for-windows-v4911000-officially-released/&do=findComment&comment=98197.

My About screenshot is this:

About4_4_8_1000_MaxthonSnap2016030514171

 

                                      <<SL>>

 

 

Does this mean I do not get updates if I install beta version?

Tip   Give
Link to comment
Share on other sites

1. Auto update never worked. I remember only two times:

  • When I use MX with AdSkiper it will be update to standart MX, Eric Hu solve this issue, so MX with AdSkip has strange number.
  • When MX stopped supporting MX3, all old versions (and old MX4 too) was updated to last MX4.

So if you need it, it does not work. Never. Only with very old versions. 
Or this is the bug of localization. Because when I used MX with AdSkiper, I downloaded it from usa.maxthon.com

2. You really use last version: MX 4.9.1.1000
This is new browser - MX 4.9 (testing version of MX5). 
But MX still support MX 4.4.x and last version is MX 4.4.8.2000.


1. Автообновление действительно никогда не работало. Я вот помню только два случая:

  • Когда я установил MX с AdSkip, он почти сразу предложил обновиться, но обновился до стандартного. Эрик Ху тогда быстро исправил этот косяк, поэтому у MX с AdSkip такая странная версия.
  • Когда MX перестали поддерживать MX3, они принудительно обновили все старые версии (и MX4 тоже) до актуальной.

Так что если тебе нужно обновиться, это не работает. И не работало.  Обновляются только очень старые версии. Как-будто MX считает важными только первые две-три цифры в версии. Ну или это косяк локализации. Потому что MX с AdSkip я качал на usa.maxthon.com

2. Ты действительно используешь последнюю версию: MX 4.9.1.1000
Это новый браузер - MX 4.9 (тестовая версия будущего MX5).
Но MX всё еще поддерживает старую версию MX 4.4.x. Последнее обновление - MX 4.4.8.2000. Скорее всего обновления будут выходить еще пару месяцев после выхода MX5. По крайней мере с MX3 и MX4 было так.

Tip   Give
Link to comment
Share on other sites

2 minutes ago, A.S. said:

You really use last version: MX 4.9.1.1000

Nope, it's 100, not 1000. It's not a problem for me to check for updates manually at the forum. I'm just curious, why auto updater doesn't work. Rather simple to fix, I suppose, but this bug remains for years.

Tip   Give
Link to comment
Share on other sites

19 minutes ago, Olgir said:

Nope, it's 100, not 1000. It's not a problem for me to check for updates manually at the forum. I'm just curious, why auto updater doesn't work. Rather simple to fix, I suppose, but this bug remains for years.

Oh... Yep... 
I used MX from MX2 (2008 or earlier). And update from About never worked. But I think this is the problem of Russian version. 
If we here for serious talk, look in changelog: they optimized update notification in MX 4.4.5.1000.
But I'm sure you never see this notification. This is small bar in bottom right corner, like web-notification on VK. Did anyone see this? I did.

 

Оу... Да...
Я сижу на MX с MX2 (с 2008 или раньше). И обновление в О программе никогда не работало. Но мне казалось, это косяк русской версии.
Коли разговор серьезный, глянь список изменений: они "оптимизировали" уведомления об обновлениях в MX 4.4.5.1000.
Но я уверен, что ты никогда это уведомление не видел. Это такая маленькая плашка в правом нижнем углу, как уведомления в ВК.  Кто-то видел это вообще? Я вот видел.

Tip   Give
Link to comment
Share on other sites

35 minutes ago, SnowLeopard said:

You didn't download the right version.  

A... So... When you open About, update works?
Where are you? What language do you use by default? 
Because for me it never worked. On all PC, with Win7 and XP. 
But meny Russian users had problems when MX closed MX3 and every old versions were updated to last MX4. But this is very old versions as 4.4.x or 4.x. 

Tip   Give
Link to comment
Share on other sites

1 hour ago, A.S. said:

A... So... When you open About, update works?
Where are you? What language do you use by default? 
Because for me it never worked. On all PC, with Win7 and XP. 
But meny Russian users had problems when MX closed MX3 and every old versions were updated to last MX4. But this is very old versions as 4.4.x or 4.x. 

You missed the point I was making.  The screenshot I quoted showed 4.9.1.100 but he was talking about 4.9.1.1000 as in my screenshot.

i have never used auto-update and.seeing the messages about it not working kept me from even trying.  The forum is always much more definite.

                    <<SL>>

Tip   Give
Link to comment
Share on other sites

2 hours ago, SnowLeopard said:

The forum is always much more definite.

Indeed it is. But they have the feature there and it should work. Casual users don't want or care to browse forums just to update something when it should be doing it automatically.

Why they still can't get it working properly is the question that needs to be answered.

It's basic maths to do a version check: is this version lower than the version on the server. If yes, download and update. It doesn't get much more simple than that?!

EDIT: Just did a check and update on a test install running 4.4.7.3000. It successfully found and updated to 4.4.8.2000. So it is working?

So this shows that it does work (at least for me), and that what has been said in the past, that only certain versions are added to the update server. So users that check here might see a later release, but it's not one that is on the server yet for whatever reason.

Tip   Give
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.