×

Give a tip

Youtube "Click here to quit fullscreen" issue/bug


hardahmed

Recommended Posts

Maxthon Version: 4.4.8.1000

Problem: Watching any youtube video (embedded or on the main site) in fullscreen causes the top bar "Click here to quit fullscreen F11" notification to appear somewhere on the right center when the notification auto-hides.

No extensions are being used other than the default.

Clean Maxthon browser installed in Windows 10 version 1511 build 10586.71. 

Checked with Chrome browser... no issues. So YouTube's not the issue.

Any fixes? Or should i install version  4.9.0.3000 RC?

maxthon youtube.jpg

Tip   Give
Link to comment
Share on other sites

Another weird issue/bug I found. Check this site http://me.ign.com/en/street-fighter-5/115788/review/street-fighter-5-review?p=2 

Click play on the last video on the page. This is what Im getting when Im going fullscreen. Please see attached image below.

Issue only happens in Maxthon. Works fine on other browsers. 

ignpage.jpg

Tip   Give
Link to comment
Share on other sites

2 hours ago, hardahmed said:

Another weird issue/bug I found. Check this site http://me.ign.com/en/street-fighter-5/115788/review/street-fighter-5-review?p=2 

Click play on the last video on the page. This is what Im getting when Im going fullscreen. Please see attached image below.

Issue only happens in Maxthon. Works fine on other browsers. 

ignpage.jpg

Plays just fine for me in 4.9.0.3000RC

link.png

post3dmg4_zps398d3651.jpgWindows 10 64-bit build 10525/Windows 10 Mobile build 10512

Tip   Give
Link to comment
Share on other sites

3 hours ago, hardahmed said:

Another weird issue/bug I found. Check this site http://me.ign.com/en/street-fighter-5/115788/review/street-fighter-5-review?p=2 

Click play on the last video on the page. This is what Im getting when Im going fullscreen. Please see attached image below.

Issue only happens in Maxthon. Works fine on other browsers. 

ignpage.jpg

The video and full screen mode work fine here in both  4.4.8.1000 and 4.9.0.3000.

You may restart the browser or run a clean install of v4.9.0.3000 RC.

 

Tip   Give
Link to comment
Share on other sites

Firstly i'd like to say thank you for providing all the info you have and what tests were done. If only every user did the same it would make it easier for everyone.

Try the portable version (extract & run) and see if the same happens.

As the others have noted, there are no issues in mx4.9. If you want change to using that is an option.

aahhh, street fighter 5!! If only it was on Xbox one...

Tip   Give
Link to comment
Share on other sites

Thanks for the replies everyone!

I did install version 4.9.3000 RC and checked the same ign page, now this works fine but still has the "notification" issue in fullscreen.

@No.1MaxthonFan  "the video works fine on 4.9.0.3000RC"  please check the last one which is like 5:18mins. This video causes the weird page spilt. 

As 7Twenty requested I downloaded both portable versions 4.4.8.1000 and 4.9.0.3000 and tested. The portables somehow work fine (notification appears in center right and dissapears immediately) Good.

The new issue v4.9.0.3000 RC (Portable or Installer) is now when it maximizes i lose the top title bar of the browser in "Nvidia surround" mode.

Tested in Single Monitor mode: Resolutions 1920X1080 and 1920x1200  - Maximized correctly

Tested in Multi Monitor mode: Triple screen Resolution 5760 X 1200 - Maximized but titlebar not showing correctly.

In Surround mode it should fit to the current monitor if maximised. Works fine in Chrome.

On the center screen when maximised i cant see the title bar, but if i maximize it on the last screen it looks like the following. Could be an Nvidia driver issue but chrome seems to handle it without problems. (Tested on Nvidia driver v361.75 and v361.91).

@7twenty Street fighter 5 PC version still seems incomplete at launch, no arcade mode..!

Btw Maxthon is one of the best browsers I have used so far. Tried every browser out there. Using it since version 2. Especially cause of the drag to search function.

screen.jpg

Tip   Give
Link to comment
Share on other sites

1 hour ago, hardahmed said:

Thanks for the replies everyone!

I did install version 4.9.3000 RC and checked the same ign page, now this works fine but still has the "notification" issue in fullscreen.

@No.1MaxthonFan  "the video works fine on 4.9.0.3000RC"  please check the last one which is like 5:18mins. This video causes the weird page spilt. 

As 7Twenty requested I downloaded both portable versions 4.4.8.1000 and 4.9.0.3000 and tested. The portables somehow work fine (notification appears in center right and dissapears immediately) Good.

The new issue v4.9.0.3000 RC (Portable or Installer) is now when it maximizes i lose the top title bar of the browser in "Nvidia surround" mode.

Tested in Single Monitor mode: Resolutions 1920X1080 and 1920x1200  - Maximized correctly

Tested in Multi Monitor mode: Triple screen Resolution 5760 X 1200 - Maximized but titlebar not showing correctly.

In Surround mode it should fit to the current monitor if maximised. Works fine in Chrome.

On the center screen when maximised i cant see the title bar, but if i maximize it on the last screen it looks like the following. Could be an Nvidia driver issue but chrome seems to handle it without problems. (Tested on Nvidia driver v361.75 and v361.91).

@7twenty Street fighter 5 PC version still seems incomplete at launch, no arcade mode..!

Btw Maxthon is one of the best browsers I have used so far. Tried every browser out there. Using it since version 2. Especially cause of the drag to search function.

screen.jpg

Maxthon is playing the vids with flash, chrome is using html5.

Mx4.9 uses an older flash version, 15.x.x.x. You can update to your default flash player by copying pepflashplayerxx.xx.x.x.xxx.dll from here: C:\Windows\SysWOW64\Macromed\Flash and place it into C:\Program Files (x86)\Maxthon\Core\Blink\plugins after deleting the old file in the folder. Rename it to pepflashplayer.dll. (this should fix the upper title bar issue.)

 

Tip   Give
Link to comment
Share on other sites

I could not find a pepflashplayer in the SysWOW64 path. I found one in "C:\Program Files (x86)\Google\Chrome\Application\48.0.2564.109\PepperFlash"

I replaced the pepflashplayer.dll in the Maxthon folder only to find Maxthon played the above video using HTML5 even on youtube.
Good thing is my flash player is now newer v20.0.0.306. But the issue still remains.  Whats the solution? Any way to make Maxthon play all videos in Flash instead of HTML5? It would also help the Video float bar as it does not work with HTML5 videos.

Tip   Give
Link to comment
Share on other sites

On 2/16/2016, 4:03:31, hardahmed said:

I could not find a pepflashplayer in the SysWOW64 path. I found one in "C:\Program Files (x86)\Google\Chrome\Application\48.0.2564.109\PepperFlash"

I replaced the pepflashplayer.dll in the Maxthon folder only to find Maxthon played the above video using HTML5 even on youtube.
Good thing is my flash player is now newer v20.0.0.306. But the issue still remains.  Whats the solution? Any way to make Maxthon play all videos in Flash instead of HTML5? It would also help the Video float bar as it does not work with HTML5 videos.

Try C:\Windows\SysWOW64\Macromed\Flash\ next time.  You found another place,  but not everyone has Chrome installed.

I use YouTube Center to control what player runs among the many other features it offers.

                        <<SL>>

Tip   Give
Link to comment
Share on other sites

On 2/17/2016 5:03:31, hardahmed said:

I could not find a pepflashplayer in the SysWOW64 path. I found one in "C:\Program Files (x86)\Google\Chrome\Application\48.0.2564.109\PepperFlash"

I replaced the pepflashplayer.dll in the Maxthon folder only to find Maxthon played the above video using HTML5 even on youtube.
Good thing is my flash player is now newer v20.0.0.306. But the issue still remains.  Whats the solution? Any way to make Maxthon play all videos in Flash instead of HTML5? It would also help the Video float bar as it does not work with HTML5 videos.

May we know the link to the youtube video you tested with? We will test on Nvidia driver to see if we can reproduce this problem.

Tip   Give
Link to comment
Share on other sites

Its not a specific youtube video, but Its on every video which uses html5.

For example: See this link used to test: https://www.youtube.com/watch?v=RWgQmpzdqpc 

Files attached below shows the "fullscreen" notification and Maximize issue.

  • In the first video "maxthon_maximize.mp4" you can see the moment I maximize maxthon it fills the screen in center while losing the top bar. Until I restore the window, the buttons on top are missing (actually there in the far right but somehow doesnt show" . Then i go fullscreen in any youtube video and press "esc" you can now see where the top bars "min, max, close" buttons appear in the far right. 
     
  • In the second video "youtube_notification.mp4" you can see exactly what I mean when playing fullscreen and the notification bar's issue.

Tried both versions 4.4.8.1000 and 4.9.0.3000 in Windows 10 x64.

Nvidia Driver version: v361.91

3X Screen each resolution 1920x1200 set as Nvidia surround. (Windows sees it as a single Monitor with 5760 X 1200 resolution) :)

Temporary solutions I tried: Used "Youtube Center Extension" to force youtube to play in flash rather than html5. Notification issue is gone.

Could it be an issue with the Nvidia driver incompatibility with Maxthon?.
Other browsers work fine without any issues. Some Adobe apps like Photoshop CC also gave that loosing title bar buttons issue. Looking for permanent solution.

Thanks

maxthon_maximize.mp4

youtube_notification.mp4

Tip   Give
Link to comment
Share on other sites

Hi everyone, I Tried the using the new v4.9.1.100 beta version too, still same issue with video. Found the fault/bug yet?

New bug or semicolons not supported?... Drag to search with semicolon trys to open in windows asking for a defined app.  See below.

mania: test

Highlight the above line of text and drag. 

Tip   Give
Link to comment
Share on other sites

7 hours ago, hardahmed said:

Hi everyone, I Tried the using the new v4.9.1.100 beta version too, still same issue with video. Found the fault/bug yet?

New bug or semicolons not supported?... Drag to search with semicolon trys to open in windows asking for a defined app.  See below.

mania: test

Highlight the above line of text and drag. 

Hi again,

We tried many times without reproducing this problem. The" click here to quit full screen" notification always displays in normal position( center top of the the screen)

Drag to search issue has been resolved in our internal version. Please wait patiently.

Tip   Give
Link to comment
Share on other sites

5 hours ago, BugSir007 said:

We tried many times without reproducing this problem. The" click here to quit full screen" notification always displays in normal position( center top of the the screen)

Has it been tested on a system with multiple monitors, preferably with nVidia gfx? Seems it might be related to having more than one monitor and MX getting confused or somethign?

Tip   Give
Link to comment
Share on other sites

I've discovered a new way to verify the issue:

If you use Mxsnap to capture a near fullscreen snap on a monitor where Nvidia Control Panel( Display> Adjust desktop size and position) has been used to adjust the size of the desktop, Mxzsnap doesn't recognize the proper size being displayed and places the Mxsnap tool bar outside the image. This does not happen on a monitor that isn't resized by Nvidia.

MxSnap on Nvidia resized monitor

Clipboard08.jpg

MxSnap Non Nvidia resized Monitor

Clipboard10.jpg

Tip   Give
Link to comment
Share on other sites

13 hours ago, 7twenty said:

Has it been tested on a system with multiple monitors, preferably with nVidia gfx? Seems it might be related to having more than one monitor and MX getting confused or somethign?

The test was not conducted on a system with multiple monitors though, but we tried with Nvidia driver and nothing happened. We do not have a Triple screen Resolution 5760 X 1200 to test this problem at the moment, but i have notified our test team to look into this problem again.

 

Tip   Give
Link to comment
Share on other sites

3 hours ago, BugSir007 said:

The test was not conducted on a system with multiple monitors though, but we tried with Nvidia driver and nothing happened. We do not have a Triple screen Resolution 5760 X 1200 to test this problem at the moment, but i have notified our test team to look into this problem again.

 

Hope my previous post is helpful with regards to multiple monitors

I started the above response to bugsir but never posted it. This is what appears when trying to quote 7twenty.

@7twenty: The OP's vids are using mp4 codec which won't play in either html5 or flash player. So how did you view this:

On 2/18/2016, 6:44:10, hardahmed said:

 

Tip   Give
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.