Always has no retro mode button in Maxthon Cloud for Windows

Recommended Posts

2 minutes ago, said:

I'm using Maxthon Cloud portable both at home and office. But at my office, Maxthon Cloud doesn't show retro mode button no matter what url I opens. Does anyone has same experience?

did you enable it in view ?




Link to comment
Share on other sites


This topic is now archived and is closed to further replies.